[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Uploaded perl 5.004.04-2 (source i386) to master



-----BEGIN PGP SIGNED MESSAGE-----

I've uploaded the latest maintenance release of Perl to master.  There
are two changes in this version of the Debian Perl package.
1. Due to an excellent suggestion by Scott Ellis <storm@stormcrow.ml.org>, 
   packages with Perl extensions (XS stuff) will no longer need to be
   re-packaged with every maintenance release.  If developers with those 
   packages (I've cc'ed you on this post) build with this Perl package,
   you won't need to do so again due to a new maintenance release.
2. There is now a perl-base essential, base package.  This is *not*
   replaced by perl, it is supplemented by perl now.  perl-5.004.04-1
   was a test release to make sure that I get this at least mostly
   correct.  Some problems were found and this is therefore
   perl-5.004.04-2.

As always this is available at ftp://ftp.debian.org/pub/debian/perl* as
well.

Darren

Format: 1.5
Date: Fri, 28 Nov 1997 22:27:45 -0800
Source: perl
Binary: perl-suid perl-debug perl-base perl
Architecture: source i386
Version: 5.004.04-2
Distribution: unstable
Urgency: medium
Maintainer: Darren Stalder <torin@daft.com>
Description: 
 perl       - Larry Wall's Practical Extracting and Report Language.
 perl-base  - The Pathologically Eclectic Rubbish Lister
 perl-debug - Allow debugging perl scripts (and perl).
 perl-suid  - Runs setuid perl scripts.
Changes: 
 perl (5.004.04-2) unstable; urgency=medium
 .
   * Wonderful idea from Scott Ellis <storm@stormcrow.ml.org>, set archlib
     to be the major version so that maintenance versions don't break all
     the arch-dependent perl-debian packages.
   * Strip a2p, fixing Bug #14891.
   * Files copied by make.base should keep hard-links.
 .
 perl (5.004.04-1) unstable; urgency=low
 .
   * New upstream (maintenance) version
   * Turn off Perl 5.003 compatibility since this is the libc6
     version. (should've been done last version)
   * All tests finally pass now that locale test #102 was considered not
     important for Perl.
   * First attempt to get perl-base -really- working.  (As opposed to what
     I did in 5.003.07).
Files: 
 3bb017b9f73797a735bac8b5b2af07c0 651 interpreters - perl_5.004.04-2.dsc
 c6ab953abfef97ad818a20b7a275232d 2581713 interpreters - perl_5.004.04.orig.tar.gz
 1b04b67d1330618172dceeaf75b69e45 25220 interpreters - perl_5.004.04-2.diff.gz
 5991a5ede890d2b813b89fadd9d62f69 3041628 interpreters Important perl_5.004.04-2_i386.deb
 05787256c9110cb785cb8a649d3e8e96 477062 base required perl-base_5.004.04-2_i386.deb
 ccba91dce621f2efba8395b905ee2e3c 235496 interpreters Standard perl-suid_5.004.04-2_i386.deb
 50284994a2dd9af23870fb6d294b833a 1329840 interpreters Optional perl-debug_5.004.04-2_i386.deb

- -- 
<torin@daft.com> <http://www.daft.com/~torin> <torin@debian.org> <torin@io.com>
Darren Stalder/2608 Second Ave, @282/Seattle, WA 98121-1212/USA/+1-800-921-4996
@ Sysadmin, webweaver, postmaster for hire.  C/Perl/CGI programmer and tutor. @
@		     Make a little hot-tub in your soul.		      @

-----BEGIN PGP SIGNATURE-----
Version: 2.6.3
Charset: noconv
Comment: Processed by Mailcrypt 3.4, an Emacs/PGP interface

iQCVAwUBNICbk44wrq++1Ls5AQEzJgP+OkD82Fj7+9frvFeknu+hGsfhPFIA+Y8z
/NS5svcmW3PVK/VTohXpIhaKKNkdD4NOgS7DWkj7fDI6cqFh9KWgj38X6oq6016k
4DvKlbTJL4m4p7To4lV9NR0vIgvhrAAUm6tY94UAkNEra8lMa9CqffNiiHs5WQ0F
nJKbpdSdrq8=
=9+5j
-----END PGP SIGNATURE-----


--
TO UNSUBSCRIBE FROM THIS MAILING LIST: e-mail the word "unsubscribe" to
debian-devel-changes-request@lists.debian.org . 
Trouble?  e-mail to templin@bucknell.edu .


Reply to: