[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Preparation of Debian GNU/Linux 2.2r4



The entire section on kernels and pcmcia-cs needs to be reworked and
reconsidered.  I may skip them entirely.  What you read below is a
left-over from a couple of months ago, it's not up-to-date.

Regards,

	Joey

Preparation of Debian GNU/Linux 2.2r4
=====================================

Up-to-date version on http://master.debian.org/~joey/2.2r4/

I'm currently preparing 2.2r4 and will send reports so people can
actually comment on it.  The plan is to get it out within this month.
I'm sortof responsible for this release, however Anthony Towns or
James Troup have to give the final approval for each package.  I,
however, can and will try to make his work as easy as possible in the
hope to get the next release out real soon now.

My requirements for packages to go into stable:

 1. The package fixes a security problem.  Quite helpful would be an
    advisory issued by the Security Team already.

 2. The package fixes a critical bug which can lead into data loss,
    data corruption or an overly broken system.

 3. The stable version of the package is not installable at all due to
    broken or unmet dependencies or broken installation scripts

 4. The package gets all architectures in stable in sync.

 5. All released architectures have to be in sync.

Packages that I will most probably reject:

  . Package that fixes non-critical bugs

  . Misplaced uploads, i.e. packages that were uploaded to 'stable unstable'

  . Packages for which its binary packages  are out of sync wrt. our
    different architectures.

Accepted packages
-----------------

These packages should make it into stable.

apache      stable    1.3.9-13.2  alpha, arm, i386, m68k, powerpc, sparc
apache      testing   1.3.19-1    alpha, arm, i386, m68k, powerpc, sparc
apache      unstable  1.3.19-1    hurd-i386
apache      unstable  1.3.20-1.1  alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sh, sparc
apache      updates   1.3.9-14    alpha, arm, i386, m68k, powerpc, sparc

install apache_1.3.9-14_alpha.changes
install apache_1.3.9-14_arm.changes
install apache_1.3.9-14_i386.changes
install apache_1.3.9-14_m68k.changes
install apache_1.3.9-14_powerpc.changes
install apache_1.3.9-14_sparc.changes

	* Non-maintainer upload on behalf of Simon Huggins <huggie@earth.li>
	* Applied patch from Martin Kraemer to fix mod_negotiation bug to prevent
	  revealing of directory contents.

	This looks like a half security update, right?

empty

boot-floppies_2.2.24_i386.changes
boot-floppies_2.2.25_arm.changes
boot-floppies_2.2.25_i386.changes
boot-floppies_2.2.26_i386.changes

	2.2.25: Important ARM fixes

	2.2.26: Important PowerPC fixes

	Not sure if we should demand architectures to be in sync...

cfingerd    updates   1.4.1-1.2    alpha, arm, i386, m68k, powerpc, sparc

install cfingerd_1.4.1-1.1_security.changes
install cfingerd_1.4.1-1.2_security.changes

	Security Update, DSA 049

cron        updates   3.0pl1-57.3  alpha, arm, i386, m68k, powerpc, sparc

install cron_3.0pl1-57.3_all.changes

	Security Update, DSA 054

cslatex     updates   1.2.3       all

install cslatex_1.2.3_i386.changes

	Showstopper, ChangeLog:

	* Grr, really fix the installation stop now (closes: #94346)

	Note from the Editor: Petr, you are a moron...

	Fixed cslatex stops installation (closes: #67214, #69224)

devscripts  updates   2.5.8.2     all

install devscripts_2.5.8.2_i386.changes

	Fix insecure regex's in debian.procmail example filter


comerr-dev    updates   2.0-1.18-3.0potato1  alpha, arm, i386, m68k, powerpc, sparc
e2fslibs-dev  updates   1.18-3.0potato1      alpha, arm, i386, m68k, powerpc, sparc
e2fsprogs     updates   1.18-3.0potato1      alpha, arm, i386, m68k, powerpc, sparc
ss-dev        updates   2.0-1.18-3.0potato1  alpha, arm, i386, m68k, powerpc, sparc
uuid-dev      updates   1.2-1.18-3.0potato1  alpha, arm, i386, m68k, powerpc, sparc

install	e2fsprogs_1.18-3.0potato1_arm.changes
install	e2fsprogs_1.18-3.0potato1_i386.changes
install	e2fsprogs_1.18-3.0potato1_m68k.changes
install	e2fsprogs_1.18-3.0potato1_powerpc.changes
install	e2fsprogs_1.18-3.0potato1_sparc.changes
install	e2fsprogs_1.18-3.0potato1_alpha.changes

	Fix for serial console installs.

eximon      stable    3.12-10     alpha, arm, i386, m68k, powerpc, sparc
eximon      updates   3.12-10.1   alpha, arm, i386, m68k, powerpc, sparc
exim        stable    3.12-10     alpha, arm, i386, m68k, powerpc, sparc
exim        updates   3.12-10.1   alpha, arm, i386, m68k, powerpc, sparc

install exim_3.12-10.1_all.changes

	Fixed format string vulnerability in accept.c.

	DSA 058

exuberant-ctags  stable    1:3.2.4-0.1    alpha, arm, i386, m68k, powerpc, sparc
exuberant-ctags  updates   1:3.2.4-0.1.1  sparc

install exuberant-ctags_3.2.4-0.1.1_sparc.changes

	Rebuilt for sparc, security update otherwise

fetchmail   stable    5.3.3-1.1   alpha, arm, i386, m68k, powerpc, sparc
fetchmail   updates   5.3.3-3     alpha, arm, i386, m68k, powerpc, sparc

install fetchmail_5.3.3-1.2_i386.changes
install fetchmail_5.3.3-2_i386.changes
install fetchmail_5.3.3-2_m68k.changes
install fetchmail_5.3.3-3_i386.changes
install fetchmail_5.3.3-3_m68k.changes
install fetchmail_5.3.3-3_multi.changes

	DSA 060, 071

gftp        updates   2.0.6a-3.1  alpha, arm, i386, m68k, powerpc, sparc

install gftp_2.0.6a-3.1_all.changes

	Security update, DSA 057

glibc-doc     stable    2.1.3-18    all
i18ndata      stable    2.1.3-18    all
libc6-dbg     stable    2.1.3-18    arm, i386, m68k, powerpc, sparc
libc6-dev     stable    2.1.3-18    arm, i386, m68k, powerpc, sparc
libc6-pic     stable    2.1.3-18    arm, i386, m68k, powerpc, sparc
libc6-prof    stable    2.1.3-18    arm, i386, m68k, powerpc, sparc
libc6         stable    2.1.3-18    arm, i386, m68k, powerpc, sparc
locales       stable    2.1.3-18    alpha, arm, i386, m68k, powerpc, sparc
nscd          stable    2.1.3-18    alpha, arm, i386, m68k, powerpc, sparc
glibc-doc     updates   2.1.3-19    all
i18ndata      updates   2.1.3-19    all
libc6-dbg     updates   2.1.3-19    arm, i386, m68k, powerpc, sparc
libc6-dev     updates   2.1.3-19    arm, i386, m68k, powerpc, sparc
libc6-pic     updates   2.1.3-19    arm, i386, m68k, powerpc, sparc
libc6-prof    updates   2.1.3-19    arm, i386, m68k, powerpc, sparc
libc6         updates   2.1.3-19    arm, i386, m68k, powerpc, sparc
locales       updates   2.1.3-19    alpha, arm, i386, m68k, powerpc, sparc
nscd          updates   2.1.3-19    alpha, arm, i386, m68k, powerpc, sparc
libc6.1-dbg   stable    2.1.3-18    alpha
libc6.1-dev   stable    2.1.3-18    alpha
libc6.1-pic   stable    2.1.3-18    alpha
libc6.1-prof  stable    2.1.3-18    alpha
libc6.1       stable    2.1.3-18    alpha
libc6.1       updates   2.1.3-19    alpha
libc6.1-dbg   updates   2.1.3-19    alpha
libc6.1-dev   updates   2.1.3-19    alpha
libc6.1-pic   updates   2.1.3-19    alpha
libc6.1-prof  updates   2.1.3-19    alpha

install glibc_2.1.3-19_alpha.changes
install glibc_2.1.3-19_arm.changes
install glibc_2.1.3-19_i386.changes
install glibc_2.1.3-19_m68k.changes
install glibc_2.1.3-19_powerpc.changes
install glibc_2.1.3-19_sparc.changes

	fts/chdir vulnerability fix.

	No DSA assigned though

gnupg        updates   1.0.6-0potato1             alpha, arm, i386, m68k, powerpc, sparc

install gnupg_1.0.6-0potato1_alpha.changes
install gnupg_1.0.6-0potato1_arm.changes
install gnupg_1.0.6-0potato1_i386.changes
install gnupg_1.0.6-0potato1_m68k.changes
install gnupg_1.0.6-0potato1_powerpc.changes
install gnupg_1.0.6-0potato1_sparc.changes

	Security Update, DSA 061

groff       stable    1.15.2-1    alpha, arm, i386, m68k, powerpc, sparc
groff       updates   1.15.2-2    alpha, arm, i386, m68k, powerpc, sparc

install groff_1.15.2-2_arm.changes
install groff_1.15.2-2_i386.changes
install groff_1.15.2-2_m68k.changes
install groff_1.15.2-2_multi.changes

	* Security upload by new maintainer, backported from unstable.
	* src/preproc/pic/pic.y: Fix format string vulnerability that could allow
	  the -S flag to be disabled (closes: #107459). Patch adapted from one by
	  Zenith Parsec <zen-parse@gmx.net>.

	DSA 072


horde       stable    2:1.2.3-0.potato.4  all
horde       updates   2:1.2.6-0.potato.4  all
imp         stable    2:2.2.3-0.potato.4  all
imp         updates   2:2.2.6-0.potato.3  all

install horde_1.2.6-0.potato.4_i386.changes

	DSA 073, though it mentioned horde 1.2.6-0.potato.1 and imp
	2.2.6-0.potato.1

kernel-headers-2.2.19-compact  updates   2.2.19-4    i386
kernel-headers-2.2.19-idepci   updates   2.2.19-4    i386
kernel-headers-2.2.19-ide      updates   2.2.19-4    i386
kernel-headers-2.2.19          updates   2.2.19-4    i386
kernel-image-2.2.19-compact    updates   2.2.19-4    i386
kernel-image-2.2.19-idepci     updates   2.2.19-4    i386
kernel-image-2.2.19-ide        updates   2.2.19-4    i386
kernel-image-2.2.19            updates   2.2.19-4    i386
kernel-doc-2.2.19              updates   2.2.19-3    all
kernel-source-2.2.19           updates   2.2.19-3    all
kernel-headers-2.2.19          updates   2.2.19-2    m68k
kernel-image-2.2.19-mac        updates   2.2.19-2    m68k
kernel-patch-2.2.19-m68k       updates   2.2.19-2    all
kernel-image-2.2.19-netwinder  updates   20010414    arm
kernel-image-2.2.19-riscpc     updates   20010414    arm
kernel-patch-2.2.19-arm        updates   20010414    all

install-u kernel-image-2.2.19-i386_2.2.19-3_i386.changes
install kernel-image-2.2.19-i386_2.2.19-4_i386.changes
install kernel-source-2.2.19_2.2.19-3_i386.changes
install kernel-headers-2.2.19-m68k_2.2.19-2_m68k.changes
install kernel-image-2.2.19-mac_2.2.19-2_m68k.changes
install kernel-patch-2.2.19-m68k_2.2.19-2_m68k.changes
install kernel-image-2.2.19-netwinder_20010414_arm.changes
install kernel-image-2.2.19-riscpc_20010414_arm.changes
install kernel-patch-2.2.19-arm_20010414_i386.changes

	(i386) 2.2.19-4 - Corrected flavour

	(arm) First version of 2.2.19

	(m68k) First version of 2.2.19

kernel-doc-2.0.36                    stable    2.0.36-3                     all
kernel-headers-2.0.36                stable    2.0.36-3                     i386
kernel-doc-2.2.10                    stable    2.2.10-1                     all
kernel-headers-2.2.10                stable    2.2.10-1                     i386
kernel-headers-2.2.10                stable    19990716                     arm
kernel-doc-2.2.12                    stable    2.2.12-4                     all
kernel-headers-2.2.12                stable    2.2.12-4                     i386
kernel-headers-2.2.12                stable    19991019                     arm
kernel-doc-2.2.13                    stable    2.2.13-2                     all
kernel-headers-2.2.13                stable    2.2.13-2                     i386
kernel-doc-2.2.15                    stable    1:2.2.15-3                   all
kernel-headers-2.2.15                stable    1:2.2.15-2                   alpha, i386
kernel-headers-2.2.15                stable    2.2.16pre4-1                 powerpc
kernel-doc-2.2.17                    stable    2.2.17pre6-1                 all
kernel-headers-2.2.17                stable    2.2.17pre6-1                 i386
kernel-headers-2.2.17                stable    2.2.17pre11-2                powerpc
kernel-doc-2.2.18pre21               stable    2.2.18pre21-1                all
kernel-headers-2.2.18pre21           stable    2.2.18pre21-1                alpha, i386
kernel-headers-2.2.18pre21           stable    2.2.18pre21-2                powerpc
kernel-doc-2.2.18                    stable    2.2.18-1                     all
kernel-doc-2.2.19pre17               stable    2.2.19pre17-1                all
kernel-image-2.2.10-netwinder        stable    19990716                     arm
kernel-image-2.2.12-netwinder        stable    19991019                     arm
kernel-image-2.2.10-amiga            stable    2.2.10-4                     m68k
kernel-image-2.2.10-atari            stable    2.2.10-4                     m68k
kernel-image-2.2.10-bvme6000         stable    2.2.10-8                     m68k
kernel-image-2.2.10-mvme147          stable    2.2.10-8                     m68k
kernel-image-2.2.10-mvme16x          stable    2.2.10-8                     m68k
kernel-image-2.2.15-generic          stable    1:2.2.15-2                   alpha
kernel-image-2.2.15-jensen           stable    1:2.2.15-2                   alpha
kernel-image-2.2.15-nautilus         stable    1:2.2.15-2                   alpha
kernel-image-2.2.15-smp              stable    1:2.2.15-2                   alpha
kernel-image-2.2.15-chrp             stable    2.2.16pre4-1                 powerpc
kernel-image-2.2.15-pmac             stable    2.2.16pre4-1                 powerpc
kernel-image-2.2.15-prep             stable    2.2.16pre4-1                 powerpc
kernel-image-2.2.17-compact          stable    2.2.17pre6-1                 i386
kernel-image-2.2.17-idepci           stable    2.2.17pre6-1                 i386
kernel-image-2.2.17-ide              stable    2.2.17pre6-1                 i386
kernel-image-2.2.17                  stable    2.2.17pre6-1                 i386
kernel-image-2.2.17-chrp             stable    2.2.17pre11-2                powerpc
kernel-image-2.2.17-pmac             stable    2.2.17pre11-2                powerpc
kernel-image-2.2.17-prep             stable    2.2.17pre11-2                powerpc
kernel-image-2.2.18pre21-generic     stable    2.2.18pre21-1                alpha
kernel-image-2.2.18pre21-jensen      stable    2.2.18pre21-1                alpha
kernel-image-2.2.18pre21-nautilus    stable    2.2.18pre21-1                alpha
kernel-image-2.2.18pre21-smp         stable    2.2.18pre21-1                alpha
kernel-image-2.2.18pre21-chrp        stable    2.2.18pre21-2                powerpc
kernel-image-2.2.18pre21-pmac        stable    2.2.18pre21-2                powerpc
kernel-image-2.2.18pre21-prep        stable    2.2.18pre21-2                powerpc
kernel-image-2.2.18pre21-compact     stable    2.2.18pre21-1                i386
kernel-image-2.2.18pre21-idepci      stable    2.2.18pre21-2                i386
kernel-image-2.2.18pre21-ide         stable    2.2.18pre21-1                i386
kernel-image-2.2.18pre21             stable    2.2.18pre21-1                i386
kernel-image-2.2.17-sun4cdm          stable    2                            sparc
kernel-image-2.2.17-sun4dm-pci       stable    2                            sparc
kernel-image-2.2.17-sun4dm-smp       stable    2                            sparc
kernel-image-2.2.17-sun4u-smp        stable    2                            sparc
kernel-image-2.2.17-sun4u            stable    2                            sparc
kernel-image-2.2.18pre21-sun4cdm     stable    3                            sparc
kernel-image-2.2.18pre21-sun4dm-pci  stable    3                            sparc
kernel-image-2.2.18pre21-sun4dm-smp  stable    3                            sparc
kernel-image-2.2.18pre21-sun4u-smp   stable    3                            sparc
kernel-image-2.2.18pre21-sun4u       stable    3                            sparc
kernel-image-2.2.19pre17-chrp        stable    2.2.19pre17-1                powerpc
kernel-image-2.2.19pre17-pmac        stable    2.2.19pre17-1                powerpc
kernel-image-2.2.19pre17-prep        stable    2.2.19pre17-1                powerpc
kernel-source-2.0.36                 stable    2.0.36-3                     all
kernel-source-2.2.10                 stable    2.2.10-1                     all
kernel-source-2.2.12                 stable    2.2.12-4                     all
kernel-source-2.2.13                 stable    2.2.13-2                     all
kernel-source-2.2.15                 stable    1:2.2.15-3                   all
kernel-source-2.2.17                 stable    2.2.17pre6-1                 all
kernel-source-2.2.18pre21            stable    2.2.18pre21-1                all
kernel-source-2.2.18                 stable    2.2.18-1                     all
kernel-source-2.2.19pre17            stable    2.2.19pre17-1                all
kernel-patch-2.2.10-kdb              stable    0.5-2                        i386
kernel-patch-2.2.10-m68k             stable    2.2.10-12                    all
kernel-patch-2.2.10-pc9800           stable    2.2.10.0.002pre.19990627-2   all
kernel-patch-2.2.12-netwinder        stable    19991019                     all
kernel-patch-2.2.15-ide              stable    20000405-1                   all
kernel-patch-2.2.17-ide              stable    20000625-1                   all
kernel-patch-2.2.18pre21-ide         stable    20001118-1                   all
kernel-patch-2.2.19pre17-ide         stable    20001221-1                   all
kernel-patch-2.2.15-powerpc          stable    20000422-2.2.16pre4-1        all
kernel-patch-2.2.17-powerpc          stable    20000714-2.2.17pre11-2       all
kernel-patch-2.2.18pre21-powerpc     stable    20001119-2.2.18pre21-2       all
kernel-patch-2.2.19pre17-powerpc     stable    20010304-2.2.19pre17-1       all

remove all packages from the above list

	I plan to request removal for these kernel headers images,
	patches and source files from the stable distribution.  Please
	drop me a line with a reason if you object.

	2.0.36: There is still 2.0.38 which contains some security fixes.

	2.2.10/i386: There will be 2.2.19-4 in 2.2r4

	2.2.10/arm: There will be 2.2.13/19991215 left over

	2.2.10/m68k: There will be 2.2.17/2.2.17-1 and
	2.2.10/m68k/-mac left over.  This needs to be discussed
	because a) 2.2.10 contained a -mac image which would be pulled
	out of the other 2.2.10 kernels and b) 2.2.17 doesn't contain
	that image anymore.

	2.2.12/i386: There will be 2.2.19-4 in 2.2r4

	2.2.12/arm: There will be 2.2.13/19991215 left over

	2.2.13/i386: There will be 2.2.19-4 in 2.2r4

	2.2.15/i386: There will be 2.2.19-4 in 2.2r4

	2.2.15/powerpc: There will be 2.2.17 left over

	2.2.15/sparc: There will be 2.2.19 left over

	2.2.17/i386: There will be 2.2.19-4 in 2.2r4

	2.2.17/powerpc: There will be 2.2.19 left over

	2.2.17/sparc: There will be 2.2.19 left over

	2.2.18pre21/i386: There will be 2.2.19-4 in 2.2r4

	2.2.18pre21/alpha: There will be 2.2.19 left over

	2.2.18pre21/powerpc: There will be 2.2.19 left over

	2.2.18pre21/sparc: There will be 2.2.19 left over

	2.2.19pre17/i386: There will be 2.2.19-4 in 2.2r4.  These pkgs
	must not be removed since boot-floppies/i386 in potato are
	only buildable with these.

	2.2.19pre17/powerpc: There will be 2.2.19 left over

libpaperg   stable    1.0.3-13          alpha, sparc
libpaperg   stable    1.0.3-13.potato1  arm, i386, m68k, powerpc
libpaperg   updates   1.0.3-13.potato1  alpha, sparc
libpaper    stable    1.0.3-13          sparc
libpaper    stable    1.0.3-13.potato1  i386, m68k
libpaper    updates   1.0.3-13.potato1  sparc

sync-install libpaperg_1.0.3-13.potato1_alpha.changes
sync-install libpaper_1.0.3-13.potato1_sparc.changes

	Broken sync upload.

	If there would be libpaper *and* libpaperg version
	1.0.3-13.potato1 for sparc, I'd be convinced to accept the
	package.

	I have prepared an upload for libpaper *and* libpaperg binary
	packages sitting on auric, waiting for a free path to
	proposed-updates.

	Sparc missing

lyx         stable    1.1.4-3     powerpc
lyx         stable    1.1.4-7     alpha, i386, m68k
lyx         updates   1.1.4-7     powerpc

sync-install lyx_1.1.4-7_powerpc.changes

	Get powerpc back in sync


mac-fdisk   stable    0.1-3           m68k, powerpc
mac-fdisk   updates   0.1-6.0potato1  powerpc
pmac-fdisk  stable    0.1-3           powerpc
pmac-fdisk  updates   0.1-6.0potato1  powerpc

install mac-fdisk_0.1-6.0potato1_powerpc.changes
install mac-fdisk_0.1-6.0potato1_source.changes

	* Feature added: menu option to create bootstrap partition needed for
	  powerpc NewWorld machines with the proper type and size (patch supplied
	  by Ethan Benson). This should help newbies that won't read the docs
	  anyway. Closes: #99660.

	* Bugfix: mac-fdisk used to get the disk size wrong when brute force
	  probing for end-of-disk by seek&read. Turns out gcc did not cope with
	  arithmetics on long long types without explicit cast. Closes: #99700.

	I wonder why there was an m68k version of mac-fdisk.

mailcrypt   stable    3.5.5-6     all
mailcrypt   updates   3.5.5-6.1   all

install mailcrypt_3.5.5-6.1_i386.changes

	* Non-maintainer upload.
	* mc-gpg.el: one character fix to regex so it will parse output from
	  GnuPG >= 1.0.5.

	That's required, since GnuPG 1.0.6 will get into stable (DSA 061)

mailman     stable    1.1-6       alpha, arm, i386, m68k, powerpc, sparc
mailman     updates   1.1-8       alpha, arm, i386, m68k, powerpc, sparc

install mailman_1.1-7_i386.changes
install mailman_1.1-8_i386.changes
install mailman_1.1-8_m68k.changes
install mailman_1.1-8_multi.changes

	* Fix possible (but rare) security problem if site password was blank
	
	* Fix maintainer field
	* Completely fix previous security flaw
	* Fix dedent in Mailman/SecurityManager.py (closes: #107768)

	DSA missing, it seems

man-db      stable    2.3.16-1.1    arm, i386, m68k, powerpc, sparc
man-db      stable    2.3.16-1.1.1  alpha
man-db      updates   2.3.16-4      alpha, arm, i386, m68k, powerpc, sparc

install-u man-db_2.3.16-2_multi.changes
install man-db_2.3.16-3_m68k.changes
install man-db_2.3.16-3_multi.changes
install man-db_2.3.16-4_m68k.changes
install man-db_2.3.16-4_multi.changes

	* Backport another security fix from unstable.
	* Count how many times privileges have been dropped, and don't regain them
	  until regain_effective_privs() is called the same number of times. The
	  lack of nesting meant it was still possible to create files owned by uid
	  man (thanks, Luki R.; closes: #99624).

	Security Update, DSA 056

most        stable    4.9.0-2     alpha, arm, i386, m68k, powerpc, sparc
most        updates   4.9.0-2.1   alpha, arm, i386, m68k, powerpc, sparc

install most_4.9.0-2.1.changes
install most_4.9.0-2.1_i386.changes

	DSA 076

communicator           updates   1:4.77-1    i386
navigator              updates   1:4.77-1    i386
netscape-base-4-libc5  updates   1:4.77-1    i386
netscape-base-4        updates   1:4.77-1    i386
netscape               updates   1:4.77-1    i386
communicator-base-477      updates   4.77-2      i386
communicator-nethelp-477   updates   4.77-2      all
communicator-smotif-477    updates   4.77-2      i386
communicator-spellchk-477  updates   4.77-2      all
navigator-base-477         updates   4.77-2      i386
navigator-nethelp-477      updates   4.77-2      all
navigator-smotif-477       updates   4.77-2      i386
netscape-base-477          updates   4.77-2      i386
netscape-ja-resource-477   updates   4.77-2      all
netscape-java-477          updates   4.77-2      all
netscape-ko-resource-477   updates   4.77-2      all
netscape-smotif-477        updates   4.77-2      i386
netscape-zh-resource-477   updates   4.77-2      all

install-u netscape4.77_4.77-1_i386.changes
install netscape4.77_4.77-2_i386.changes
install netscape4.base_4.77-1_i386.changes
remove communicator-base-472
remove communicator-base-473
remove communicator-base-475
remove communicator-base-476
remove communicator-base-47
remove communicator-nethelp-472
remove communicator-nethelp-473
remove communicator-nethelp-475
remove communicator-nethelp-476
remove communicator-nethelp-47
remove communicator-smotif-472-libc5
remove communicator-smotif-472
remove communicator-smotif-473-libc5
remove communicator-smotif-473
remove communicator-smotif-475-libc5
remove communicator-smotif-475
remove communicator-smotif-476-libc5
remove communicator-smotif-476
remove communicator-smotif-47
remove communicator-spellchk-472
remove communicator-spellchk-473
remove communicator-spellchk-475
remove communicator-spellchk-476
remove communicator-spellchk-47
remove navigator-base-472
remove navigator-base-473
remove navigator-base-475
remove navigator-base-476
remove navigator-base-47
remove navigator-nethelp-472
remove navigator-nethelp-473
remove navigator-nethelp-475
remove navigator-nethelp-476
remove navigator-nethelp-47
remove navigator-smotif-472-libc5
remove navigator-smotif-472
remove navigator-smotif-473-libc5
remove navigator-smotif-473
remove navigator-smotif-475-libc5
remove navigator-smotif-475
remove navigator-smotif-476-libc5
remove navigator-smotif-476
remove navigator-smotif-47
remove netscape-base-472
remove netscape-base-473
remove netscape-base-475
remove netscape-base-476
remove netscape-base-47
remove netscape-ja-resource-475
remove netscape-ja-resource-476
remove netscape-java-472
remove netscape-java-473
remove netscape-java-475
remove netscape-java-476
remove netscape-java-47
remove netscape-ko-resource-475
remove netscape-ko-resource-476
remove netscape-smotif-472-libc5
remove netscape-smotif-472
remove netscape-smotif-473-libc5
remove netscape-smotif-473
remove netscape-smotif-475-libc5
remove netscape-smotif-475
remove netscape-smotif-476-libc5
remove netscape-smotif-476
remove netscape-smotif-47
remove netscape-zh-resource-475
remove netscape-zh-resource-476

	Security Update, DSA 051

ldap-rfc             stable    1:1.2.11-1  all
ldap-rfc             updates   1:1.2.12-1  all
libopenldap-dev      stable    1:1.2.11-1  alpha, arm, i386, m68k, powerpc, sparc
libopenldap-dev      updates   1:1.2.12-1  alpha, arm, i386, m68k, powerpc, sparc
libopenldap-runtime  stable    1:1.2.11-1  all
libopenldap-runtime  updates   1:1.2.12-1  all
libopenldap1         stable    1:1.2.11-1  alpha, arm, i386, m68k, powerpc, sparc
libopenldap1         updates   1:1.2.12-1  alpha, arm, i386, m68k, powerpc, sparc
openldap-gateways    stable    1:1.2.11-1  alpha, arm, i386, m68k, powerpc, sparc
openldap-gateways    updates   1:1.2.12-1  alpha, arm, i386, m68k, powerpc, sparc
openldap-utils       stable    1:1.2.11-1  alpha, arm, i386, m68k, powerpc, sparc
openldap-utils       updates   1:1.2.12-1  alpha, arm, i386, m68k, powerpc, sparc
openldapd            stable    1:1.2.11-1  alpha, arm, i386, m68k, powerpc, sparc
openldapd            updates   1:1.2.12-1  alpha, arm, i386, m68k, powerpc, sparc

install openldap_1.2.12-1_security.changes

	Upstream bug-fix release for security problems

	DSA 068

libreadline2-altdev  stable    2.1-12      sparc
libreadline2-altdev  stable    2.1-20      m68k
libreadline2-altdev  stable    2.1-21      i386
libreadline2-altdev  updates   2.1-21      m68k
libreadline2         stable    2.1-12      sparc
libreadline2         stable    2.1-20      m68k
libreadline2         stable    2.1-21      i386
libreadline2         updates   2.1-21      m68k
libreadlineg2        stable    2.1-17      sparc
libreadlineg2        stable    2.1-19      alpha, arm, powerpc
libreadlineg2        stable    2.1-20      m68k
libreadlineg2        stable    2.1-21      i386
libreadlineg2        updates   2.1-21      alpha, arm, m68k, powerpc, sparc

sync-install readline2_2.1-21_alpha.changes
sync-install readline2_2.1-21_arm.changes
sync-install readline2_2.1-21_m68k.changes
sync-install readline2_2.1-21_sparc.changes
sync-install readline2_2.1-21_powerpc.changes

	Get architectures back in sync

rxvt-ml     stable    1:2.6.2-2    alpha, arm, i386, m68k, powerpc, sparc
rxvt-ml     updates   1:2.6.2-2.1  alpha, arm, i386, m68k, powerpc, sparc
rxvt        stable    1:2.6.2-2    alpha, arm, i386, m68k, powerpc, sparc
rxvt        updates   1:2.6.2-2.1  alpha, arm, i386, m68k, powerpc, sparc

install rxvt_2.6.2-2.1_security.changes

	DSA 062

samba-common  experimental  2.2.0.cvs20010416-1  i386
samba-common  stable        2.0.7-3              alpha, arm, i386, m68k, powerpc, sparc
samba-common  testing       2.0.7-3              alpha, arm, i386, m68k, powerpc, sparc
samba-common  unstable      2.0.7-5              arm, m68k, mips
samba-common  unstable      2.2.0.final-2        alpha, hppa, i386, powerpc, sparc
samba-common  updates       2.0.7-3.3            alpha, arm, i386, m68k, powerpc, sparc
samba-doc     experimental  2.2.0.cvs20010416-1  all
samba-doc     stable        2.0.7-3              all
samba-doc     testing       2.0.7-3              all
samba-doc     unstable      2.2.0.final-2        all
samba-doc     updates       2.0.7-3.3            all
samba         experimental  2.2.0.cvs20010416-1  i386
samba         stable        2.0.7-3              alpha, arm, i386, m68k, powerpc, sparc
samba         testing       2.0.7-3              alpha, arm, i386, m68k, powerpc, sparc
samba         unstable      2.0.7-5              arm, m68k, mips
samba         unstable      2.2.0.final-2        alpha, hppa, i386, powerpc, sparc
samba         updates       2.0.7-3.3            alpha, arm, i386, m68k, powerpc, sparc
smbclient     experimental  2.2.0.cvs20010416-1  i386
smbclient     stable        2.0.7-3              alpha, arm, i386, m68k, powerpc, sparc
smbclient     testing       2.0.7-3              alpha, arm, i386, m68k, powerpc, sparc
smbclient     unstable      2.0.7-5              arm, m68k, mips
smbclient     unstable      2.2.0.final-2        alpha, hppa, i386, powerpc, sparc
smbclient     updates       2.0.7-3.3            alpha, arm, i386, m68k, powerpc, sparc
smbfs         experimental  2.2.0.cvs20010416-1  i386
smbfs         stable        2.0.7-3              alpha, arm, i386, m68k, powerpc, sparc
smbfs         testing       2.0.7-3              alpha, arm, i386, m68k, powerpc, sparc
smbfs         unstable      2.0.7-5              arm, m68k, mips
smbfs         unstable      2.2.0.final-2        alpha, hppa, i386, powerpc, sparc
smbfs         updates       2.0.7-3.3            alpha, arm, i386, m68k, powerpc, sparc
swat          experimental  2.2.0.cvs20010416-1  i386
swat          stable        2.0.7-3              alpha, arm, i386, m68k, powerpc, sparc
swat          testing       2.0.7-3              alpha, arm, i386, m68k, powerpc, sparc
swat          unstable      2.0.7-5              arm, m68k, mips
swat          unstable      2.2.0.final-2        alpha, hppa, i386, powerpc, sparc
swat          updates       2.0.7-3.3            alpha, arm, i386, m68k, powerpc, sparc

install-u samba_2.0.7-3.2.1_sparc.changes
install-u samba_2.0.7-3.2_security.changes
install-u samba_2.0.7-3.3_all.changes
install samba_2.0.7-3.4_security.changes

	Security Update, DSA 048

sendfile    updates   2.1-20.3    alpha, arm, i386, m68k, powerpc, sparc

install-u sendfile_2.1-20.2.changes
install sendfile_2.1-20.3.changes

	Security Update, DSA 050, 052

slrnpull    stable    0.9.6.2-9potato1  alpha, arm, i386, m68k, powerpc, sparc
slrnpull    updates   0.9.6.2-9potato2  alpha, arm, i386, m68k, powerpc, sparc
slrn        stable    0.9.6.2-9potato1  alpha, arm, i386, m68k, powerpc, sparc
slrn        updates   0.9.6.2-9potato2  alpha, arm, i386, m68k, powerpc, sparc

install slrn_0.9.6.2-9potato2_i386.changes
install slrn_0.9.6.2-9potato2_security.changes

	DSA 078

squid-cgi    stable    2.2.5-3.1   alpha, arm, i386, m68k, powerpc, sparc
squid-cgi    updates   2.2.5-3.2   alpha, arm, i386, m68k, powerpc, sparc
squidclient  stable    2.2.5-3.1   alpha, arm, i386, m68k, powerpc, sparc
squidclient  updates   2.2.5-3.2   alpha, arm, i386, m68k, powerpc, sparc
squid        stable    2.2.5-3.1   alpha, arm, i386, m68k, powerpc, sparc
squid        updates   2.2.5-3.2   alpha, arm, i386, m68k, powerpc, sparc

install squid_2.2.5-3.2_security.changes

	* Fix DoS problem with invalid handling of mkdir-only PUT requests,
	  squid bugzilla #233

	DSA 077

ssltelnet    updates   0.16.3-1.1                 alpha, arm, i386, m68k, powerpc
ssltelnet    updates   0.16.3-1.2                 sparc
telnet-ssl   updates   0.16.3-1.1                 alpha, arm, i386, m68k, powerpc
telnet-ssl   updates   0.16.3-1.2                 sparc
telnetd-ssl  updates   0.16.3-1.1                 alpha, arm, i386, m68k, powerpc
telnetd-ssl  updates   0.16.3-1.2                 sparc

install netkit-telnet-ssl_0.16.3-1.1_alpha.changes
install netkit-telnet-ssl_0.16.3-1.1_arm.changes
install netkit-telnet-ssl_0.16.3-1.1_i386.changes
install netkit-telnet-ssl_0.16.3-1.1_m68k.changes
install netkit-telnet-ssl_0.16.3-1.1_powerpc.changes
install netkit-telnet-ssl_0.16.3-1.1_sparc.changes
install netkit-telnet-ssl_0.16.3-1.2.changes

	Security Update, DSA 075

unzip-crypt  stable    5.32-1      m68k
unzip-crypt  stable    5.40-1.0    alpha, arm, i386, powerpc, sparc
unzip-crypt  updates   5.40-1.0    m68k

sync-install unzip-crypt_5.40-1.0_m68k.changes

	Get architectures back in sync

uucp        stable    1.06.1-11         alpha, arm, i386, m68k, powerpc, sparc
uucp        updates   1.06.1-11potato1  alpha, arm, i386, m68k, powerpc, sparc

install uucp_1.06.1-11potato1.changes

	* Fixed exploit that allowed to gain uid.guid uucp.uucp:
	  Applied patch that blocks the long arg variants of -I -u -g in uuxqt
	  (taken from Calderas security update; From: Jeff Johnson <jbj@redhat.com>)
	* Changed maintainer to weasel@debian.org

	DSA 079

w3m         stable    0.1.10+0.1.11pre+kokb23-1  alpha, arm, i386, sparc
w3m         stable    0.1.6-4                    powerpc
w3m         updates   0.1.10+0.1.11pre+kokb23-4  alpha, arm, i386, powerpc, sparc

install w3m_0.1.10+0.1.11pre+kokb23-4_i386.changes
install w3m_0.1.10+0.1.11pre+kokb23-4_security.changes

	* [SECURITY FIX] backport fix of mime header buffer overflow
	  SNS Advisory No.32
	  w3m malformed MIME header Buffer Overflow Vulnerability
	  http://www.lac.co.jp/security/snsadv/32.html (Japanese)
	* dont install w3m.el in emacs dir because it wont work well.
	  closes: Bug#96385

	It's an unknown security fix, but w3m fixed tend to be
	japanese only, so we can't handle them properly anyway...
	Even all architectures are in sync, wow.

libdockapp-dev   stable    0.61.1-4      alpha, arm, i386, m68k, powerpc
libdockapp-dev   stable    0.61.1-4.0.1  sparc
libdockapp-dev   updates   0.61.1-4.1    alpha, arm, i386, m68k, powerpc, sparc
libwings-dev     stable    0.61.1-4      alpha, arm, i386, m68k, powerpc
libwings-dev     stable    0.61.1-4.0.1  sparc
libwings-dev     updates   0.61.1-4.1    alpha, arm, i386, m68k, powerpc, sparc
libwmaker0-dev   stable    0.61.1-4      alpha, arm, i386, m68k, powerpc
libwmaker0-dev   stable    0.61.1-4.0.1  sparc
libwmaker0-dev   updates   0.61.1-4.1    alpha, arm, i386, m68k, powerpc, sparc
libwraster1-dev  stable    0.61.1-4      alpha, arm, i386, m68k, powerpc
libwraster1-dev  stable    0.61.1-4.0.1  sparc
libwraster1-dev  updates   0.61.1-4.1    alpha, arm, i386, m68k, powerpc, sparc
libwraster1      stable    0.61.1-4      alpha, arm, i386, m68k, powerpc
libwraster1      stable    0.61.1-4.0.1  sparc
libwraster1      updates   0.61.1-4.1    alpha, arm, i386, m68k, powerpc, sparc
wmaker           stable    0.61.1-4      alpha, arm, i386, m68k, powerpc
wmaker           stable    0.61.1-4.0.1  sparc
wmaker           updates   0.61.1-4.1    alpha, arm, i386, m68k, powerpc, sparc

install wmaker_0.61.1-4.1_multi.changes

	* Fix buffer overflow in titlebar handling

	DSA 074

xcal        stable    4.1-8       alpha, arm, i386, m68k, powerpc, sparc
xcal        updates   4.1-9       alpha, arm, i386, m68k, powerpc, sparc

install xcal_4.1-9_alpha.changes
install xcal_4.1-9_arm.changes
install xcal_4.1-9_i386.changes
install xcal_4.1-9_m68k.changes
install xcal_4.1-9_powerpc.changes
install xcal_4.1-9_sparc.changes

	aj: a calendar program getting days of a month wrong seems a
	decent thing to fix.

xinetd      stable    1:2.1.8.8.p3-1    alpha, arm, i386, m68k, powerpc, sparc
xinetd      updates   1:2.1.8.8.p3-1.1  alpha, arm, i386, m68k, powerpc, sparc

install xinetd_2.1.8.8.p3-1.1_security.changes

	* Non-maintainer upload by security team
	* Fix buffer overflow in svc_logprint()
	* Set default umask to 022 in init_common()

	DSA 063


xloadimage  stable    4.1-5         alpha, arm, i386, m68k, powerpc, sparc
xloadimage  updates   4.1-5potato1  alpha, arm, i386, m68k, powerpc, sparc

install xloadimage_4.1-5potato1_alpha.changes
install xloadimage_4.1-5potato1_arm.changes
install xloadimage_4.1-5potato1_i386.changes
install xloadimage_4.1-5potato1_m68k.changes
install xloadimage_4.1-5potato1_powerpc.changes
install xloadimage_4.1-5potato1_sparc.changes

	* config.c, faces.c, imagetypes.c, options.c, packtar.c: fix unsafe
	  str{cpy,cat} usage.  Seen in
	  http://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=46186

	DSA 069

xpvm        stable    1.2.5-5     arm
xpvm        stable    1.2.5-6     alpha, i386, m68k, powerpc, sparc
xpvm        updates   1.2.5-6     arm

sync-install xpvm_1.2.5-6_arm.changes

	Get architectures back in sync


xqf         stable    0.9.3-1     alpha, arm, i386, m68k, sparc
xqf         updates   0.9.3-1     powerpc

sync-install xqf_0.9.3-1_powerpc.changes

	Get architectures in sync

zope        updates   2.1.6-10    alpha, arm, i386, m68k, powerpc, sparc

install-u zope_2.1.6-9_alpha.changes
install-u zope_2.1.6-9_arm.changes
install-u zope_2.1.6-9_i386.changes
install-u zope_2.1.6-9_m68k.changes
install-u zope_2.1.6-9_powerpc.changes
install-u zope_2.1.6-9_sparc.changes
install zope_2.1.6-10_alpha.changes
install zope_2.1.6-10_arm.changes
install zope_2.1.6-10_i386.changes
install zope_2.1.6-10_m68k.changes
install zope_2.1.6-10_powerpc.changes
install zope_2.1.6-10_sparc.changes

	Security Update, DSA 055 (and fix to DSA 043)

zsh-doc     stable    3.1.9.dev6-7      all
zsh         stable    3.1.9.dev6-2      alpha
zsh         stable    3.1.9.dev6-7      arm, i386, m68k, powerpc, sparc
zsh         updates   3.1.9.dev6-7.0.1  arm

sync-install zsh_3.1.9.dev6-7.0.1_arm.changes

	* Binary-only non-maintainer upload for arm; no source changes.
	* rebuild against current libc, which doesn't have LFS support.

	Get architectures back in sync


Further investigation
---------------------

These packages need further investigation.  One reason the package is
listed here could be that I'm not yet convinced this package should go
into stable, but don't want to reject it entirely at the moment.
Another reason could be that released and updated architectures are
not in sync yet.

bwbasic     stable    2.20pl2-3    alpha, i386, m68k, powerpc
bwbasic     stable    2.20pl2-3.1  sparc
bwbasic     updates   2.20pl2-3.2  m68k, sparc

bwbasic_2.20pl2-3.2_m68k.changes
bwbasic_2.20pl2-3.2_sparc.changes

	* New maintainer.
	* Recompile.  Due to strange interactions with libc6, functions
	  weren't interpreted, and the package was practically unusable.
	  Closes: #108924.

	Architectures missing: alpha, i386, powerpc and arm (if possible)

cfs         stable    1.3.3-7     powerpc, sparc
cfs         stable    1.3.3-8     alpha, arm, i386, m68k
cfs         updates   1.3.3-8     sparc

delay-sync-install cfs_1.3.3-8_sparc.changes

	Get architectures in sync

	PowerPC missing

	This is non-US.

freewnn-common       stable    1.1.0+1.1.1-a016-1           all
freewnn-cserver-dev  stable    1.1.0+1.1.1-a016-1           alpha, arm, i386, m68k, powerpc, sparc
freewnn-cserver      stable    1.1.0+1.1.1-a016-1           alpha, arm, i386, m68k, powerpc, sparc
freewnn-jserver-dev  stable    1.1.0+1.1.1-a016-1           alpha, arm, i386, m68k, powerpc, sparc
freewnn-jserver      stable    1.1.0+1.1.1-a016-1           alpha, arm, i386, m68k, powerpc, sparc
freewnn-kserver-dev  stable    1.1.0+1.1.1-a016-1           alpha, arm, i386, m68k, powerpc, sparc
freewnn-kserver      stable    1.1.0+1.1.1-a016-1           alpha, arm, i386, m68k, powerpc, sparc
freewnn-common       updates   1.1.0+1.1.1-a016-1.potato.3  all
freewnn-cserver-dev  updates   1.1.0+1.1.1-a016-1.potato.3  i386, m68k
freewnn-cserver      updates   1.1.0+1.1.1-a016-1.potato.3  i386, m68k
freewnn-jserver-dev  updates   1.1.0+1.1.1-a016-1.potato.3  i386, m68k
freewnn-jserver      updates   1.1.0+1.1.1-a016-1.potato.3  i386, m68k
freewnn-kserver-dev  updates   1.1.0+1.1.1-a016-1.potato.3  i386, m68k
freewnn-kserver      updates   1.1.0+1.1.1-a016-1.potato.3  i386, m68k

delay-install freewnn_1.1.0+1.1.1-a016-1.potato.1_i386.changes
delay-install freewnn_1.1.0+1.1.1-a016-1.potato.1_m68k.changes
delay-install freewnn_1.1.0+1.1.1-a016-1.potato.3_i386.changes
delay-install freewnn_1.1.0+1.1.1-a016-1.potato.3_m68k.changes

	* [security fix] backport from freewnn 1.1.0+1.1.1-a017-6.4
	  - adduser wnn, kwnn, cwnn for jserver,kserver,cserver respectively
	    instead of running as root user
	  - restrict upload/create path under jserver_dir

	The 2nd upload is required to make the package installable
	*sigh*  At least, it is proved to be tested now...

	However: alpha, arm, powerpc and sparc are missing

icecast-client  stable    1.0.0-1     alpha, arm, i386, m68k, powerpc, sparc
icecast-server  stable    1.0.0-1     alpha, arm, i386, m68k, powerpc, sparc
icecast-server  updates   1.3.10-1    i386, m68k, powerpc

clarify icecast-server_1.3.10-1_i386.changes
clarify icecast-server_1.3.10-1_m68k.changes
clarify icecast-server_1.3.10-1_powerpc.changes

	Alleged security update.

	Changelog says:

	* Several security exploits found to icecast.  No simple way to patch

	* old version, so upgrade to latest stable version from icecast.org

	* If questions or assistance needed join #icecast on openprojects.net IRC

	Do you have a documentation about said security exploits?
	That's still pending

	Is it something different than this one?

	"icecast" is a server used to distribute audio streams to compatible
	clients such as winamp, mpg123, xmms and many others.
	Matt Messier (mmessier@prilnari.com) and John Viega (viega@list.org)
	have identified several buffer overflow and format strings problems
	in Icecast that could be remotely exploited.
	Our latest update to this software changes the package to use an
	unprivileged user ("icecast") for the daemon, so the impact of this
	vulnerability is not as high. Recent distributions (CL >= 5.1) have
	this package compiled with StackGuard to make it more difficult to
	exploit buffer overflows.

	It's said to be.

	Clarification appreciated.

inn2-dev          updates   2.2.2.2000.01.31-4.1  arm
inn2-dev          updates   2.2.2.2000.01.31-5    alpha, i386, m68k, sparc
inn2-inews        updates   2.2.2.2000.01.31-4.1  arm
inn2-inews        updates   2.2.2.2000.01.31-5    alpha, i386, m68k, sparc
inn2              updates   2.2.2.2000.01.31-4.1  arm
inn2              updates   2.2.2.2000.01.31-5    alpha, i386, m68k, sparc
task-news-server  updates   2.2.2.2000.01.31-5    all

install inn2_2.2.2.2000.01.31-5_i386.changes
install inn2_2.2.2.2000.01.31-5_m68k.changes
install inn2_2.2.2.2000.01.31-5_source.changes
install inn2_2.2.2.2000.01.31-5_sparc.changes
install inn2_2.2.2.2000.01.31-5_alpha.changes

	Security Update, DSA 023

	Bdale reports a serious problem with this upload, it broke
	some functionality.  He's going to upload a fixed version, so
	this will have to wait for 2.2r4 then.  Fixed for 2.2.2.2000.01.31-5.

	arm and powerpc missing

nedit       updates   1:5.1.1-3   alpha, arm, i386, m68k, powerpc

install	nedit_5.1.1-3_alpha.changes
install	nedit_5.1.1-3_arm.changes
install	nedit_5.1.1-3_i386.changes
install	nedit_5.1.1-3_m68k.changes
install	nedit_5.1.1-3_powerpc.changes

	nedit is now Free Software.

	sparc missing

telnetd     stable    0.16-4          alpha
telnetd     stable    0.16-4potato.1  arm, i386, m68k, powerpc, sparc
telnetd     updates   0.16-4potato.3  i386
telnet      stable    0.16-4          alpha
telnet      stable    0.16-4potato.1  arm, i386, m68k, powerpc, sparc
telnet      updates   0.16-4potato.3  i386

delay-install netkit-telnet_0.16-4potato.3_i386.changes

	Changelog says: * Fixed same overflow with minimal change.

	All stable arch's but i386 are missing

	DSA 070 mentioned version 0.16-4potato.2

pcmcia-modules-2.2.19-compact  updates   3.1.22-0.2potatok4  i386
pcmcia-modules-2.2.19-idepci   updates   3.1.22-0.2potatok4  i386
pcmcia-modules-2.2.19-ide      updates   3.1.22-0.2potatok4  i386
pcmcia-modules-2.2.19          updates   3.1.22-0.2potatok4  i386

install pcmcia-modules-2.2.19-compact_3.1.22-0.2potatok4_i386.changes
install pcmcia-modules-2.2.19-ide_3.1.22-0.2potatok4_i386.changes
install pcmcia-modules-2.2.19-idepci_3.1.22-0.2potatok4_i386.changes
install pcmcia-modules-2.2.19_3.1.22-0.2potatok4_i386.changes
remove pcmcia-modules-2.2.19pre17-compact
remove pcmcia-modules-2.2.19pre17-idepci
remove pcmcia-modules-2.2.19pre17-ide
remove pcmcia-modules-2.2.19pre17

	Update for kernel-source-2.2.19pre17

	Need further info, why aren't pcmcia-modules-2.2.19pre17-idepci
	and the like sufficient?  Herbert has mail.


php4-cgi-gd     updates   4.0.3pl1-0potato1.1  alpha, sparc
php4-cgi-gd     updates   4.0.3pl1-0potato2    i386, m68k, powerpc
php4-cgi-imap   updates   4.0.3pl1-0potato1.1  alpha, sparc
php4-cgi-imap   updates   4.0.3pl1-0potato2    i386, m68k, powerpc
php4-cgi-ldap   updates   4.0.3pl1-0potato1.1  alpha, sparc
php4-cgi-ldap   updates   4.0.3pl1-0potato2    i386, m68k, powerpc
php4-cgi-mhash  updates   4.0.3pl1-0potato1.1  alpha, sparc
php4-cgi-mhash  updates   4.0.3pl1-0potato2    i386, m68k, powerpc
php4-cgi-mysql  updates   4.0.3pl1-0potato1.1  alpha, sparc
php4-cgi-mysql  updates   4.0.3pl1-0potato2    i386, m68k, powerpc
php4-cgi-pgsql  updates   4.0.3pl1-0potato1.1  alpha, sparc
php4-cgi-pgsql  updates   4.0.3pl1-0potato2    i386, m68k, powerpc
php4-cgi-snmp   updates   4.0.3pl1-0potato1.1  alpha, sparc
php4-cgi-snmp   updates   4.0.3pl1-0potato2    i386, m68k, powerpc
php4-cgi-xml    updates   4.0.3pl1-0potato1.1  alpha, sparc
php4-cgi-xml    updates   4.0.3pl1-0potato2    i386, m68k, powerpc
php4-cgi        updates   4.0.3pl1-0potato1.1  alpha, sparc
php4-cgi        updates   4.0.3pl1-0potato2    i386, m68k, powerpc
php4-dev        updates   4.0.3pl1-0potato2    all
php4-gd         updates   4.0.3pl1-0potato1.1  alpha, sparc
php4-gd         updates   4.0.3pl1-0potato2    i386, m68k, powerpc
php4-imap       updates   4.0.3pl1-0potato1.1  alpha, sparc
php4-imap       updates   4.0.3pl1-0potato2    i386, m68k, powerpc
php4-ldap       updates   4.0.3pl1-0potato1.1  alpha, sparc
php4-ldap       updates   4.0.3pl1-0potato2    i386, m68k, powerpc
php4-mhash      updates   4.0.3pl1-0potato1.1  alpha, sparc
php4-mhash      updates   4.0.3pl1-0potato2    i386, m68k, powerpc
php4-mysql      updates   4.0.3pl1-0potato1.1  alpha, sparc
php4-mysql      updates   4.0.3pl1-0potato2    i386, m68k, powerpc
php4-pgsql      updates   4.0.3pl1-0potato1.1  alpha, sparc
php4-pgsql      updates   4.0.3pl1-0potato2    i386, m68k, powerpc
php4-snmp       updates   4.0.3pl1-0potato1.1  alpha, sparc
php4-snmp       updates   4.0.3pl1-0potato2    i386, m68k, powerpc
php4-xml        updates   4.0.3pl1-0potato1.1  alpha, sparc
php4-xml        updates   4.0.3pl1-0potato2    i386, m68k, powerpc
php4            updates   4.0.3pl1-0potato1.1  alpha, sparc
php4            updates   4.0.3pl1-0potato2    i386, m68k, powerpc

install php4_4.0.3pl1-0potato2_i386.changes
install php4_4.0.3pl1-0potato2_m68k.changes
install php4_4.0.3pl1-0potato2_powerpc.changes

	Security Update

	Roland Bauerschmidt reports "php4-cgi broken".  Look at
	#89431. /usr/lib/cgi-bin/php4 is a symlink to
	debian/php4-cgi/usr/bin/php4 which of course doesn't exist.

	Rebuild for 4.0.3pl1-0potato2 issued.  Missing: alpha, sparc

	Updated packages should be uploaded soon.

ecpg                stable    6.5.3-26    alpha, arm, i386, m68k, powerpc, sparc
ecpg                updates   6.5.3-27    i386, m68k
libpgperl           stable    6.5.3-26    alpha, arm, i386, m68k, powerpc, sparc
libpgperl           updates   6.5.3-27    i386, m68k
libpgsql2           stable    6.5.3-26    alpha, arm, i386, m68k, powerpc, sparc
libpgsql2           updates   6.5.3-27    i386, m68k
libpgtcl            stable    6.5.3-26    alpha, arm, i386, m68k, powerpc, sparc
libpgtcl            updates   6.5.3-27    i386, m68k
odbc-postgresql     stable    6.5.3-26    alpha, arm, i386, m68k, powerpc, sparc
odbc-postgresql     updates   6.5.3-27    i386, m68k
pgaccess            stable    6.5.3-26    alpha, arm, i386, m68k, powerpc, sparc
pgaccess            updates   6.5.3-27    i386, m68k
postgresql-client   stable    6.5.3-26    alpha, arm, i386, m68k, powerpc, sparc
postgresql-client   updates   6.5.3-27    i386, m68k
postgresql-contrib  stable    6.5.3-26    alpha, arm, i386, m68k, powerpc, sparc
postgresql-contrib  updates   6.5.3-27    i386, m68k
postgresql-dev      stable    6.5.3-26    alpha, arm, i386, m68k, powerpc, sparc
postgresql-dev      updates   6.5.3-27    i386, m68k
postgresql-doc      stable    6.5.3-26    all
postgresql-doc      updates   6.5.3-27    all
postgresql-pl       stable    6.5.3-26    alpha, arm, i386, m68k, powerpc, sparc
postgresql-pl       updates   6.5.3-27    i386, m68k
postgresql-test     stable    6.5.3-26    alpha, arm, i386, m68k, powerpc, sparc
postgresql-test     updates   6.5.3-27    i386, m68k
postgresql          stable    6.5.3-26    alpha, arm, i386, m68k, powerpc, sparc
postgresql          updates   6.5.3-27    i386, m68k
python-pygresql     stable    6.5.3-26    alpha, arm, i386, m68k, powerpc, sparc
python-pygresql     updates   6.5.3-27    i386, m68k

delay-install postgresql_6.5.3-27_i386.changes
delay-install postgresql_6.5.3-27_m68k.changes

	* postgresql: applied patch from Ben Pfaff <pfaffben@msu.edu> to cure
	  problem with segfault in pg_dump.  High urgency because pg_dump is
	  essential for transferring data when upgrading postgresql.
	  Closes: #101940

	No security update but something that is anticipated to
	prevent data loss, I'm convinced.

	But anyway, some architectures are missing: alpha, arm,
	powerpc, sparc

samba-common  updates   2.0.7-3.2   alpha, arm, i386, m68k, powerpc, sparc
samba-doc     updates   2.0.7-3.2   all
samba         updates   2.0.7-3.2   alpha, arm, i386, m68k, powerpc, sparc
smbclient     updates   2.0.7-3.2   alpha, arm, i386, m68k, powerpc, sparc
smbfs         updates   2.0.7-3.2   alpha, arm, i386, m68k, powerpc, sparc
swat          updates   2.0.7-3.2   alpha, arm, i386, m68k, powerpc, sparc

install samba_2.0.7-3.2_security.changes

	Security update, DSA 048

	Broken on sparc and alpha, needs a new upload

tkseti      stable    2.10-1      arm
tkseti      stable    2.12-1      powerpc
tkseti      stable    2.12-2      alpha, i386, sparc
tkseti      updates   2.12-2      arm

sync-install tkseti_2.12-2_arm.changes

	Get versions back in sync.

	PowerPC missing

unzip-crypt  stable    5.32-1      m68k
unzip-crypt  stable    5.40-1.0    alpha, i386, powerpc, sparc
unzip-crypt  updates   5.40-1.0    arm

sync-install unzip-crypt_5.40-1.0_arm.changes

	Get architectures in sync.

	m68k missing

	This is non-US.

w3m-ssl      updates   0.1.10+0.1.11pre+kokb23-4  i386

delay-install w3m-ssl_0.1.10+0.1.11pre+kokb23-4_i386.changes

	Unknown security fix

	5/6 architectures missing

webrt       stable    1.0.1-3     arm, powerpc
webrt       stable    1.0.1-4     alpha, i386, m68k, sparc
webrt       updates   1.0.1-4     powerpc

delay-install webrt_1.0.1-4_powerpc.changes

	* Security fix: /etc/rt/config.pm was world readable (closes: #62383)

	An arm package is missing still

xtel        stable    3.2.1-4           alpha, arm, i386, m68k, powerpc, sparc
xtel        updates   3.2.1-4.potato.1  i386, m68k

delay-install xtel_3.2.1-4.potato.1_i386.changes
delay-install xtel_3.2.1-4.potato.1_m68k.changes

	* New maintainer
	* Security fixes:
	  - symlink vulnerability in xteld (see #87787).
	  - symlink vulnerability in xtel while printing harcopy of screen.
	  - run xteld under control of tcpd to be able to restrict access to the
	    service from network.
	* Backport of annoying and easy to fix bugs from woody version of xtel:
	  - Fixed segfaults (see #43566).
	  - Fixed a little typo in the /etc/xtel/lignes file.
	  - Fixed creation of the symlink to french doc directory (see #55131).
	* Other annoying fixes:
	  - bad X resource in Xtel[m].ad (missing '-o -' in a2ps printing command).

	No DSA, Architectures missing: alpha, arm, powerpc and sparc

xxgdb       stable    1.12-9.3        alpha, arm, i386, m68k, powerpc, sparc
xxgdb       testing   1.12-10         alpha, arm, i386, m68k, powerpc, sparc
xxgdb       unstable  1.12-10         alpha, arm, hppa, i386, ia64, m68k, powerpc, sparc
xxgdb       updates   1.12-9.4potato  i386, m68k, powerpc

install xxgdb_1.12-9.4potato_i386.changes
install xxgdb_1.12-9.4potato_m68k.changes
install xxgdb_1.12-9.4potato_powerpc.changes

	* Applied a patch from Massimo Dal Zotto <dz@cs.unitn.it>. This is a
	  workaround for a serious bug (#94892) in libXaw.

	Seems this bug makes xxgdb useless in stable

	alpha, arm and sparc missing

yabasic     stable    2.42-1      arm
yabasic     stable    2.53-1      alpha, i386, m68k, powerpc, sparc
yabasic     updates   2.53-2      m68k, powerpc, sparc

delay-install yabasic_2.53-2_m68k.changes
delay-install yabasic_2.53-2_powerpc.changes
delay-install yabasic_2.53-2_sparc.changes

	* New maintainer.
	* yabasic.c: Fixed a /tmp race condition.
	* Completed the FHS transition to allow building with a recent
	  debhelper.  Closes: #98875.

	Architectures missing: alpha, arm, i386

	No DSA assigned, maintainer, please get in touch with the
	Security Team

zope        updates   2.1.6-7     sparc
zope        updates   2.1.6-9     alpha, arm, i386, m68k, powerpc

install-u zope_2.1.6-5.3_alpha.changes
install-u zope_2.1.6-5.3_arm.changes
install-u zope_2.1.6-5.3_i386.changes
install-u zope_2.1.6-5.3_powerpc.changes
install-u zope_2.1.6-5.3_sparc.changes
install-u zope_2.1.6-5.4_m68k.changes
install-u zope_2.1.6-5.4_security.changes
install-u zope_2.1.6-6_arm.changes
install-u zope_2.1.6-6_i386.changes
install-u zope_2.1.6-6_m68k.changes
install-u zope_2.1.6-6_powerpc.changes
install-u zope_2.1.6-6_sparc.changes
install-u zope_2.1.6-7_alpha.changes
install-u zope_2.1.6-7_arm.changes
install-u zope_2.1.6-7_i386.changes
install-u zope_2.1.6-7_m68k.changes
install-u zope_2.1.6-7_powerpc.changes
install-u zope_2.1.6-7_sparc.changes
install-u zope_2.1.6-8_alpha.changes
install-u zope_2.1.6-8_arm.changes
install-u zope_2.1.6-8_i386.changes
install-u zope_2.1.6-8_m68k.changes
install-u zope_2.1.6-8_powerpc.changes
install zope_2.1.6-9_alpha.changes
install zope_2.1.6-9_arm.changes
install zope_2.1.6-9_i386.changes
install zope_2.1.6-9_m68k.changes
install zope_2.1.6-9_powerpc.changes

	Security upload, DSA 006, DSA 007, DSA 043

	Zope 2.1.6-7 indeed had two problems with two of the Hotfixes
	included, so I prepared a new version 2.1.6-8 and uploaded
	that to Incoming (target 'stable'):

	First, Hotfix_2000-10-02 broke some stuff in 2.1.6 (the README
	said that this Hotfox_2000-10-02 would apply to 2.2.x and
	later, which is obviously correct). Therefore 2000-10-02 was
	removed in 2.1.6-8. Obviously, the vulnerability fixed by this
	Hotfix was only introduced in Zope 2.2.0.

	Then, Hotfix_2000-10-11 wouldn't work with 2.1.6 out of the
	box, but since 2.1.6 was affected by the vulnerability
	nonetheless, I had to apply a fix to the Hotfix. Included in
	2.1.6-8 as well.

	This time, 2.1.6-8 has been tested on a potato system to a
	moderate degree.

	Sparc missing.  Mike Renfro compiled it: http://mwr.ddts.net/a/mwr/


Rejected packages
-----------------

Packages that don't meet the requirements

afbackup-client  stable    3.1beta1-1.1  alpha, arm, i386, m68k, powerpc, sparc
afbackup         stable    3.1beta1-1.1  alpha, arm, i386, m68k, powerpc, sparc

reject afbackup_3.3.3beta3-1_i386.changes
reject afbackup_3.3.3beta3-1_m68k.changes
reject afbackup_3.3.3beta3-1_powerpc.changes

	New upstream version

	Files lost, only .changes are left over, huh?

barcode     stable    0.94-1        alpha, arm, i386, m68k, powerpc, sparc
barcode     testing   0.95.1-4      alpha, hppa, i386, ia64, m68k, powerpc, sparc
barcode     unstable  0.95.1-4      alpha, hppa, hurd-i386, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
barcode     updates   0.95.1-4      sparc

reject barcode_0.95.1-4_sparc.changes

	Misplaced upload

catsboot    testing   0.2         arm
catsboot    unstable  0.2.1       arm
catsboot    updates   0.2.1       arm

reject catsboot_0.2.1_arm.changes

	No reason to go into stable.  ChangeLog:

	* No code change, just bump the version for upload to stable.

	Maintainer: Philip Blundell <pb@debian.org>

everybuddy      stable    0.0.7-3         alpha, arm, i386, m68k, powerpc, sparc

reject everybuddy_0.2.0-5_i386.changes
reject everybuddy_0.2.1beta6-1_i386.changes
reject everybuddy_0.2.1beta6-1_m68k.changes

	* Potato build for stable upload
	* Last version in stable was 0.0.7 ... significant performance,
	  security, and stability fixes.  Also, this one actually works.

	Only i386 uploaded

	The files are lost anyway...

freetype-tools  stable    1.3.1-1       alpha, arm, i386, m68k, powerpc, sparc
freetype-tools  updates   1.4-0potato2  alpha
freetype2-dev   stable    1.3.1-1       alpha, arm, i386, m68k, powerpc, sparc
freetype2-dev   updates   1.4-0potato2  alpha
freetype2       stable    1.3.1-1       alpha, arm, i386, m68k, powerpc, sparc
freetype2       updates   1.4-0potato2  alpha

reject freetype1_1.4-0potato2_alpha.changes

	* The configure options for kpathsea support in ttf2pk has been changed
	  upstream, and 1.4-0potato1 was inadvertently built without kpathsea
	  support.  Thanks to Philipp Lehman for the bug report!  :-)
	  Closes: Bug#83403.

	* Oops, I didn't know that debhelper (>= 2.1.0) and libtools (>= 1.3.4-1)
	  aren't in potato yet.  Fixed Build-Depends line.  Thanks to fellow
	  Debian developer Dan Jacobowitz for letting me know.

	There is no version 1.4-0potato1 in potato, so there doesn't
	need to be an update.  Apart from that, where are the other
	architectures?  However, the most interesting question to day
	is; where is the source?

g2          stable    0.40-1      alpha, arm, i386, m68k, powerpc, sparc
g2          testing   0.40-1      alpha, arm, i386, m68k, powerpc, sparc
g2          updates   0.40-2      alpha

reject g2_0.40-2_alpha.changes

	Distribution: stable

	* New maintainer.

	* Updated description - g2 site moved since last release.

	* Added dependency on libgd-gif1.  Closes: Bug#61124

	Apparently somebody forgot the whole idea about stable and
	unstable as well as source and binary packages.  Well...

hztty       testing   2.0-3         powerpc
hztty       testing   2.0-5         alpha, arm, i386, m68k, sparc
hztty       unstable  2.0-3         powerpc
hztty       unstable  2.0-5         alpha, arm, hppa, i386, ia64, m68k, sparc
hztty       updates   2.0-3potato4  alpha

reject hztty_2.0-3potato4_alpha.changes

	Well... we should probably keep silence about this package...


ftpd        stable    0.11-8potato.1  alpha, arm, i386, m68k, powerpc, sparc
ftpd        updates   0.11-8potato.2  i386, m68k

reject linux-ftpd_0.11-8potato.2_i386.changes
reject linux-ftpd_0.11-8potato.2_m68k.changes

	* Register sessions with PAM.
	* Use pam_limits by default.
	* Documented the procedure to counter globbing attacks.

	Doesn't sound like a requirement for inclusion in stable to me.

procmail    stable    3.13.1-3    alpha
procmail    stable    3.13.1-4    arm, i386, m68k, powerpc, sparc
procmail    updates   3.15.2-1    i386, m68k

reject procmail_3.15.2-1_i386.changes
reject procmail_3.15.2-1_m68k.changes
reject procmail_3.20-1_i386.changes
reject procmail_3.20-1_m68k.changes
reject procmail_3.21-1_i386.changes
reject procmail_3.21-1_sparc.changes

	Changelog for 3.15.2-1:

	* New upstream release, with improved security and robustness involving
	  signal handlers. Author recommends upgrading to this version on
	  any system where it is installed setuid or setgid.
	* This release fixes also Bug #108417: procmail -p -m resets PATH.

	Changelog for 3.20.1-1:

	* New upstream release, with improved security and robustness involving
	  signal handlers. Author recommends upgrading to version 3.20 on
	  any system where it is installed setuid or setgid.

	Changelog for 3.21.1-1:

	* New upstream release, with improved security and robustness involving
	  signal handlers. Author recommends upgrading to this version on
	  any system where it is installed setuid or setgid.
	  Note: In 3.20 the INCLUDERC directive was broken on some archs.

	Not conviced, all version seem to use about the same changelog
	line and I haven't seen any security reports.

realplayer  updates   8.0.1.potato.3  i386

reject realplayer_8.0.1.potato.1_i386.changes
reject realplayer_8.0.1.potato.2_i386.changes
reject realplayer_8.0.1.potato.3_i386.changes

	realplayer (8.0.1.potato.1) stable; urgency=medium

	  * The about-bloody-time release, heh, sigh..
	  * New version (again) (Closes: #98751, #95272)
	  * Made some changes, should help with borkedness (Closes: #95768)
	  * added realplayer icon (Closes: #96318)
	  * I have a feeling 89658 may still pop-up.
	  * There's nothing I can do about this, upstream's fault
	    and they don't seem to care *shrug* (Closes: #86837)
	    Nothing gained from keeping it in BTS.
	  * Probably still see more of these bugs popup again..
	    but _I_ can't duplicate them now.. of course they're pretty
	    much all related to the legal nature of this stupid non-free software.
	
	realplayer (8.0.1.potato.2) stable; urgency=low

	  * .. And they go and release a new RPM on me, heh heh...
	  * Added german templates for the hell of it.
	
	realplayer (8.0.1.potato.3) stable; urgency=medium

	  * Basically the same as the version in unstable, except
	    dependency on xlib6g/xlibs difference.
	  * fixed version in debian/config,
	  * General cleanup in postinst/config/etc.
	  * s/isdefault true/seen false/
	  * Silenced cpio, no 'nnnn blocks' output.
	  * Working stable version (Closes: #95272)

	Why am I not convinced?  And no, there is no version in stable.

sash        stable    3.4-6       alpha, arm, i386, m68k, powerpc, sparc
sash        updates   3.4-8       i386, m68k, sparc

reject sash_3.4-7_i386.changes
reject sash_3.4-7_m68k.changes
reject sash_3.4-8_i386.changes
reject sash_3.4-8_m68k.changes
reject sash_3.4-8_sparc.changes

	* incorporated workaround for dpkg breakage on /usr/doc -> /usr/share/doc
	  (fixes #91634)
	* adopted adrian bunk's suggestions for build-depends (fixes #94329)
	* this version being new, will be newer than that in potato (fixes #97561)
	* no Section: problem was apparently caused by build tools -- a test build
	  shows that 3.4-7 has Section: shells (fixes #84494)
	* not fixed: no debconf support yet.  I'm still considering legacy issues.
	* not fixed: support for -- as end of options indicator.  Meaningless,
	  as sash takes no non-options arguments (it's not designed for scripts).

	Not convinced this should go into stable.  Besides, packages
	for alpha, arm and powerpc are missing.

screen      stable    3.9.5-9      alpha, arm, i386, m68k, powerpc, sparc
screen      updates   3.9.8-1      m68k

reject screen_3.9.8-1_i386.changes
reject screen_3.9.8-1_m68k.changes

	New upstream version --> misplaced upload

trueprint   stable    5.1-1       alpha, arm, i386, m68k, powerpc, sparc
trueprint   updates   5.1-8       alpha

trueprint_5.1-8_alpha.changes

	Another piece from the forget-this-please department.

xemacs21-basesupport  stable    1999.12.15-1    all
xemacs21-basesupport  updates   1999.12.15-1.2  all

reject xemacs21-basesupport_1999.12.15-1.2_i386.changes

	* Non-maintainer release to fix previous upload.
	* Another hack in debian/rules to force the .elc files I had to remove
	  to be rebuilt (Closes: #86990).  This should really be done in a
	  Better Way, but this package does not seem to provide support for
	  compiling elc files.
	* Removed psgml-other.* from MANIFEST.psgml.

xvt         stable    2.1-11      alpha, arm, i386, m68k, powerpc, sparc
xvt         updates   2.1-13      i386

reject xvt_2.1-13_i386.changes

	xvt (2.1-13) stable unstable; urgency=HIGH
	.
	  * Fix a yada bug which prevented the package building in some
	    situations.  Closes:Bug#102744.
	.
	xvt (2.1-12) unstable; urgency=HIGH
	.
	  * Fix a couple of buffer overflows which could result in a local
	    root compromise.  Thanks to Christophe Bailleux <cb@t-online.fr>
	    for finding them.

	Alleged security fix.  No DSA.  All but i386 architectures
	missing.  And even worse the upload was meant for stable and
	unstable, which in turn will most likely render the upload
	useless for stable due to different libc versions.

libhz-dev       updates   0.3.9-1potato1.2  alpha, m68k, powerpc
libhz0          updates   0.3.9-1potato1.2  alpha, m68k, powerpc
zh-autoconvert  updates   0.3.9-1potato1.2  alpha, m68k, powerpc

reject zh-autoconvert_0.3.9-1potato1.2_alpha.changes
reject zh-autoconvert_0.3.9-1potato1.2_m68k.changes
reject zh-autoconvert_0.3.9-1potato1.2_powerpc.changes

	Broken or misplaced upload.  No source, no arm, i386 and sparc.


Disclaimer
----------

This list intends to help the ftp-masters releasing 2.2r4.  They have the
final power to accept a package or not.  If you want to comment on
this list, please send a mail to Martin Schulze <joey@debian.org>.

-- 
It's time to close the windows.

Please always Cc to me when replying to me on the lists.

Attachment: pgpZuML1R7FaE.pgp
Description: PGP signature


Reply to: