[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Hamm Bug Stamp-Out List for June 30, 1998

Welcome to the nem Hamm Bugs Stamp-Out List.

Since Richard Braakman is currently on vacation, I will be maintaining
this for two weeks.

Major changes:
- Security uploads for: qpopper, mutt, libtool
- Portability-uploads for: netpbm-free
- New release-critical bugs: 24073(boot-floppies), 23951(ircd),
  22941(libreadline2), 23995(netbase), 23053(xadmin)
- Closed release-critical bugs: 23520(dpkg), 19351(libdb1-dev)

There are 6 bugreports marked FIX, leaving us 32 to work on.


Mon, 29 Jun 1998 23:45:50 GMT: 38 release-critical bugs in hamm.

Package: boot-floppies        
Maintainer: Enrique Zanardi <sr1-boot-floppies@debian.org>              
[FIX] 2.0.8 has been installed, which fixes these bugs.
  23842  install.html missing from boot-floppies
  24073  cannot install laptop from CD

Package: cvs-pcl              
Maintainer: Tom Lees <tom@lpsg.demon.co.uk>                             
  22577  compile of pcl-cvs.el fails (cannot load "cookie")

Package: cwnn                 
Maintainer: Keita Maehara <maehara@debian.org>                          
  20539  Overlap between cwnn, wnn, and kwnn
[FIX] wnn 4.2-4 has been installed, bug should be closed

Package: dpkg                 
Maintainer: Klee Dienes and Ian Jackson <dpkg-maint@chiark.greenend.org.uk>
   1797  upgrade/downgrade dependency calculation problem
  17381  dpkg: please add --force-overwrite-inexistant-files and def
  17624  dpkg: installs regular dir when .deb contains symlink !
  20401  Problems updating bo -> hamm
  21182  dpkg: dpkg can go into an infinite loop with --force-config

Package: dpkg-dev             
Maintainer: Klee Dienes and Ian Jackson <dpkg-maint@chiark.greenend.org.uk>
  20776  dpkg-dev: dpkg-dev does not use emacsen-commen method of in
  21186  dpkg-dev: dpkg-dev has a file also provided in dpkg

Package: dpkg-python          
Maintainer: Klee Dienes <klee@debian.org>                               
  23059  .py files must not install files into /usr/lib/python
[FIX] Fixing this would break other packages in hamm.  Gregor Hoffleit
      (python maintainer) said he would change the severity level of
      the bug to 'normal'.  Matthias Klose will fix it in slink.

Package: elib                 
Maintainer: Tom Lees <tom@lpsg.demon.co.uk>                             
  23810  Emacsen add-on packages must depend on emacsen, not emacsen

Package: general              (pseudo)
Maintainer: debian-devel@lists.debian.org                               
  23867  Critical permissions bug on /lib and /tmp
[STRATEGY] This might be a result of someone unpacking a package using
           /lib or /tmp as installation root. Being investigated.

Package: infocom              
Maintainer: Brian White <bcwhite@pobox.com>                             
  23563  infocom: /usr/doc/infocom/copyright doesn't include a licen

Package: ircd                 
Maintainer: Johnie Ingram <johnie@debian.org>                           
  23951  ircd: postisnt does not check for errors
[STRATEGY] Johnie will upload a new package with the fixes already made
           for slink.

Package: kdebase              (i386 contrib)
Maintainer: Stephan Kulow <coolo@kde.org>                               
  23655  kdebase includes /etc/X11/Xsession
[STRATEGY] David Engel: "Remove kdebase from hamm or move the beta4 slink
           packages from slink to hamm."

Package: libc5-dev            (m68k main)
Maintainer: Helmut Geyer <Helmut.Geyer@iwr.uni-heidelberg.de>           
  19347  libc5-dev: no-copyright-file LI#82
[STRATEGY] libc5-dev can be removed from m68k once libc5 5.4.38-1.1 has
      been compiled for it.

Package: libc6                
Maintainer: Dale Scheetz <dwarf@polaris.net>                            
  23893  libc6: "env LD_PRELOAD= ls" core dump

Package: libreadline2         
Maintainer: Guy Maor <maor@debian.org>                                  
  22941  libreadline2 depends on libc6

Package: libreadlineg2        
Maintainer: Guy Maor <maor@debian.org>                                  
  23035  bash: Not 8-bit clean.
[STRATEGY] Guy proposed a simple set-statement for a .bashrc to fix this

Package: libtool              
Maintainer: Frederic Lepied <Lepied@debian.org>                         
  23884  libtool: Insecure use of /tmp (?)

Package: mailx                
Maintainer: Loic Prylli <lprylli@graville.fdn.fr>                       
  23880  [alvaro@lander.es: [linux-security] security hole in mailx]

Package: nas                  
Maintainer: Steve McIntyre <stevem@chiark.greenend.org.uk>              
  23841  nas: init.d script fails to start au because of missing pat

Package: netbase              
Maintainer: Peter Tobias <tobias@et-inf.fho-emden.de>                   
  23995  netbase: Upgrade to 2.0 beta now makes Solaris 2.5.1 server

Package: nonus.debian.org     (pseudo)
Maintainer: Sven Rudolph <sr1@inf.tu-dresden.de>                        
This is being maintained by Heiko Schlittermann <heiko@lotte.sax.de>.
  18572  nonus.debian.org: remove des-solnet_1.03-5.deb
  18785  nonus.debian.org: incoming backlog
  20773  nonus.debian.org: please remove gnupg from frozen
  21423  Dpkg-ftp can't handle alternative distributions
[HELP] Yann Dirson: "This used to work until some date I don't know
       exactly. I guess that non-us has changed the paths they use
       in the Packages file."  (more info, and workaround, in the bug
       entry itself)
       (Bug has been reassigned from dpkg-ftp to nonus.debian.org)
  22287  nonus.debian.org with incorrect layout

Package: passwd               
Maintainer: Guy Maor <maor@debian.org>                                  
  21275  passwd: useradd violates base-passwd's rules

Package: smail                
Maintainer: Soenke Lange <soenke@escher.north.de>                       
  23717  smail: smtp entry in inetd.conf gone after smail upgrade

Package: sox                  
Maintainer: Geiger Guenter <geiger@iem.mhsg.ac.at>                      
  23913  SOX doesn't work at all

Package: ssh                  (i386 non-us)
Maintainer: Philip Hands <phil@hands.com>                               
[FIX] Philip Hands uploaded 1.2.25-1 on June 18, which fixes both the debug
      message and the security fix.
  22470  ssh: ssh spits out debugging messages because of socks4
[FIX] "I just uploaded 1.2.23-1 without socks support.  I'll wait for
       the problem to be resolved in libsocks before putting it back
       in again."

Package: wu-ftpd-academ       
Maintainer: Heiko Schlittermann <heiko@lotte.sax.de>                    
  17401  netstd overwrites ftpd.8.gz
  20355  wu-ftpd: contains ftpd.8.gz which is also present in netstd

Package: xadmin               
Maintainer: Turbo Fredriksson <turbo@debian.org>                        
  23053  xadmin does not set perms correctly for /etc/shadow
[FIX] This is fixed in xadmin 1.0.15-2, which has been installed in hamm.

Package: xbase                
Maintainer: Branden Robinson <branden@debian.org>                       
  22877  xbase: xdm port, and X applications
[HELP] "These have been forwarded upstream but I haven't heard anything
        from XFree86 about them to date.  Fixing them is beyond my knowledge."

To UNSUBSCRIBE, email to debian-devel-announce-request@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Reply to: