[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#852014: desktop-base: Boot hangs if plymouth is not installed

Tags: moreinfo unreproducible

Hi Marko.

Thank you for your bug report.
I'm not sure it's raised against the correct package tough, or I will need more information to analyze this problem.

Le 20 janvier 2017 19:00:37 GMT+01:00, "Marko Mäkelä" <msmakela@gmail.com> a écrit :
>Package: desktop-base
>Version: 9.0.1
>Severity: critical
>Justification: breaks the whole system
>Dear Maintainer,
>I run Debian unstable on my desktop. Today, after "apt update&&apt
>the system failed to boot.
>After some analysis (booting into rescue mode and entering the root
>password, and following the instructions to view the systemd log),
>I figured out that the fatal error was that
>exec /bin/plymouth failed, because the program was not installed.

Could you share more complete logs about that ?

>Finally, I figured out how to manually bring up the Ethernet interface
>and how to install plymouth. The next reboot worked.
>The command
>grep -lr plymouth /etc
>suggests that the existence of files in /usr/share/plymouth/themes
>led to the assumption that plymouth is available. I am filing this
>bug against desktop-base because dpkg -S suggests that the directory
>is associated with desktop-base.

This is really unrelated to desktop-base as far as I can tell.
The path you mention is used in a "case" branch specific to *buntu and Tanglu derivatives, and not for Debian. Please have a look at the contents of 05_debian_theme.

>Possibly this bug should be filed against grub-common instead, because
>grub-common owns the file /etc/grub.d/05_debian_theme which references
>the directory /usr/share/plymouth/themes.

Yes, I'd agree with that but I'm still unsure this is the real cause of your problem.

>Here are some versions of packages:
>desktop-base: 9.0.1
>grub-common: 2.02~beta3-3
>systemd: 232-12
>plymouth: 0.9.2-4
>I got the hang with systemd 232-9 and 232-11 before installing

I have a VM with up to date stretch and installed desktop-base 9.0.1 from sid, then uninstalled plymouth* and I could not reproduce the issue.

Additional information would be welcome !


Reply to: