[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Fglrx-glx can't be installed alongside libgl1-mesa-glx

This might be a bug, I'm honestly not sure. Currently I'm running sid
(yes I know, moving past that though)

The rest of the FGLRX packages installed no problem. But when I do
apt-get install fglrx-glx, it wants to remove libgl1-mesa-glx, along
with 224 other packages (basically... all of X, and KDE and a bunch of
other graphical programs, and for some reason it wants to INSTALL vlc)

Just out of curiousity I told apt to install Nvidia's glx' module to
see if the same result happened... it didn't. Nvidia's glx module it
correctly wants to remove fglrx, but thats it. It will install no
problem (assumably, haven't tried since I have an AMD card)

I have the update-alternatives packages installed so that once
FGLRX-glx and MESA-glx are installed, I can jump between them. But if
fglrx-glx is to be moved into testing and eventually stable, at some
point, something about that package (depends list maybe?) needs to be

If anyone is able to help me install fglrx-glx as a drop-in
replecement of mesa-glx, please give a shout. I've been using Fedora,
Gentoo and Arch a lot for the last few months, so my Apt's a bit

Reply to: