[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Wifi not working in Lenovo laptop/Ideapad/Atheros QCA9377

Attaching the mail to debian-debbugs list & debian-boot lists.
Please redirect if necessary. 
Summary : 
1) System hangs/stucks when firmware-atheros is installed. 
2) Thereaferwards Rebooting is not successfull.

Please help.


On Sun, Jun 2, 2019 at 12:12 PM senthil kosapeta <sendil.vlsi@gmail.com> wrote:
On Sat, Jun 1, 2019 at 6:54 PM tv.debian@googlemail.com <tv.debian@googlemail.com> wrote:
On 01/06/2019 16:52, senthil kosapeta wrote:
[...giant snip]
>>    I looked into the firmware-atheros package in Debian Stable (9),
>> backports, testing and unstable. Only the version in unstable currently
>> has the firmware file you need to make your wifi chip work
>> (/lib/firmware/ath10k/QCA9377/hw1.0/firmware-6.bin) .
>> You can download it yourself on one of the Debian mirrors:
>> https://packages.debian.org/sid/all/firmware-atheros/download
>> Then install the package with the command:
>> dpkg -i firmware-atheros_20190502-1_all.deb
>> This command must be issued in the directory where you downloaded the
>> package, and with root privileges.
>> When this is done, simply reboot your system, or unload/reload the
>> driver module with:
>> modprobe -r ath10k_pci
>> modprobe -r ath10k_core
>> modprobe -v ath10k_core
>> modprobe -v ath10k
>> Ignore the "irq=" option for now, I am on Debian unstable and wrongly
>> assumed you had the needed firmware file already on your system.
> HI,
> My system got crashed.
> After installing firmware-atheros, I tried modprobe commands. (Even before
> restarting)
> When i am done with last command which is "modprobe -v ath10k_pci", system
> got stuck.
> I had force shutdown, and restarting the laptop is hit with the same old
> problem like earlier crash.
> When i run through recovery mode, it says following (also seen during
> earlier crash)
> *ath10_pci *** : failed to recieve control response completion, polling ...*
> After that i tried booting via debian live usb, got the root prompt, tried
> following commands
>>> modprobe -r ath10k_pci
>>> modprobe -r ath10k_core
>>> modprobe -v ath10k_core
>>> modprobe -v ath10k_pci irq_mode=1
> It is still not working and is stuck while boot.
> Please suggest more.
> Sen

Hi, which version of the firmware-atheros package did you install ? Was
the installation successful, no error messages ?

When the boot sequence gets stuck, when exactly does it happen, what do
you see on the screen ? If you crashed the system a few times, the
file-system may need to be checked, did you see any message mentioning
"fsck" or file-system check ?

Nota: you can answer back to the list only, I am subscribed.


I installed the same version you have mentioned.
I did not see any error messages.

I am attaching the screenshots
It stucks after "Started D-bug system Message bus" only if i boot via recovery mode.
I don't see any clear messages when boot through normal mode, but it does not continue. (at the very beginning stage). 

I dont think of "file-system" problem because it runs fine until firmware-atheros is installed. 
Also i have run the the memory test and check everything is fine.

Senthil Kumar

Senthil Kumar
Mob No : 9000311791

Reply to: