[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#280600: libmime-perl: debbugs MIME handling no more work

On Mon, Nov 15, 2004 at 10:16:11AM +0000, Colin Watson wrote:
> On Fri, Nov 12, 2004 at 09:32:25AM -0500, David F. Skoll wrote:
> > This behaviour of MIME-tools (failing if an I/O operation fails) will
> > *not* be changed; I've had discussions about this before.
> > 
> > Silently permittion I/O operations to fail can be a security risk.  It's
> > up to users of MIME-tools to ensure that their underlying file handles
> > support the flush() method correctly.
> We use variously IO::Scalar and IO::Lines, both of which have a flush()
> method (the latter via IO::ScalarArray), so I'm slightly puzzled. Bill,
> I don't suppose you could do me a favour and investigate with 'perl -d'
> to see exactly which MIME-tools call is failing?

[Colin, my english skill let me at doubt on the meaning on that last
sentence, and I will just assume you tried to be overly polite.]

After learning a bit about CGI, I tried

QUERY_STRING="bug=89" sid perl -d ./bugreport.cgi

        MIME::Parser::process_singlepart('MIME::Parser=HASH(0x89a4024)', 'IO::Lines=GLOB(0x898b538)', 'MIME::Parser::Reader=HASH(0x898c258)', 'MIME::Entity=HASH(0x89ab380)') called at /usr/share/perl5/MIME/Parser.pm line 1049
        MIME::Parser::process_part('MIME::Parser=HASH(0x89a4024)', 'IO::Lines=GLOB(0x898b538)', 'MIME::Parser::Reader=HASH(0x898c258)', 'Retype', '') called at
/usr/share/perl5/MIME/Parser.pm line 714
        MIME::Parser::process_multipart('MIME::Parser=HASH(0x89a4024)', 'IO::Lines=GLOB(0x898b538)', 'MIME::Parser::Reader=HASH(0x898c0fc)', 'MIME::Entity=HASH(0x898c150)') called at /usr/share/perl5/MIME/Parser.pm line 1039
        MIME::Parser::process_part('MIME::Parser=HASH(0x89a4024)', 'IO::Lines=GLOB(0x898b538)', 'undef') called at /usr/share/perl5/MIME/Parser.pm line 1143
        MIME::Parser::parse('MIME::Parser=HASH(0x89a4024)', 'IO::Lines=GLOB(0x898b538)') called at ./bugreport.cgi line 281

Lines  277-281 are 
                   my $parser = new MIME::Parser;
#                  $parser->output_under("/tmp");
                   my $entity = $parser->parse( new IO::Lines \@mail );

At this point @mail contains (line by line) an email with MIME
attachement, so I suspect $parser was not set up correctly.

Bill. <ballombe@debian.org>

Imagine a large red swirl here. 

Reply to: