[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Simple-cdd and etch

On 2/20/06, Vagrant Cascadian <vagrant@freegeek.org> wrote:
i have only developed and tested simple-cdd with sarge. others have
tried it, but i do not know how sucessful they have been.

by default, it will pull in whatever distribution debian-cd pulls in by
default. you can set any environment variable that debian-cd supports in
simple-cdd.conf- to change the distribution pulled in, you may want to
set the CODENAME variable (be sure to do so before the line that sources
debian-cd's CONF.sh).

Sorry for late reply but I'm in a hurry here. I tryed to build up simple-cdd under etch but I've found some interesting problems. Here the following error after build-simple-cdd run:

/usr/bin/mkisofs: Uh oh, I cant find the boot catalog directory 'isolinux'!
make: ** [bin-image] Erro 255

The most interesting part of this is isolinux directory and files already exist. I have no idea why this exception occurs so I made a search into build-simple-cdd file and I've found  implicit declarations of _sarge_ word. Here is the quoted part of the file:

cd $BASEDIR/tools/boot/sarge
  cat boot-i386 | sed -e 's/TIMEOUT 0/TIMEOUT 5/g' > boot-i386.new && \
    chmod +x boot-i386.new && \
    mv -f boot-i386.new boot-i386 || echo "WARNING: timeout could not be set."

and this,

if [ "true" = "$default_26_kernel" ]; then
  echo "setting to use 2.6 kenel by default"
  cd $BASEDIR/tools/boot/sarge
  cat boot-i386 | sed -e 's,/install/initrd.gz,/install/2.6/initrd.gz,g' -e 's,/install/vmlinuz,/install/2.6/vmlinuz,g' > boot-i386.new && \
    chmod +x boot-i386.new && \
    mv -f boot-i386.new boot-i386 || echo "WARNING: could not be set 2.6 kernel."

I dont know if those declarations can cause fail in build _etch_ proccess. Finally I tryed to update debian-cd to etch but the same error persists. I'm interested in help you with the porting proccess to etch and others versions of Debian GNU/Linux.


Matheus Morais

Reply to: