[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#682010: [mumble] Communication failures due to CELT codec library removal

On Monday, July 23, 2012 04:52:29, Nicos Gollan wrote:
> Hi,
> On Monday 23 July 2012 00:31:27 Chris Knadle wrote:
> > This means that the Opus-only client ruins the audio connection for
> > everybody else that's connected, at least in this case.
> That happens because the maintainer patch "20-add-opus-threshold-option"
> sets the threshold variable default to 1, which is a pretty nonsensical
> value in most situations. It only really makes sense to set it to 0 or
> 100, unless you want to fabricate some really weird behaviour in codec
> negotiation…

Yes I see that opusthreshold is commented out, and iOpusThreshold = 1.
I've verified that this patch doesn't exist in the "348" version in Wheezy -- 
nor does it contain patches in relation to Opus.

> In that case, any client with Opus support should trigger the issue, no
> matter if it supports CELT.
> Just for completeness' sake, this is _not_ an upstream issue, the value is
> initialised to 100 there.
> I guess manually setting "opusthreshold=100" in your murmur.ini would
> restore sane behaviour on the server side, but I'm not inclined to dig
> through the other maintainer patches to see what else is interfering at
> this point.

When it comes to the -2 version in Sid I hope it will only be necessary to get 
the build fixes required to build "348" -1 in Wheezy.

  -- Chris

Chris Knadle

Reply to: