[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Bug#682010: re celt and mumble referred to the TC

On Friday, July 20, 2012 10:21:17, Ian Jackson wrote:
> Chris Knadle writes ("Re: Bug#682010: re celt and mumble referred to the 
> > On Friday, July 20, 2012 01:47:21, Chris Knadle wrote:
> > […]
> > 
> > > From this test I draw the following conclusions:
> > […]
> > 
> > >    - Once -2 of the Mumble client is migrated to Testing we will be
> > >    
> > >      fully committed to the plan
> > 
> > Update: scratch the above, the "348" version of Mumble in Wheezy as
> > it is now won't build anyway, so there's no harm in migrating -2
> > from Sid

I'm going to reverse the order of your two questions below.

> It won't build in sid because sid is missing celt but it will build
> in wheezy.

Negative.  It builds fine in Sid, without celt being required.  But because it 
does not use the celt library (regardless of whether it is installed) clients 
cannot voice communicate with any server with connected clients that require 
using anything other than Opus.  Text communication always works.

> Why won't it build ?  

The mumble source pacakge will not build in Wheezy on amd64 due to Wheezy 
getting an upgrade to gcc 4.7 in relation with zero-ice.

Phillip Kern sent the following link to (Bug #675971, msg #131):


On i386 the package does build, but due to ABI breakage in zero-ice, mumble-
server is unable to start and spits out an error on every invocation.

I'm working on getting you a build log from a Wheezy amd64 VM.

  -- Chris

Chris Knadle
GPG Key: 4096R/0x1E759A726A9FDD74

Attachment: signature.asc
Description: This is a digitally signed message part.

Reply to: