[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#614907: [Pkg-javascript-devel] Bug#680080: Invalidated by dependency: Excuse for mediawiki-extensions

[keeping all recipients - don't blame me for the noise]

On 12-07-10 at 03:58pm, Thorsten Glaser wrote:
> On Tue, 10 Jul 2012, Jonas Smedegaard wrote:
> > I am concerned about switching compressor - see the discussion at 
> > bug#679665.
> I see. (But yui was used before, right? Why the switch away from it, 
> then?)

Because it performs worse, which makes it less used in general, which 
makes it less tested, which makes it less trustworthy.  I thought that 
was already clarified at bug#679665.  Does it make sense now?

> On the other hand, the IMHO best fix for the overall situation of 
> developers trying to follow Policy and replace courtesy copies of 
> ECMAscript libraries with packaged versions would be to ship the 
> nōn-minified versions right now, with the .min.js being symlinks to 
> them, and upload packages that compress again once a suitable solution 
> for compressing is found, of course under the assumption that the 
> Release Managers will grant a freeze exception for such, if asked 
> beforehand I’m sure they will.

As I already mentioned in bug#679665, replacing files with symlinks are 
bad here, because some web server setups treat symlinks specially.

Apart from the symlinking, it seems you are talking about same as my 
option c) as clarified at http://bugs.debian.org/679665#25 .

It is helpful that you introduce _different_ approaches if you have 
ideas you think might be better, but less helpful to repost existing 
ones rephrased.  Please do elaborate if I am mistaken and your proposal 
is really a new one.


 - Jonas

 * Jonas Smedegaard - idealist & Internet-arkitekt
 * Tlf.: +45 40843136  Website: http://dr.jones.dk/

 [x] quote me freely  [ ] ask before reusing  [ ] keep private

Attachment: signature.asc
Description: Digital signature

Reply to: