Re: Bug#1057359: qmake: use qmake6 when QT_SELECT=qt6
- To: Salvo Tomaselli <tiposchi@tiscali.it>, 1057359@bugs.debian.org
- Cc: debian-devel-games@lists.debian.org, Alexandre Detiste <alexandre.detiste@gmail.com>, debian-qt-kde@lists.debian.org, debian-cross@lists.debian.org
- Subject: Re: Bug#1057359: qmake: use qmake6 when QT_SELECT=qt6
- From: Helmut Grohne <helmut@subdivi.de>
- Date: Mon, 11 Dec 2023 16:30:14 +0100
- Message-id: <[🔎] 20231211153014.GA3196394@subdivi.de>
- Mail-followup-to: Salvo Tomaselli <tiposchi@tiscali.it>, 1057359@bugs.debian.org, debian-devel-games@lists.debian.org, Alexandre Detiste <alexandre.detiste@gmail.com>, debian-qt-kde@lists.debian.org, debian-cross@lists.debian.org
- In-reply-to: <3002826.mvXUDI8C0e@galatea>
- References: <170164472969.12203.4438449851020664320.reportbug@localhost> <170164472969.12203.4438449851020664320.reportbug@localhost> <3002826.mvXUDI8C0e@galatea>
Hi,
On Mon, Dec 04, 2023 at 10:58:44AM +0100, Salvo Tomaselli wrote:
> I use this in my rules when using qt6
>
>
> %:
> dh $@
>
> override_dh_auto_configure:
> ln -s /usr/bin/qmake6 ./qmake
> PATH=`pwd`:$(PATH) dh_auto_configure
>
> override_dh_auto_clean:
> $(RM) qmake
> dh_auto_clean
This is also being used in src:explosive-c4 now and the approach breaks
cross compilation. Please stop doing this, we'll have to touch all of
these.
Still the use case is real and we need a better way to build packages
with qmake6. I was talking with Sune and Lisandro on IRC and their
consensus seems to have been that qtchooser and QT_SELECT are dead and
should not be used for Qt6. They suggested that we add add a new
--buildsystem to debhelper. We already have qmake_qt4 and qmake, why not
have qmake6? While changing QT_SELECT from qt5 to qt6 would be
convenient, changing it to "dh $@ --buildsystem qmake6" is easy enough,
no? The qmake6 build system can reuse qmake just like qmake_qt4 and
doing it that way immediately makes cross compilation just work (since
we already have <triplet>-qmake6). Lisandro requested naming it qmake6
rather than qmake_qt6. Even though this breaks consistency with earlier
use in debhelper, the similarity to how upstream calls it more
important.
Salvo and Alexandre, do you second this?
Can I also get some ack from Qt maintainers such that we can move
forward in consensus?
Helmut
diff --minimal -Nru debhelper-13.11.8/debian/changelog debhelper-13.11.9/debian/changelog
--- debhelper-13.11.8/debian/changelog 2023-11-15 09:10:26.000000000 +0100
+++ debhelper-13.11.9/debian/changelog 2023-12-11 16:21:08.000000000 +0100
@@ -1,3 +1,9 @@
+debhelper (13.11.9) UNRELEASED; urgency=medium
+
+ * Add the qmake6 build system. (Closes: #-1)
+
+ -- Helmut Grohne <helmut@subdivi.de> Mon, 11 Dec 2023 16:21:08 +0100
+
debhelper (13.11.8) unstable; urgency=medium
* Team upload.
diff --minimal -Nru debhelper-13.11.8/lib/Debian/Debhelper/Buildsystem/qmake6.pm debhelper-13.11.9/lib/Debian/Debhelper/Buildsystem/qmake6.pm
--- debhelper-13.11.8/lib/Debian/Debhelper/Buildsystem/qmake6.pm 1970-01-01 01:00:00.000000000 +0100
+++ debhelper-13.11.9/lib/Debian/Debhelper/Buildsystem/qmake6.pm 2023-12-11 16:20:28.000000000 +0100
@@ -0,0 +1,15 @@
+package Debian::Debhelper::Buildsystem::qmake6;
+
+use strict;
+use warnings;
+use parent qw(Debian::Debhelper::Buildsystem::qmake);
+
+sub DESCRIPTION {
+ "qmake for QT 6 (*.pro)";
+}
+
+sub _qmake {
+ return 'qmake6';
+}
+
+1
Reply to: