[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#732788: marked as done (overlayroot useless without kernel module overlayfs)

Your message dated Thu, 30 Dec 2021 11:32:51 +0100
with message-id <8b842913-5aef-2e45-b6fa-120480bd1fd2@debian.org>
and subject line Re: Processed (with 5 errors): 732788
has caused the Debian Bug report #732788,
regarding overlayroot useless without kernel module overlayfs
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact owner@bugs.debian.org

732788: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=732788
Debian Bug Tracking System
Contact owner@bugs.debian.org with problems
--- Begin Message ---
Package: overlayroot
Severity: grave
Justification: renders package unusable

Dear Maintainer,

I tried to use the package overlayroot. But it seems to me not useable.
At startup the package complains about the missing kernel module overlayfs. But
this kernel module is not part of any debian package.

However, the initrd script of overlayroot seems to be prepared for aufs, too.
But there is no way to tell that it should use aufs and the script does not
detect the kernel module. And the initrd hook script does not integrate aufs.

If I integrate aufs into the initrd and set overlayfs_driver manualy to aufs,
overlayroot says that everything is ok. But it does not work. Overlayroot is
not able to create the fstab for aufs.

It seems to me that overlayroot does not work at all. I suggest either remove
this package until overlayfs is part of debian or make this package useable
with aufs.

-- System Information:
Debian Release: jessie/sid
  APT prefers testing
  APT policy: (500, 'testing'), (500, 'stable')
Architecture: amd64 (x86_64)
Foreign Architectures: i386

Kernel: Linux 3.11-2-amd64 (SMP w/4 CPU cores)
Locale: LANG=de_DE.UTF-8, LC_CTYPE=de_DE.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

--- End Message ---
--- Begin Message ---
On 12/30/21 12:32 AM, Carl Karsten wrote:
> Hello!
> overlayfs is now included, and overlayroot package from ubuntu works
> on a distro cocktail mix of Raspberry Pi and Ubuntu:
> wget -N http://launchpadlibrarian.net/493868580/overlayroot_0.47ubuntu1_all.deb
> apt install --assume-yes ./overlayroot_0.47ubuntu1_all.deb
> KERN=$(uname -r)
> update-initramfs -c -k "${KERN}"
> https://github.com/CarlFK/pici/blob/main/files/rpi/setup3.sh#L20-L28
> It isn't clear why I need "update-initramfs" but if you can put it
> into unstable I'll be happy to test and report my results.

Yeah, but the package still doesn't need a fix. overlayroot!=aufs and
it's fine if the package is still removed from Debian.


Thomas Goirand (zigo)

--- End Message ---

Reply to: