[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Vagrant libvirt mount error rpc.statd

Le 10/06/2016 18:34, Martin Vietz a écrit :
> Hi Antonio,
> On 10.06.2016 12:58, Antonio Terceiro wrote:
>> When it worked before, was it using NFS, or rsync? See
>> https://github.com/vagrant-libvirt/vagrant-libvirt/issues/419 for a
>> discussion on an issue where vagrant chooses a synced folder backend
>> non-deterministically.
> It looks, like nfs:
> | vagrant@jessie:~$ mount | grep /vagrant
> | on /vagrant type
> nfs(rw,relatime,vers=3,rsize=32768,wsize=32768,namlen=255,hard,proto=udp,timeo=11,retrans=3,sec=sys,mountaddr=,mountvers=3,mountport=20048,mountproto=udp,local_lock=none,addr=
> | vagrant@jessie:~$ cat /etc/debian_version
> | 8.4
> A "vagrant destroy && vagrant up" had the same results.
>> Actually, I wanted to make 9p the default in the libvirt boxes, but it
>> seems not all distros have 9p enabled in qemu and/or linux.
> I have tried a debian box with 9p on my fedora workstation a few months
> ago. If I correct remember it works, but only unidirectional.

As long as a write in the host is synced is in the guest, it's fine for
the standard vagrant uses. (ie I do dev on my host, but my programm is
running in the guest)
The rsync synced folder backend is also unidirectional.

Reply to: