[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#1001722: python3.10: autopkgtest needs update for new version of setuptools: deprecation warning on stderr



Source: python3.10
Version: 3.10.1-1
Severity: serious
X-Debbugs-CC: debian-ci@lists.debian.org, setuptools@packages.debian.org
Tags: sid bookworm
User: debian-ci@lists.debian.org
Usertags: needs-update
Control: affects -1 src:setuptools

Dear maintainer(s),

With a recent upload of setuptools the autopkgtest of python3.10 fails in testing when that autopkgtest is run with the binary packages of setuptools from unstable. It passes when run with only packages from testing. In tabular form:

                       pass            fail
setuptools             from testing    59.4.0-1
python3.10             from testing    3.10.1-1
all others             from testing    from testing

I copied some of the output at the bottom of this report. The test fails because there is a deprecation warning on stderr and the allow-stderr restriction is not set on the autopkgtest.

Currently this regression is blocking the migration of setuptools to testing [1]. Of course, setuptools shouldn't just break your autopkgtest (or even worse, your package), but it seems to me that the change in setuptools was intended and your package needs to update to the new situation.

More information about this bug and the reason for filing it can be found on
https://wiki.debian.org/ContinuousIntegration/RegressionEmailInformation

Paul

[1] https://qa.debian.org/excuses.php?package=setuptools

https://ci.debian.net/data/autopkgtest/testing/amd64/p/python3.10/17559467/log.gz

testFibPy
running install
/usr/lib/python3/dist-packages/setuptools/command/install.py:34: SetuptoolsDeprecationWarning: setup.py install is deprecated. Use build and pip and other standards-based tools.
  warnings.warn(
/usr/lib/python3/dist-packages/setuptools/command/easy_install.py:158: EasyInstallDeprecationWarning: easy_install command is deprecated. Use build and pip and other standards-based tools.
  warnings.warn(
running bdist_egg
running egg_info
creating fibpy.egg-info
writing fibpy.egg-info/PKG-INFO
writing dependency_links to fibpy.egg-info/dependency_links.txt
writing top-level names to fibpy.egg-info/top_level.txt
writing manifest file 'fibpy.egg-info/SOURCES.txt'
reading manifest file 'fibpy.egg-info/SOURCES.txt'
writing manifest file 'fibpy.egg-info/SOURCES.txt'
installing library code to build/bdist.linux-x86_64/egg
running install_lib
running build_py
creating build
creating build/lib
copying fibpy.py -> build/lib
creating build/bdist.linux-x86_64
creating build/bdist.linux-x86_64/egg
copying build/lib/fibpy.py -> build/bdist.linux-x86_64/egg
byte-compiling build/bdist.linux-x86_64/egg/fibpy.py to fibpy.cpython-310.pyc
creating build/bdist.linux-x86_64/egg/EGG-INFO
copying fibpy.egg-info/PKG-INFO -> build/bdist.linux-x86_64/egg/EGG-INFO
copying fibpy.egg-info/SOURCES.txt -> build/bdist.linux-x86_64/egg/EGG-INFO
copying fibpy.egg-info/dependency_links.txt -> build/bdist.linux-x86_64/egg/EGG-INFO copying fibpy.egg-info/top_level.txt -> build/bdist.linux-x86_64/egg/EGG-INFO
copying fibpy.egg-info/zip-safe -> build/bdist.linux-x86_64/egg/EGG-INFO
creating dist
creating 'dist/fibpy-42.0.0-py3.10.egg' and adding 'build/bdist.linux-x86_64/egg' to it
removing 'build/bdist.linux-x86_64/egg' (and everything under it)
Processing fibpy-42.0.0-py3.10.egg
Copying fibpy-42.0.0-py3.10.egg to /usr/lib/python3.10/dist-packages
Adding fibpy 42.0.0 to easy-install.pth file

Attachment: OpenPGP_signature
Description: OpenPGP digital signature


Reply to: