[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

I proudly present: first version of apt-release


On 26-01-17 13:50, Martin Pitt wrote:
> Paul Gevers [2017-01-23 22:19 +0100]:
>> It looks like I have something working that generalizes --apt-pocket in
>> an --apt-release option and use that generalization to still support
>> that --apt-pocket. While at it, I have added a check on the suite name
>> versus code name issue I discussed earlier.
> Nice! Comments below inline.

Appreciated, thanks.

> Until then, you can also push the tree to github or similar, where it's nice to
> comment/discuss inline.

I'll probably do that shortly then.

>> --- a/lib/adt_run_args.py
>> +++ b/lib/adt_run_args.py
> TBH, I wouldn't bother with adding new options to adt-run. It's been deprecated
> for a while and I really don't want new deployments to use adt-run (I want to
> drop it after the stretch release).

I thought about that, so ack. Will remove it again.

>> --- a/lib/adt_testbed.py
>> +++ b/lib/adt_testbed.py
>> @@ -46,7 +46,7 @@ timeouts = {'short': 100, 'copy': 300, 'install': 3000, 'test': 10000,
>>  class Testbed:
>>      def __init__(self, vserver_argv, output_dir, user,
>>                   setup_commands=[], setup_commands_boot=[], add_apt_pockets=[],
>> -                 copy_files=[]):
>> +                 add_apt_releases=[], copy_files=[]):
> This is probably bikeshedding matter, but my feeling is that this new
> option/variables should be --apt-series/SERIES/add_apt_series. I. e. if you
> have "jessie-backports", then the release of that is "jessie", the pocket is
> "backports", and the series is the combination ("jessie-backports"), AFAIUI?

I think it is worth bikeshedding about, to be honest. I must admit that
to me it isn't 100% clear which name means what. I have the impression
it is used for different things in different contexts.

Reply to: