[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#800845: autopkgtest: Add support for nested VMs

Hi Martin,

On 04.03.2016 13:16, Martin Pitt wrote:
> Indeed it seems Ubuntu's qemu is modified accordingly
> (https://launchpad.net/ubuntu/+source/qemu/1:2.5+dfsg-5ubuntu1):
>     - d/p/ubuntu/expose-vmx_qemu64cpu.patch: enable nested kvm by default
>       in qemu64 cpu type.

Oh, that explains it. I tried it under Debian, where this patch isn't
applied. :)

>> This is kind of a bummer for me, because I'd really like to have
>> continuous integration for actual functionality that relies on
>> nested VMs. But in principle qemu should run in the cloud, right?
> In most Openstack ones at least, yes. There are other nova-compute
> backends like libvirt or lxc, though.

But I expect QEMU to run in e.g. LXC, at least if /dev/kvm is available.
(Haven't tried it though.) I mean, QEMU runs as a normal user, so I
don't see how LXC would interfere. (Except for device group permissions
for /dev/kvm, but that can be remedied.)

Also, at least in my case, I require isolation-machine anyway, because
the server I set up is also kernel-related, so I need VMs. In other
cases it could be the case though that QEMU within LXC would be
sufficient for testing the software.

>> So it's only a question of whether it's somehow possible to get
>> a working base image in there?
> Right. Openstack/EC2 hide this pretty well, so there's no way to get
> the base image into the instance directly :-( It's of course possible
> to download a public cloud image in the test, but that's much less
> convenient.

Yes. Ok, let's take it one step at a time: first get nested VM support
working in general for the QEMU runner, and then discuss this with the
people working on the automatic CI parts of that. (One could also make
the case that for the few packages that really need nested VM support -
it's not going to be more than a couple of dozen I guess - you could
just create a dedicated Jenkins job for those that uses the QEMU runner.
Maybe that's just the simplest solution.)


-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 801 bytes
Desc: OpenPGP digital signature
URL: <http://lists.alioth.debian.org/pipermail/autopkgtest-devel/attachments/20160304/a342c901/attachment-0001.sig>

Reply to: