[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#644332: autopkgtest: uses python2.6



Jakub Wilk writes ("Bug#644332: autopkgtest: uses python2.6"):
> Source: autopkgtest
> Version: 2.0.1
> Severity: normal
> User: debian-python at lists.debian.org
> Usertags: python2.6-removal
> 
> Python 2.6 is not a default version anymore, and it will be removed from 
> Debian at some point in future. Is there any reason that autopkgtest 
> doesn't use the default version?

Python is not necessarily compatible across versions so when I wrote
autopkgtest I used a specific python version to avoid it breaking in
the future.  Now that 2.7 is the last it's probably appropriate to
rethink this.

I'll see if I can do a test.  But if someone else gets there first
and sends a tested patch that would be great :-).

Ian.





Reply to: