[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#803938: extlinux: boot from xfs partition not working

Hi Marek,

I've recently taken over maintenance of syslinux/exlinux as part of
the Debian CD Group, so I it's time to have a look at my own bug report.
Thanks for providing the link to the upstream changelog :) .

I've just compiled the most recent version of syslinux from git.  It
turns out that even this version can only boot from XFS partitions if
an MBR partition scheme is used.  With a GPT partition scheme, booting
is still not possible (same error as above).  I only then noticed that,
according to the wiki [1], syslinux only supports booting from XFS in
MBR partition schemes:

    As of Syslinux 6.03, an XFS partition in an "MBR" partition scheme
    is supported.

I've cloned the bug to track the MBR [2] and GPT [3] problems
separately.  I should be able to close the XFS+MBR problem eventually.
Since XFS+GPT is not yet supported upstream and it doesn't look like
anyone is actively working on that at the moment, I doubt that can be
fixed anytime soon.


[1] http://www.syslinux.org/wiki/index.php?title=Filesystem#XFS
[2] https://bugs.debian.org/803938
[3] https://bugs.debian.org/879543

Reply to: