[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#789600: cdimage.debian.org: Missing 'part_gpt' in Release ISO's GRUB EFI -> Debian 8.0 cannot be booted from GPT/FAT32 drive in UEFI mode

Package: cdimage.debian.org
Severity: important
Tags: newcomer

Dear Maintainers,

It appears that the Debian 8.0 "Jessie" ISO release uses a GRUB binary that
doesn't embed the 'part_gpt' GRUB module.

Because of this, if you happen to copy the "Jessie" ISO content onto a FAT32
drive (eg: USB Flash Drive) that was partitioned using GPT, you will end up
with the GRUB rescue prompt when booting on a UEFI system, as GRUB will not be
able to locate the installation files on the GPT drive.

Note that this is only an issue if you copy content into an installation media
that is GPT: If you use 'dd' to create the installation media from the
ISOHybrid, or copy the content to a FAT32 drive that uses the MBR partition
scheme, then the problem does not occur.

Looking at the GRUB EFI binary's strings from the ISO, it seems that 'part_gpt'
was not embedded, which in turn prevents the embedded 'grub.cfg' from locating
the '/.disk/info' marker during the search for the root media, as it cannot
access GPT volumes.

I'm hoping that the GRUB EFI binary can be modified for next ISO release to
include 'part_gpt', as this should prevent this issue.

The expectation is that Windows users, who may have heard that simply copying
the Debian ISO content on a FAT32 drive should work with UEFI systems (and who
prefer using that method because they find DD/image tools a bit daunting), will
encounter this issue if they happen to copy the ISO data onto a drive that was
partitioned in GPT mode.
This is also a problem for Windows USB installation tools, such as Rufus, if
you set the USB partition scheme to GPT, as it also uses the ISO -> FAT32 copy

* What led up to the situation?
  Trying to install Debian 8.0 in UEFI mode on an intel NUC (D54250WYK), after
copying the whole ISO content to an USB drive with a single GPT/FAT32

* What exactly did you do (or not do) that was effective (or ineffective)?
  Tried to use the GRUB rescue prompt, but was unable access the USB disk.
  After recreating the USB installation media using an MBR/FAT32 partition, I
found that it worked, which demonstrates that this is a GPT vs MBR partition
scheme issue.
  Finally, looking at the GRUB binary on the Release ISO, it seems pretty clear
that the 'part_gpt' module is missing, which I believe is required, even in
UEFI mode, to access GPT partitioned drives.



-- System Information:
Debian Release: 8.1
  APT prefers stable
  APT policy: (500, 'stable')
Architecture: amd64 (x86_64)

Kernel: Linux 3.16.0-4-amd64 (SMP w/2 CPU cores)
Locale: LANG=en_GB.UTF-8, LC_CTYPE=en_GB.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)

Reply to: