[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#251825: marked as done (full cd isses: missing netcfg, missing kernel for modern macs)

Your message dated Sun, 8 Oct 2006 13:35:11 +0100
with message-id <20061008123510.GX30190@einval.com>
and subject line Closing old bugs
has caused the attached Bug report to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what I am
talking about this indicates a serious mail system misconfiguration
somewhere.  Please contact me immediately.)

Debian bug tracking system administrator
(administrator, Debian Bugs database)

--- Begin Message ---
Package: debian-installer
Version: sarge 20040523 CD

I booted the install CD in expert mode, and was able to progress
through the installation until picking a kernel.  I picked the
kernel-image-2.6.6-powerpc (I also tried 2.4.25-powerpc-small-pmac and
got the same result).  It failed to install, producing these error

  You are attempting to install an initrd kernel image (version 2.6.6-powerpc)
  This will not work unless you have configured your boot loader to use
  initrd. (An initrd image is a kernel image that expects to use an INITial
  Ram Disk to mount a minimal root file system into RAM and use that for

  I repeat, You need to configure your boot loader -- please read your
  bootloader documentation for details on how to add initrd images.

  If you have already done so, and you wish to get rid of this message,
  please put
    `do_initrd = Yes'
  in /etc/kernel-img.conf. Note that this is optional, but if you do not,
  you'll continue to see this message whenever you install a kernel
  image using initrd.
  Do you want to stop now? [Y/n]OK, Aborting
  dpkg: error processing /derom/pool/main/k/kernel-patch-powerpc-2.6.6/kernel-image/2.6.6-powerpc_2.6.6-2_powerpc.deb (--unpack):
   subprocess pre-installation script returned error exit status 1

I don't know whether the yaboot configuration stuff (which comes later
in debian-installer) know how to handle an initrd 2.6 (or 2.4) kernel.
There was no documentation in the manuals about whether or when it is
appropriate to use 2.6 kernels in debian-installer...

...and no documentation anywhere visible, about which of the dozen+
kernels is even for which hardware!

(I tried rebooting and reinstalling and editing that file, as it
suggested, but before the kernel install, the file doesn't exist; and
the failure happens very soon after you pick the kernel to install.)


PS:  I had tried to do this install in non-expert mode, but you can see
the results of that in bug#248067.  It picked the 2.4.25-powerpc-smp-prep
kernel (I don't know if that works on a PowerBook G4 -- it says it's for a
PrEP computer, which I've never heard of).  But then it didn't install
anyway, with a "(=D) is not a directory" error message.

--- End Message ---
--- Begin Message ---
 #218032 - Descarga CD's con jigdo
 #239078 - install: Beta3, BIOS does not boot CD
 #239290 - Can not boot the CD at all
 #246948 - No error if CD is ejected while integrity is being tested
 #248055 - missing appropriate powerpc kernel on sarge CD
 #251825 - full cd isses: missing netcfg, missing kernel for modern macs
d-i and debian CDs have seen lots of development (including a stable
release and several etch betas) since the last traffic on these bugs,
so I'm closing these - the reported problems should all be fixed by
now. If you're still experiencing problems, please re-open or open a
new bug against newer versions.

Steve McIntyre, Cambridge, UK.                                steve@einval.com
Who needs computer imagery when you've got Brian Blessed?

Attachment: signature.asc
Description: Digital signature

--- End Message ---

Reply to: