[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: About RockRidge

Hi Michelle,

Tks for your advice.

>   1)  dd if=/dev/zero of=new_cd_image.raw bs=1M count=650
>   2)  mkfs.ext2 -b 1024 -m 0 new_cd_image.raw
>   3)  mount new_cd_image.raw /mnt -o loop
>   4)  Copy your stuff onto it
>   5)  Burn the RAW image onto CD

I tried the steps but did succeed.  I made the test on a FC3 PC on
another location as I did not have a Knoppix LiveCD 4.0.2 in hand.

Steps performed as follows;
# dd if=/dev/zero of=new_cd_image.raw bs=1M count=650
650+0 records in
650+0 records out
# mkfs -t ext3 -b 1024 -m 0 new_cd_image.raw
mke2fs 1.38 (30-Jun-2005)
new_cd_image.raw is not a block special device.
Proceed anyway? (y,n) y
Filesystem label=
OS type: Linux
Block size=1024 (log=0)
Fragment size=1024 (log=0)
83312 inodes, 665600 blocks
0 blocks (0.00%) reserved for the super user
First data block=1
Maximum filesystem blocks=67895296
82 block groups
8192 blocks per group, 8192 fragments per group
1016 inodes per group
Superblock backups stored on blocks:
        8193, 24577, 40961, 57345, 73729, 204801, 221185, 401409,

Writing inode tables: done
Creating journal (16384 blocks): done
Writing superblocks and filesystem accounting information: done

This filesystem will be automatically checked every 34 mounts or
180 days, whichever comes first.  Use tune2fs -c or -i to override.

(Remark: the files to be copied on a partition of fs ext3

also tested "mkfs.ext2 -b 1024 -m 0 new_cd_image.raw"
with the same result, not successful)

# cp /home/satimis/Documents/FedoraCore3/ /mnt/
cp: omitting directory `/home/satimis/Documents/FedoraCore3/'

# du -h new_cd_image.raw
651M    new_cd_image.raw

# ls -al /mnt/
total 21
drwxr-xr-x   3 root root  1024 Jan 31 10:54 .
drwxr-xr-x  25 root root  4096 Jan 31 09:25 ..
drwx------   2 root root 12288 Jan 31 10:54 lost+found

To my surprize, there was nothing inside

# ls /mnt/new_cd_image.raw
ls: /mnt/new_cd_image.raw: No such file or directory

# umount /mnt/
# du -h new_cd_image.raw
651M    new_cd_image.raw
(Remark:  Also tested without "umount /mnt".  Same result,

Continued burning CD
# cdrecord dev=ATA:1,0,0 speed=10 -v -eject new_cd_image.raw
Average write speed   9.9x.
Min drive buffer fill was 98%
Fixating time:   26.990s
cdrecord: fifo had 10736 puts and 10736 gets.
cdrecord: fifo was 0 times empty and 10467 times full, min fill was

# mount /dev/hdc /mnt/cdwriter
mount: block device /dev/hdc is write-protected, mounting read-only
mount: wrong fs type, bad option, bad superblock on /dev/hdc,
or too many mounted file systems
Please check that the disk is entered correctly.

I could not read the CD.  Whether the steps only work on Knoppix



Reply to: