[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

[no subject]

On Sat, 2002-08-10 at 13:03, Richard Atterer wrote:
Hello Nelson,

I'm not sure about the source of the problem - you are the first
person to report something like that. What version of jigdo-lite are
you using, and on what kernel?

Sorry for the lack of information 8-) the Jigdo version is the last: 0.6.8 I'm using for now Debian Woody Unstable, dated April 15, 2002 using now the kernel 2.4.18-k7 (got a AMD Athlon 950) the date for all the dics that I have it's not the same: 1. 15-04-2002 2. 29-03-2002 3. 29-04-2002 4. idem 5. idem 6. idem 7. idem 8. 15-04-2002 how do you figure out it, APT has a lot of files holded.

On Fri, Aug 09, 2002 at 08:36:41PM -0400, Nelson Suniaga  wrote:
> Yes, I got a .iso.tmp image (why still it has a .tmp > extension?),

Because it isn't finished yet. Once all the data has been written to
it, it is renamed to just ".iso".

> `/mnt/iso/pool/main/g/gnome-libs/libgnome32_1.4.1.4-3_i386.deb'
> does not match checksum in template data

That is weird. It means that when jigdo read in that .deb for the
first time to find out its checksum, the checksum matched, but when it
later wanted to write the .deb to the .iso.tmp file, the checksum no
longer matched.
Exactly! that's very strange, it's just like someone o some thing change the numbers inside the file after the process reading.

> Really I can't get it, can someone explain me this? ah...! almost I
> forget it: all those files with wrong checksums are differents
> everytime that I run jigdo-lite...

Very strange indeed. Are you sure the CD/harddisc containing /mnt/iso
does not have read errors?

my hard disc it's some old (Samsung with 6 GB) but anyway, how I can know if my disc it's possesed with bad spirits or bad sectors? I did it a resizing to the partitions, cause it didn't has enough space for the iso image... the image it must will be created on /opt/tmp Filesystem 1k-blocks Used Available Use% Mounted on /dev/hda5 2583624 2062476 468620 82% / /dev/hda6 514144 388736 114968 78% /home /dev/hda7 1391380 654852 722392 48% /opt /dev/hda1 1627368 1503172 124196 93% /win what do you think about it? Ah...! almost forget it: 128MB on RAM.

> and other thing: if I run jigdo-lite like a "normal user" the
> .iso.tmp image is not generated completely (only 13 MB) but if I am
> root then I get a file of 678 MB

"Interesting." :-/

> This happen also with the US jigdo and template files, just the
> message it's different:
> > Not downloading .template file - `woody-i386-1.template' > already present

This message means that the template data matches the checksum that is
listed in the .jigdo file...

> Found 375 of the 1352 files required by the
> template
> zstream.cc:282: Assertion failed, `dataUnc > 0 || (status > ==
> Z_STREAM_END || status == Z_OK)'

...but this indicates that the template data is corrupted.

I cannot imagine how this could possibly be a bug in jigdo - it may be
bad RAM, a broken HD... :-|

> Question 1 : I must or not use that image?

Whether you need CD 1 or CD 1_NONUS is your decision. Our
recommendation to end users is to use 1_NONUS. jigdo should be able to
download both.

Yeah, I can understand that, Jigdo download both, but none it's totally created.

> Question 2 : What happen with the DEBs with wrong md5sum after of
> the installation???

As long as there are .debs with wrong md5sums, the .iso.tmp will never
be finished; if you burn the .iso.tmp file instead of a final .iso
file to CD-R, then the installation will break in weird and wonderful

Sorry, I cannot really help you!

Well... maybe the answer would be to wait another release of Jigdo (0.7.0 perhaps...? 8-) Anyway, thanks so much for all, now I know that it's not me, it's other thing... it's something unknown 8-)

  __   _
  |_) /|  Richard Atterer     |  CS student at the Technische  |  GnuPG key:
  | \/¯|  http://atterer.net  |  Universität München, Germany  |  0x888354F7
  ¯ '` ¯

Reply to: