[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Can't find SPARC or MD5 files while jigdo-ing woody i386 disk 1?

I have a RedHat (boo, hiss! :) system and have been considering
converting over to Debian.  Over the past few days I have been trying
to use jigdo 0.6.4 to get disk #1 of i386 woody (I do know about the
netinstall images, but the machine I'm planning to be fooling around
with it at first does not have a network card at the moment).

I run jigdo-lite, and when it asks me for the URL of a .jigo
I give it:

It then give it some nearby mirrors like it asks for, and it merrily
starts grinding away.  However, every time it fails with 12 files to
go, and the errors it gets in that final batch are always the same.  I
find them puzzling because one is for a SPARC file, yet this is an
i386 distribution (maybe a bug in whatever generates the .jigdo and
.template files)?  As for the file-with-the-name-of an-MD5-string it's
trying to get from ftp.fsn.hu, I don't know what's up with that (but
then I don't claim to know what lurks in the heart of debian package
management as I've never used it before :), but I *can* say that the
MD5-themed file it is failing to find is the MD5 sum associated with
the bogus(?) SPARC file in the .jigdo file.

I believe there are a few other similar errors - i.e., I'm pretty sure
I've seen some other failures to get MD5-themed files from ftp.fsn.hu - so
perhaps those are some of the 12 "missing" files.

In any case, here's the output I get again and again when I
have jigdo-lite try to get those last 12 files:

           => `root.bin'
Connecting to debian.lcs.mit.edu:80... connected!
HTTP request sent, awaiting response... 200 OK
Length: 1,474,560 [application/octet-stream]

    0K -> ........ ........ ......                              [100%]

12:22:25 (180.32 KB/s) - `root.bin' saved [1474560/1474560]

           => `officiallogo-nd-50.jpg'
Connecting to debian.lcs.mit.edu:80... connected!
HTTP request sent, awaiting response... 404 Not Found
12:22:25 ERROR 404: Not Found.

           => `qeYe6Ejz1xKjkgtLiN6w6Q'
Connecting to ftp.fsn.hu:21... connected!
Logging in as anonymous ... Logged in!
==> TYPE I ... done.  ==> CWD pub/debian-superseded ... done.
==> PASV ... done.    ==> RETR qeYe6Ejz1xKjkgtLiN6w6Q ... 
No such file `qeYe6Ejz1xKjkgtLiN6w6Q'.

           => `driver-1.bin'
Connecting to debian.lcs.mit.edu:80... connected!
HTTP request sent, awaiting response... 200 OK
Length: 1,474,560 [application/octet-stream]

    0K -> ........ ........ ......                              [100%]

12:22:39 (181.34 KB/s) - `driver-1.bin' saved [1474560/1474560]

Found 0 of the 12 files required by the template
Copied input files to temporary file `woody-i386-1.raw.tmp' - repeat command and supply more files to continue

Aaargh - not all files could be downloaded. This should not
happen! Depending on the problem, it may help to restart the
Also, you could try changing to another Debian or Non-US server,
in case the one you used was not updated recently.

However, if all the files downloaded without errors and you
still get this message, it means that the files changed on the
server. For the moment, in the case of Debian CD images the only
solution when that happens is to revert to rsync.

Press Return to restart.

Rich Carreiro                            rlcarr@animato.arlington.ma.us

Reply to: