[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Debian 2.1 LiNUX install problem (fwd)

Just cleaning up my mail before Christmas, found this hidden away and
forgotten about...

Steve McIntyre, Allstor Software         smcintyr@allstor-sw.co.uk
<a href=http://www.chiark.greenend.org.uk/~stevem/comp/>My PC page</a>
"Can't keep my eyes from the circling sky,                 
"Tongue-tied & twisted, Just an earth-bound misfit, I..."  

---------- Forwarded message ----------
Date: Mon, 29 Nov 1999 03:08:05 +0000
From: anarkist@idirect.com
To: webmaster@linux-m68k.org
Cc: stevem@chiark.greenend.org.uk
Subject: Debian 2.1 LiNUX install problem

I have discovered a few 'bugs'! :-)
not really bugs, but advisories.

I've discovered that my install works every time IF I wait until the
"install base system" then press Ctrl-D to exit. When I see the Atari
logo I turn off my Falcon and count to 16 (for 16 MB RAM) then turn
on my Falcon and run extenDOS and restart the installation process
(bootstra.prg) from the CD-ROM. After I have gone through all the
stages (colour, keyboard, swap, mount linux partition) the program
tells me the next step is install base system, which I do, and it
works. It never worked before and I theorize that the Falcons RAM
becometo crowded with processes (it is all running in RAM at that
point) Anyway this seems to work.

Another point that was not in the Atari install directions by Michael
Schmitz but is important is remember NOT to run extenDOS (or
equivalent) when rebooting after "installing base system" and writing
a new bootargs file. Linux prefers to mount the CD-ROM on its own,
and the install process won't work if extenDOS is used. I found this
tip in the regular m68k instructions from debian.

A final warning is the multi-cd read me file. I missed it first time
around. It mentions that you should put in the LAST CD of the set
after choosing multi-cd installation. I think it would be easy to add
this to the install program. If one chooses the multi-cd option, a
line can come up asking you to put in the last CD of the set.
I am about to try this reboot and dselect again, this time with the
*laST* CD! :-)


well I tried the laST CD trick (in my case with Debian2.1 from lsl)
with no success. Here is the error message (roughly same error
message for 'Update' and 'Install' in dselect)
"cannot open /var/lib/dpkg/methods/multicd/available: no such file or
directory. Installation script returned error exit status 1"

I _did_ find an 'available' at usr/lib.dpkg/methods/multicd/
and I have searched for the installation script and found an
'install' script, but don't know how to change it to make the
installation (tasks or profile from the first time install OR dselect)
can anyone offer any assistance?
Is it worth asking this question in the m68k newsgroup?
also, although Michael Schmitz says he'd like to hear from anyone who
used his installation guide, he left no address! :-)

thanks.merci for any help

Falcon030 w/Nemesis accelerator(on or off makes no difference)
16MB RAM (14 MB accessible). using www.lsl.com Debian2.1 CD-ROM set
(2 disks binary, 2 disks source) instaqlling to a SCSI 520MB hard
drive (id 6) partionend as sde1 (200 MB initial) sde2 (290 MB /usr)
sde3 (30MB swap)

Reply to: