[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Upgrading Debian kFreeBSD from Wheezy to Jessie

Jesse Smith wrote:
> As a test I manually ran mknod to create the /run/initctl file,
> duplicating the command in the mountal.sh script. This causes the
> "reboot" and "shutdown" commands to pause for a few seconds. Then I get
> an error saying the comand timed out trying to write to /run/initctl.

I think you would also need to:
# kill -USR1 1
which signals the running init (pid 1) to open that newly-created FIFO,
and start listening for commands.

> > Do you have anything 'unusual' in /etc/fstab?
> Nothing unusual. Virtually nothing in the file at all since I'm running
> on ZFS. Perhaps that was a poor choice on my part.

ZFS should be fine;  I'm using kfreebsd jessie on ZFS right now in fact.
I've tested two versions of sysvinit so far and didn't see the bug
you're seeing.

> > Are any of the following missing from /proc/mounts?
> >
> > | devfs /dev devfs rw 0 0
> > | linprocfs /proc linprocfs rw 0 0
> > | /sys /sys sysfs rw 0 0
> > | fdescfs /dev/fd fdescfs rw 0 0
> > | tmpfs /run tmpfs rw,noexec,nosuid 0 0
> > | tmpfs /run/lock tmpfs rw,noexec,nosuid 0 0
> > | tmpfs /run/shm tmpfs rw,noexec,nosuid 0 0
> Yes, these entries are missing.

Well, they can't possibly *all* be missing (/proc/mounts itself is on
/proc!).  Could you perhaps share the contents of your /proc/mounts?
(exclude any zfs partitions if you wish)

> I tried a fresh install of Wheezy and then immediately updated to
> Jessie/Testing. I'm running into the same error. I'm beginning to think
> it's the virtual environment that is to blame, especially given the
> missing mount points mentioned above. I hope to try a fresh installation
> on a test machine soon to see what happens.

What kind of environment is it?  Something like Virtualbox, VMware, KVM?

Steven Chamberlain

Reply to: