[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#691754: marked as done (kfreebsd-amd64 fails to install on LSI MegaRAID SAS 2208)

Your message dated Mon, 20 Jan 2014 16:12:19 +0100
with message-id <52DD3CD3.8050003@debian.org>
and subject line Re: Bug#691346: mfi in 9.1
has caused the Debian Bug report #691346,
regarding kfreebsd-amd64 fails to install on LSI MegaRAID SAS 2208
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact owner@bugs.debian.org

691346: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=691346
Debian Bug Tracking System
Contact owner@bugs.debian.org with problems
--- Begin Message ---
Package: installation-reports
Severity: critical
Tags: d-i

-- Package-specific info:

Boot method: CD
Image version: debian-wheezy-DI-b3-kfreebsd-amd64-netinst.iso
Date: 201210241200

Machine: IBM System x3650 M4
Partitions: no partitions

Base System Installation Checklist:
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

Initial boot:           [E]
Detect network card:    [ ]
Configure network:      [ ]
Detect CD:              [ ]
Load installer modules: [ ]
Clock/timezone setup:   [ ]
User/password setup:    [ ]
Detect hard drives:     [ ]
Partition hard drives:  [ ]
Install base system:    [ ]
Install tasks:          [ ]
Install boot loader:    [ ]
Overall install:        [ ]


On this server the LSI RAID controller LSI MegaRAID SAS 2208/ServeRAID M5110e
is installed. I tried installing kfreebsd-amd64 on it from CD. The
installer GRUB menu works (see attachment boot.png), but right after
that the FreeBSD kernel hangs during boot with an error (see
attachment error.png). After 10/20 seconds another error line gets
printed -- something about hard resetting something -- but it was
too fast for me to take a screenshot, and the system reboots. 
On the very same machine I was able to install the standard 
debian-wheezy-DI-b3-amd64-netinst.iso without any problem. 

On LSI website I found this:
which seems to indicate that FreeBSD 9.0 ships an obsolete kernel
module for this controller, and they suggest a procedure how to create
a FreeBSD 9.0 installer with an updated module. My knowledge of
FreeBSD are a bit too limited for me to seriously think about
recompile the kernel and injecting some additional modules, but
maybe someone in the kfreebsd debian team knows how to do it?

I now have the machine up and running with linux debian amd64, so I
can make any needed additional hardware info -- as linux sees it --
available. I can also make the remote control console accessible to
more knowledgeable people for debugging.


PS: I did not know what severity to set, I thought that complete
install failures qualifies for "critical", but please downgrade it
if needed.

Attachment: boot.png
Description: PNG image

Attachment: error.png
Description: PNG image

--- End Message ---
--- Begin Message ---
Version: 9.1

On 20/01/2014 10:51, Tiziano Zito wrote:
> On Wed 15 Jan, 11:12, Robert Millan <rmh@debian.org> wrote:
>> On Mon, Nov 12, 2012 at 01:56:38PM +0100, Mathieu Simon wrote:
>>> G'day
>>> Actually FreBSD 9.1 will contain update 'mfi' driver code which
>>> largely expands the support for MegaRAID drivers. (confirmed witha
>>> 9.1-RC3 media)
>>> It might be interesting for you to boo a native FreeBSD ISO of
>>> this version to see if your controller is recognized by this mfi module.
>>> (use "pciconf -lvb | grep mfi" and "mfiutil show adapter" to check)
>> Tiziano, did you try with 9.1 kernel as suggested? Actually, you could
>> try 10.0~rc from unstable, it might give better results.
>> Please let us know if it works for you.
> Hi, 
> sorry for not following up on this sooner. Last year I decided to go
> the FreeBSD route and updated the kernel module as specified on the
> LSI website. It worked fine.
> The upgrade to 9.1 brought the new mfi module, which indeed supports
> the controller, so from kernel 9.1 onwards there is no need to
> compile any additional module. 
> The server is now running a 9.2-RELEASE kernel and everything works
> fine. As the server is in production I can not really test a
> Debian+kfreebsd installation, but I have no reason to think that it
> would make any difference, so for me the bug can be closed :)

Excellent! Thank you.

Robert Millan

--- End Message ---

Reply to: