[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Two questions about kfreebsd


Responses are inline.

On Thu, 21 Feb 2013, Steven Chamberlain wrote:

On 21/02/13 05:42, Bret Busby wrote:
I have a desktop computer with an Intel I3 CPU, and 8GB of RAM, and,
it simply does not use the swap space (I had allocated 40GB) on the
hard drive.

You probably already tried it, but the setting of Linux sysctl
vm.swappiness controls the balance of RAM/swap used, on some 0 to 100 scale.

I am not sure how or where I set it, but, from memory, I had set it to 80.

Also - just to make sure there was no misunderstanding - the output of
the "free" command might suggest most of your RAM is "used", but:

$ free
             total       used       free     shared    buffers     cached
Mem:       8197112    7735536     461576          0     232124    4324500
-/+ buffers/cache:    3178912    5018200
Swap:       270332     223600      46732

I have

total used free shared buffers cached Mem: 8059964 7987392 72572 0 90776 2146164
-/+ buffers/cache:    5750452    2309512
Swap:     42860340     821564   42038776

And, this tying up of memory, by caching of memory, appears to be a nuisance that I can not eliminate.

Whilst the above, shows some swapping to be occurring, the swapping is not enough to be worthwhile.

The "- buffers" figure in the "used" column is the more accurate figure
of RAM being used by userland software.  Most of my RAM here is being
used to cache disk I/O - and that is something it makes no sense to swap
out to disk.

As such, the only time this system ever touches swap is if I really do
exhaust my available RAM with something.  Or maybe sooner if I increased
vm.swappiness all the way to 100.

Any kind of swapping though hits this (Linux 3.2) system pretty hard -
like you described - but after a minute or so it usually recovers.  I
agree that's bad.  This is the sort of thing I imagine kFreeBSD might
handle better.

I have also noticed that, on this system, when the RAM usage shows as
having reached about 60%, the system slows, especially dta
transmission through the ethernet card.

For a driver or possibly hardware-related issue like this I do recommend
at least trying GNU/kFreeBSD with the version 9 and/or 8 kernels, since
the driver implementation will be different to Linux.  It may work
better, or otherwise you may be able to determine if it is in fact a
hardware problem.

The data transmission rate seems to slow when the memory usage increases; "inverse proportionality ratio"?

As a simple example, (apart from all of the rubbish that gmail involves, with its access obtsructions) it is taking about 20-25 minutes to log in to gmail, and it mostly times out, when I have memory usage >50%.

I had installed PC-BSD 9.0 (which is based on FreeBSD
9.0) on an HP/Compaq NX5000 (Intel Celeron CPU, 2GB RAM), in a
multiple boot scenario

I think on GNU/kFreeBSD we have a limitation of not being able to boot
from an "msdos logical" partition (e.g. /dev/sda5+), although it might
depend what filesystem is being used.  Thanks to GRUB2's flexibility we
can boot if at least either the root or /boot filesystem (I can't
remember which) is on an "msdos primary" partition.  FreeBSD and PC-BSD
might not be able to do that.

From my understanding, BSD requires to be installed in a primary
partition. From what you have said, that may apply also to kfreebsd. That is an interesting aspecty that had not previously occurred to me.

A problem, in that, on this particular computer, is that, with the preinstalled stuff on this computer, from when it was purchased, three primary partitions were occupied; one, the Windows installation, two, a resue or some such partition, and, three, a manufacturers partition; maybe drivers.

I have just ran the disk utility, and it shows (it is a Dell);
Dell Utility 74MB FAT
Recovery 9.2GB NTFS

and, as I had found, the extended partition also occupies a primary partion; 547GB.

Thus, the maximum number (4) of primary partitions on this computer, are occupied.

This is unfortunate, as, whilst it still allowed me to install Linux (two separate distributions), it would not allow, as it stands, installation of a BSD-based operating system.

I do not know whether the first two partitions (or their contents, so that the content would still be usable) in the primary partitions, can be moved to extended logical partitions (which would be needed, to install BSD (or, possibly (?) kfreebsd).

In the extended partition, I have Ubuntu 10.04 and Debian 6, installed.

Regarding the PC-BSD 9.0 installation on the laptop, PC-BSD cannot be automatically detected by GRUB. I tried to set it up manually, within the GRUB file, and that did not work. So, I installed GAG (a graphical boot loader), and that lost the pointer (?) to the Debian installation, and could not get PC-BSD running, anyway (it got to "loading xserver" or something similar, and the screen went blank, and stayed that way), so I tried uninstalling GAG, that had no apparent effect, so I reinstalled Debian 6, and that computer now shows as having only Debian 6 installed (unless I go to the disk utility,m which shows the PC0BSD 9.0 partition).

I later found that (apparently), for GAG to boot linux (it had found the installation, just not the stuff to boot it, the boot record (?) could not be in the Master Boot Record, but had to be in the bootable linux partition.

The file format that I selected for the PC-BSD installation (and thence, that partition) was ufs, which, I believe, Debian can read (if not also write to).

Steven Chamberlain

Bret Busby
West Australia

"So once you do know what the question actually is,
 you'll know what the answer means."
- Deep Thought,
  Chapter 28 of Book 1 of
  "The Hitchhiker's Guide to the Galaxy:
  A Trilogy In Four Parts",
  written by Douglas Adams,
  published by Pan Books, 1992

Reply to: