[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Bug#651624: Booting from zfs root seems to not work 8.3 and 10.0 however work

On 06/01/13 03:58, Steven Chamberlain wrote:
> I think it might have to do with devices in the zpool being renamed [...]

> Furthermore, there is a particular problem when ZFS is on a partition,
> rather than a whole device, and if that partition extends to the end of
> the disk.

> If both ada0 and ada1 are renumbered, I instead get the "failed with
> error 6" at boot.

Well, I've tried moving my ZFS partitions back from the end of the disks
(one half of the mirror at a time) and I zeroed the free space until the
end of the disk.  I'm no longer seeing this problem when device paths
are renumbered.

> I guess it tries /dev/ada3 *before*
> looking at /dev/ada3s3, attempts to import the pool that way, but is
> unable to properly read ada3 so marks the drive UNAVAIL.

On 12/12/11 22:50, Christoph Egger wrote:
> [...]
> ada0:  Previously was known as ad4
> [...]
> Trying to mount from zfs:base/root [rw]...
> vdev_geom_open_by_guid:352[1]: Searching by guid [$number]
> vdev_geom_read_guid:239[1]: Reading guid from ada0
> vdev_geom_read_guid:273[1]: guid for ada0 is $number
> vdev_geom_attach:95[1]: Attaching to ada0.
> vdev_geom_attach:116[1]: Created geom consumer for ada0
> vdev_geom_open_by_guid:363[1]: Attach by guid [$number] succegged, provider /dev/ada0
> vdev_geom_detach:156[1]: Closing access to ada0
> vdev_geom_detach:160Mounting from zfs:base/root failed with error 6 Destroyed consumer to ada0
> vdev_geom_detach:168[1]: Loader variables:
> Destroyed geom zfs::vdev.  vfs.root.mountfrom=zfs:base/root

That looks like the same issue to me - ad4 became ada0 - but Christoph
said that the zpool had been created from the installer.

The installer usually uses a (msdos) partition as a ZFS physical volume?
 So perhaps it should have tried to attach /deve/ada0s[0-9] here, but
mistakenly attached /dev/ada0 because it saw the disklabel (with correct
guid) near the end of the disk?

Steven Chamberlain

Reply to: