[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#695679: freebsd-utils: Init script fails in jail, breaks dist-upgrade

Package: freebsd-utils
Version: 9.0+ds1-8
Severity: normal

Dear Maintainer,

I am running Debian GNU/kFreeBSD jailed on a native FreeBSD 9 machine.
Trying to dist-upgrade from squeeze to wheezy I get this:

Setting up freebsd-utils (9.0+ds1-8) ...
Installing new version of config file /etc/init.d/freebsd-utils ...
[....] Loading devfs rules...devfs ruleset: ioctl DEVFSIO_SUSE:
Operation not permitted
invoke-rc.d: initscript freebsd-utils, action "start" failed.
dpkg: error processing freebsd-utils (--configure):
 subprocess installed post-installation script returned error exit
 status 1
 configured to not write apport reports
 Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)

It's easy enough to work around this issue (exit 0 in the init script
does the trick) but it's a little annoying and would be nice to have

-- System Information:
Debian Release: wheezy/sid
  APT prefers testing
  APT policy: (500, 'testing')
Architecture: kfreebsd-amd64 (x86_64)

Kernel: kFreeBSD 9.0-RELEASE-p3
Locale: LANG=C, LC_CTYPE=C (charmap=ANSI_X3.4-1968)
Shell: /bin/sh linked to /bin/dash

Versions of packages freebsd-utils depends on:
ii  libbsd0     0.4.2-1
ii  libc0.1     2.13-37
ii  libcam6     9.0+ds1-3
ii  libgeom1    9.0+ds1-3
ii  libjail1    9.0+ds1-3
ii  libkiconv4  9.0+ds1-3
ii  libkvm0     9.0+ds1-3
ii  libsbuf6    9.0+ds1-3
ii  libtirpc1   0.2.2-5
ii  lsb-base    4.1+Debian8
ii  zlib1g      1:1.2.7.dfsg-13

freebsd-utils recommends no packages.

Versions of packages freebsd-utils suggests:
pn  freebsd-hackedutils  <none>
ii  kbdcontrol           9.0+ds1-8
pn  vidcontrol           <none>

-- no debconf information

Reply to: