[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Installer Issues

tl;dr - I'm trying to install the Wheezy version of kFreeBSD with
Xfce, but have run into the following issues.

Location of Official Installer Unclear
Keyboard Layout Sometimes Not Set Correctly
Hard Disk Waring
Bad Default Mirror
8/9 Mix Doesn't Boot
8 Installs 9
Xorg Black Screen
Inconsistent Default Volatile Repository
CD Repository Not Disabled After Install


Like i said above, I'm trying to install the Wheezy version of
kFreeBSD with Xfce, but have run into a few issues. Some of the points
are from memory, but most everything here I have noticed within the
past couple of days. I am installing on VirtualBox 4.2 on a Debian
Wheezy host with the FreeBSD 64-bit guest hardware profile with the
guest hardware time set to UTC time in VirtualBox. While installing I
usually selected the volatile update repository if it wasn't already
selected, but a few times I may have not selected it if it wasn't
already selected.

Location of Official Installer Unclear
This kFreeBSD FAQ page (
http://wiki.debian.org/Debian_GNU/kFreeBSD_FAQ ) links to this
kFreeBSD wiki page ( http://wiki.debian.org/Debian_GNU/kFreeBSD ) with
download links to x86 and x64 Squeeze mini.iso images. It also links
to a folder containing many different daily mini.iso images. While on
IRC I found out that there are also CD images (
), which I think are probably more of what I'm looking for. I think
that the wiki page with the download links should probably link to the
weekly CD images either instead of or in addition to the daily
mini.iso images.

Keyboard Layout Sometimes Not Set Correctly
This Squeeze mini.iso installer (
) doesn't ask for the keyboard layout during the installer.
This daily mini.iso installer (
) asks for the keyboard layout, but doesn't set it during the install,
at least not for Dvorak.
This daily mini.iso installer (
) asks for the keyboard layout and correctly sets it during the
This weekly CD installer (
) asks for the keyboard layout, but only sets it correctly if the
kFreeBSD 9 option is selected before installing.

Hard Disk Waring
While installing as a guest in VirtualBox 4.2, the kFreeBSD 9
installer prints the following hard disk warning before partitioning.
[!] Partition disks

Could not get identity of device /dev/ada0 - Inappropriate ioctl for device



<Go Back>

Bad Default Mirror
The default mirror fails with a red 'Bad archive mirror' error page.
This happens with both the kFreeBSD 9 installers, I'm not sure about
the other installers. The default mirror location is

8/9 Mix Doesn't Boot
When I tried to install the Squeeze kFreeBSD kernel version 8 with the
mini.iso, it dropped me to a mountroot prompt after install.

8 Installs 9
When I tried to install the kFreeBSD kernel version 8, it installed
the kFreeBSD kernel version 9. It seems that kfreebsd-image-8-amd64
depends on kfreebsd-image-9-amd64. I think that the CD images may not
ask for which repository to select because I ended up with Wheezy even
though I was going for Squeeze during this particular installation.

Xorg Black Screen
So far when I have tried to install Xfce it has not worked while using
the Wheezy repository. It changes the guest screen resolution in
VirtualBox, but it only displays a black screen. I can still switch to
the terminal screens. I think I've tried installing it from the
mini.iso images and after installing from the mini.iso images. I
haven't tried it during or after the CD installation, but I'm
currently experimenting with the CD image installer.

Inconsistent Default Volatile Repository
Some of the installers, but I'm not sure which ones, have the volatile
updates repository selected by default and some don't have it selected
by default. This may be intentional, but it seemed inconsistent to me.

CD Repository Not Disabled After Install
I think this is something that may have been fixed in non-kFreeBSD
Debian not too long ago, but anyway, after I installed from the CD
image, The CD repository didn't get disabled after the install. It
should be disabled after the initial installation. Actually, the CD
repository was listed twice in /etc/apt/sources.list as follows.


# deb cdrom...

deb cdrom...

deb http...

Reply to: