[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

libbatik-java change led to uninstallables on kfreebsd


libbatik-java's dependencies were changed recently like so:

>  Package: libbatik-java
>  Architecture: all
> -Depends: openjdk-6-jre-headless | java2-runtime-headless,
> +Depends: openjdk-6-jre-headless | openjdk-7-jre-headless | java7-runtime-headless,

Unfortunately this seems to have made about 120 packages uninstallable
in sid on kfreebsd-*.

On kfreebsd-* we have a java2-runtime-headless provided by:

* default-jre-headless 1:1.5-47
* gcj-4.7-jre-headless 4.7.1-1
* gcj-4.6-jre-headless 4.6.3-1
* gcj-jre-headless 4:4.7.0-6

But we don't seem to have a java7-runtime-headless on kfreebsd-* unless
we manage to get openjdk-7 built.

Or was this simply a mistake and should java2-runtime-headless still be
in that list?

Steven Chamberlain

Reply to: