[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Bug#675837: protobuf: FTBFS[!linux]: error: 'isatty' was not declared in this scope

On Mon, Jun 11, 2012 at 03:08:54PM +0100, Steven Chamberlain wrote:
> Hi,
> Actually there seems to be another problem after this, when building the
> Java bindings.  I wonder if Build-Depends: default-jdk is really
> acceptable for platforms without an openjdk:
> > Setting up gcj-4.7-jdk (4.7.0-4) ...
> > Setting up gcj-jdk (4:4.7.0-6) ...
> > Setting up default-jdk (1:1.5-47) ...
>  ...
> > # java bindings
> > # this code mimics mvn package. This should be changed when maven is supported by debian.
> > /bin/sh /usr/bin/ant -f debian/java-build.xml jar
> > Buildfile: /tmp/buildd/protobuf-2.4.1/debian/java-build.xml
> > 
> > generate:
> >     [mkdir] Created dir: /tmp/buildd/protobuf-2.4.1/java/target/generated-sources
> >      [echo] src
> > 
> > compile:
> >     [mkdir] Created dir: /tmp/buildd/protobuf-2.4.1/java/target/classes
> >     [javac] Compiling 38 source files to /tmp/buildd/protobuf-2.4.1/java/target/classes
>  ...
> >     [javac] 70. ERROR in /tmp/buildd/protobuf-2.4.1/java/src/main/java/com/google/protobuf/TextFormat.java (at line 599)
> >     [javac]     matcher.usePattern(TOKEN);

Indeed, it might be not. This looks like what I've seen a long while
ago, when sun-jdk/openjdk was too old even on platforms where it

Do I understand correctly, that building depends on openjdk (or rather
said, on a JDK which supports java 1.5 or newer, or 1.6 or newer), so
therefore it worked until now since the kfreebsd-* builders only built
the arch-specific package? And you're trying to build all packages, not
just binary ones, so that's why I fails?

I wonder if the resulting JAR file built on (e.g.) amd64 works fine on a
machine which doesn't have openjdk.

Finally: maybe this should be split as a different bug; the gcc-4.7 fix
is good (much appreciated!), so I can upload that soon.


Reply to: