[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#651624: Booting from zfs root seems to not work 8.3 and 10.0 however work

On 10/12/11 16:52, Christoph Egger wrote:
> Booting from a zfs root filesystem (created with the daily installer
> and a 8.2 kernel) fails with the kfreebsd 9 kernel


I just had a go at this myself and it worked.  I had trouble with
zfsutils during install though which may be relevant.

I used this daily netinst image:


which only has kfreebsd-image-8.2-1-amd64 8.2-15 (I guess because
kfreebsd-9 isn't in testing quite yet?).  I may have had to go to GRUB
command line and 'set mfsroot_path=/boot/mfsroot.gz' to boot the installer.

I had difficulty getting past the partitioner stage of the install.  I
could create/see the ZFS pool from the partitioner's submenu, but it
would not ask me to set a mount point.  The main partitioner screen
would not list the ZFS pool/filesystems, only the physical drive and
partition that I'd added to the pool (correctly marked as 'in use').

Then I noticed the debian installer seemed to be using zfsutils-udeb
8.3~svn226546-6 from sid, which according to #648744 probably doesn't
work with 8.2.  So, I downgraded to zfsutils-udeb 8.2-4 inside of the
running installer ramdisk (from the console, using wget, ar and tar to
overwrite zpool/zfs and libs), and was then able to delete/recreate a
ZFS pool and root fs that worked and allowed me to finish installing.

On first boot with 8.2 kernel, I enabled the sid APT repo, installed
latest kfreebsd-image-9 (requiring newer zfsutils) and rebooted back
into the ZFS root fs with that kernel just fine.  zpool status showed
the pool as online/healthy, but suggested I upgrade to version 28, which
was successful also.

Steven Chamberlain

Reply to: