[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#644818: marked as done (libgeom1 ABI incompatible with kfreebsd-9)

Your message dated Sun, 9 Oct 2011 17:31:06 +0200
with message-id <CAOfDtXNVhmgXu+pxr1iM6aMBqGOVwmKvvecsuBErZjc4Lv=Hjg@mail.gmail.com>
and subject line Re: libgeom1 ABI incompatible with kfreebsd-9
has caused the Debian Bug report #644818,
regarding libgeom1 ABI incompatible with kfreebsd-9
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact owner@bugs.debian.org

644818: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=644818
Debian Bug Tracking System
Contact owner@bugs.debian.org with problems
--- Begin Message ---
Package: kfreebsd-9
Version: 9.0~svn225873-1

Making a bug out of this, please followup there.

2011/10/8 Arno Töll <debian@toell.net>:
> I backported and compiled kfreebsd-9:

Why not you just use the package from experimental?

> ii  libgeom1                      8.2+ds1-4         FreeBSD GEOM library
> This is the same version as Sid has, right now.
> This seems to cause an ABI incompatibility between libgeom and
> kfreebsd-9.

I don't recall this happening last time I tested. Could you check if
earlier kfreebsd-9 uploads [1] also exhibit this problem? If not,
which version introduced it?

[1] http://snapshot.debian.org/package/kfreebsd-9/

Robert Millan

--- End Message ---
--- Begin Message ---
2011/10/9 Arno Töll <debian@toell.net>:
> I did and I couldn't reproduce it on a virtual machine I prepared for
> testing. Hence I did further triaging and it turned out to be more
> likely a problem between grub and libgeom1, not kfreebsd-9 and libgeom1.
> I am not sure what caused the problem, but upgrading grub from 1.99-6 to
> 1.99-12 solved the problem. My wild guess is, that this may be a
> duplicate of #630197 fixed in -8. Hence, the bug is, if anything, a
> missing "Breaks" relation.

But if we add "Breaks: grub-common (<< 1.99-8)" in libgeom1, this
might prevent a backport of this library.

I don't think this is a Breaks relation. grub 1.99-7 was buggy because
it was built with a fscked version of libgeom which is no longer in
the archive. We don't need to add a Breaks for each buggy package


Robert Millan

--- End Message ---

Reply to: