[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Installing Grub on new squeeze vm failed

Hi I'm trying to install squeeze in a virtual machine (using VirtualBox on a Windows host with 2GB ram dedicated to vm), and I'm having problems installing Grub. I'm using kFreeBSD (amd64_cd1) iso image. I have 2 vdis, configured as:

ad4s1 - UFS, 17.5GB, '/'
ad4s2 - SWAP, 4GB
ad6s1 - UFS, 24.4GB, '/usr'
ad6s2 - UFS, 20GB, '/var'
ad6s3 - UFS, 20GB, '/home'

The base system installed fine. I selected to only install "System Utilities", which installed fine. But while trying to install grub, at the updating grub stage, 'grub-installer' is failing. I tried installing grub a second time and the same issue is happening. This is the output from terminal 4:

Oct 2 04:44:31 grub-installer: info: Installing grub on '/dev/ad4'
Oct 2 04:44:31 grub-installer: info: grub-install supports --no-floppy
Oct 2 04:44:31 grub-installer: info: Running chroot /target grub-install --no-floppy --force "/dev/ad4"
Oct 2 04:44:36 grub-installer: info: grub-install ran successfully
Oct 2 04:44:36 /bin/in-target: warning: /target/etc/mtab won't be updated since it is a symlink
Oct 2 04:44:40 grub-installer: error: Running 'update-grub' failed
Oct 2: 04:44:46 main-menu[106]: WARNING **: Configuring 'grub-installer' failed with error code 1
Oct 2 04:44:46 main-menu[106]: WARNING **: Menu item 'grub-installer' failed.

I have paused the virtual machine for now. Any ideas? Should I just retry? Should I run the install from the start again? Thanks for the help.

David Watson
e: hiranwatson@gmail.com

Reply to: