[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#612353: lsusb prints no output

Package: usbutils
Version: 0.87-5
Severity: grave
Tags: patch
User: debian-bsd@lists.debian.org
Usertags: kfreebsd

lsusb doesn't print any output on GNU/kFreeBSD.  If the package is
rebuild with libusb2-dev instead of libusb-dev, then lsusb works
as expected.

I'm unsure if this should be considered a libusb-dev bug (and
thus reassigned), or kfreebsd-* packages aren't supposed to link
with that library at all (in that case I suppose libusb-dev binaries
shouldn't be built for this architecture).

In either case, switching to libusb2-dev fixes the problem for
this package, so patch attached.

-- System Information:
Debian Release: 6.0
  APT prefers testing
  APT policy: (500, 'testing'), (500, 'stable')
Architecture: kfreebsd-amd64 (x86_64)

Kernel: kFreeBSD 8.1-1-amd64
Locale: LANG=ca_AD.utf8, LC_CTYPE=ca_AD.utf8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages usbutils depends on:
ii  libc0.1                 2.11.2-10        Embedded GNU C Library: Shared lib
ii  libusb2                 8.1-5            FreeBSD userspace USB programming 
ii  zlib1g                  1: compression library - runtime

usbutils recommends no packages.

Versions of packages usbutils suggests:
ii  wget                          1.12-2.1   retrieves files from the web

-- no debconf information
--- debian/control~	2011-02-08 00:10:26.000000000 +0100
+++ debian/control	2011-02-08 00:11:01.921416269 +0100
@@ -2,7 +2,7 @@
 Section: utils
 Priority: optional
 Maintainer: Aurelien Jarno <aurel32@debian.org>
-Build-Depends: debhelper (>> 5.0.22), autotools-dev, libusb-dev (>= 0.1.6), pkg-config, zlib1g-dev
+Build-Depends: debhelper (>> 5.0.22), autotools-dev, libusb-dev (>= 0.1.6) [!kfreebsd-any] | libusb2-dev [kfreebsd-any], pkg-config, zlib1g-dev
 Standards-Version: 3.8.4
 Package: usbutils

Reply to: