[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

lsof FTBFS on non-linux arches

Package: lsof
Version: 4.81.dfsg.1-1

lsof fails to build from source on debian's non-linux variants
(kfreebsd-i386, kfreebsd-amd64, and hurd-i386).

This appears to be at least partly because of a hardcoded line in

 ./Configure -n linux

which obviously is wrong on these other platforms.

Here is a recent failed build log on kfreebsd-amd64:


Note that lsof's upstream claims at least that it builds fine on FreeBSD:


(no mention of hurd there).

christoph tried today just changing debian/rules to use

 ./Configure -n freebsd

but that didn't work either:

> 16:45 < christoph> jep but changing to freebsd doesn't work
> 16:46 < christoph> Creating ./lockf_owner.h from /sys/kern/kern_lockf.c
> 16:46 < christoph> FATAL ERROR: can't read /sys/kern/kern_lockf.c
> 16:46 < christoph> FATAL ERROR: ./lockf_owner.h creation failed (see 00FAQ)
> 16:47 < dkg> sounds like it needs kernel source available to do that. (from 
>              00FAQ)
> 16:47 < dkg> FAQ question 8.6
> 17:26 < christoph> having the kernel-source package doesn't help has it doesn't 
>                    ship that file .. digging
> 17:27 < christoph> and there doesn't seem to be a package that does

You can access the FAQ directly here:


It would be really nice to have lsof available on kFreeBSD.  It's also a
build-dependency of some packages (i ran into this with xdotool, which
uses lsof in the build process' test suite), so its lack on those arches
is actually causing other trouble in the archive.


PS if debian-bsd folks reply to this, please CC me as i'm not on the list.

Attachment: signature.asc
Description: OpenPGP digital signature

Reply to: