[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: libparted0-udeb: not installable on kfreebsd-*, depends on libgeom0

On Mon, Jun 14, 2010 at 04:41:50PM +0200, Aurelien Jarno wrote:
> Colin Watson a écrit :
> > On Tue, May 04, 2010 at 04:59:38PM +0200, Cyril Brulebois wrote:
> >> thanks to your efforts, parted gets now built again on kfreebsd-*;
> >> unfortunately its udeb isn't installable since it depends on libgeom0.
> >> According to this mail[1], it might be a wrong version of a patch?
> >>
> >>   1. http://lists.debian.org/debian-bsd/2010/04/msg00037.html
> >>
> >> I didn't find time to investigate yet, but I don't want to forget about
> >> it totally.
> > 
> > I'm afraid I don't understand Aurelien's mail.  The current version (as
> > far as I'm aware) of the parted FreeBSD patch entirely relies on
> > libgeom.  Wouldn't the correct fix for this be to build a libgeom0-udeb?
> The problem is that the current version which is in the package is the
> old version of the patch, instead of the one that has been improved
> during the GSoC last year. The current version needs libgeom, while the
> improved version doesn't need it.
> The versions 1.8.8 were using the improved version, while the versions
> 2.2 have switched back to the original version, which introduced back a
> few bugs, especially with SCSI drives.
> You can find the improved version of this patched, ported for 2.2 at
> this URL:
> http://temp.aurel32.net/kfreebsd-gnu.patch

Ah, thanks.  I remember seeing this in the past and I could have sworn
I'd already applied it, but evidently not.  Some kind of bug report as a
reminder would have been nice ...

I'll upload this shortly.

Colin Watson                                       [cjwatson@debian.org]

Reply to: