[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

-8 kernel fails to load rootfs

Hi all!

	As already mentioned on IRC some time ago, my desktop install of
Debian GNU/kFreeBSD that works fine with the -7 kernel just won't load
the rootfs when started with a -8 kernel (some screenshots at [0]).

	That's a secondary IDE drive[1] where the freebsd root partition
is placed at ad1s11. I can mount that rootfs fine from a mini.iso (pre
8 times, will try tomorrow a newer one).

	Getting past the kernel prompt is possible by using
ufs:ufsid/$something but that'll still fail later on with a mount:
Illegal arguments (screenshots follow tomorrow at the same place).

	I tried a freebsd 8 livefs stuff which detects the partition
correctly but which I couldn't bring to mount it (I couldn't mount it
directly in the installer busybox but only did so modifying fstab +
mount -a).

	Besides me delivering a full error message of the freebsd mount
tries anything I can try? I'm already loading the geom modules trough
grub (I hope!).



[0] http://www.sieglitzhof.net/~christoph/deadboot*
[1] 00:0f.1 IDE interface: VIA Technologies, Inc. VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE (rev 06)
/"\  ASCII Ribbon : GPG-Key ID: 0xD49AE731
\ /    Campaign   : CaCert Assurer
 X   against HTML : Debian Maintainer
/ \   in eMails   : http://www.debian.org/


Attachment: signature.asc
Description: Digital signature

Reply to: