[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: A (partial) installation report

lördag 06 februari 2010 09:44:37 skrev  Rogério Brito:
> Hi, Hannes.
> On Feb 04 2010, Hannes wrote:
> > torsdag 04 februari 2010 16:58:38 skrev  Rogério Brito:
> > > Yes, an empty list. Is there anything easy to solve this?
> >
> > The kernels>=8 don't come with some geom-classes by default
> > anymore.
> That's very nice to know.
> > Load the following modules on start:
> > geom_bsd
> > geom_label
> > geom_mb
> (Is the last module supposed to end with _mbr, instead of only _mb?)


> I tried to read a little bit more regarding modules on freebsd and
>  what to do at the "mountroot" prompt.
> It seems that we are not in a boot monitor anymore (well, if we are
> running constrained in a kernel, that would be too much to ask, of
> course), but it adds some complications, since it may be too late to
> load modules.
> > Maybe you can load them directly with grub2, I don't know.
> I loaded with the kfreebsd_module_elf directive of grub2, but I still
> get the mountroot prompt and an empty list of GEOM managed devices. 
>  :-(

Bad :(

> Just to remeber, I can boot with 7.2-1-686 without any problems.

Yeah, fbsd7 had the classes compiled in. I couldn't boot my systems 
after upgrading to 8 without loading (some of) the aforementioned 
modules. I had the same error message as you, so I really think it is 

I have never used grub2, so maybe it is related to grub2 not loading the 
modules in time. Have you tried chainloading /boot/loader? is that 
available at all in current versions (sorry, I am not up2date)?


Reply to: