[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Why erlang dep-waits for perl 5.10?

On 08/05/21 13:26 +0200, Cyril Brulebois said ...
> On 21/05/2008, Y Giridhar Appaji Nag wrote:
> > perl-base is build-essential but perl is not.
> I beg to differ.
> $ apt-cache show perl | grep ^Build-Essential
> Build-Essential: yes

You are right, I stand corrected.

I followed policy (4.2 Package relationships) which pointed me to
/usr/share/build-essential/list which indicated that it includes
/usr/share/build-essential/essential-packages-list and neither of the lists
had perl, only perl-base was in essential-packages-list.

That misled me because make was listed explicitly and I thought all packages
that dpkg-dev depends on would also be listed explicitly.  Turns out that
perl, cpio etc.  that dpkg-dev depends on are not listed, but they are marked
Build-Essential: yes.

Thanks for pointing out.  I will go and fix my packages :)



Y Giridhar Appaji Nag | http://appaji.net/

Attachment: signature.asc
Description: Digital signature

Reply to: