[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Can't sign packages on kFreeBSD because gpg wants /dev/tty



Aurelien Jarno <aurelien@aurel32.net> wrote:
> markus schnalke a écrit :
> > Hoi community,
> > 
> > I have a kFreeBSD machine running and started to port my debian
> > packages (see http://prog.marmaro.de/deb-repo/ ) to kfreebsd-i386.
> > 
> > It worked well until gpg starts to sign the .dsc and .changes. gpg
> > wants to open /dev/tty which does not work.
> > I think this problem is known ...
> 
> I don't think so. Do you have an idea why you don't have /dev/tty? If
> devfs is mounted, this file should exists.

It's strange. `ls /dev' does not list "tty", but there is one shown if
I run `ls /dev/tty'!
(see the end of the mail)

It's the same on both of my kFreeBSD systems. They are both upgraded
today.
(I could test the gpg stuff only on one machine.)


> It is working correctly here, I am using gnupg regulary on this machine.

... then I think, the other problem I have is of the same kind:
I cannot `scp' with inserting my password, while it works perfect when
I use key authentification.


meillo




____

# cat /etc/mtab 

/dev/ad0s1a / ufs rw 0 0
devfs /dev devfs rw 0 0
linprocfs /proc linprocfs rw,noexec,nosuid 0 0

____

# ls /dev

acpi    ad0s1c   bpf0        cuad0.lock  devstat   io       kmem
net1     null   ptyp3  ptyp8   stderr    ttyd0.init  ttyp0  ttyp5
usb
ad0     agpgart  console     cuad1       fd        kbd0     MAKEDEV
net2     pci    ptyp4  ptyq0   stdin     ttyd0.lock  ttyp1  ttyp6
usb0
ad0s1   apm      ctty        cuad1.init  fido      kbd1     mdctl
network  ptyp0  ptyp5  ptyr0   stdout    ttyd1       ttyp2  ttyp7
xpt0
ad0s1a  ata      cuad0       cuad1.lock  full      kbdmux0  mem
nfs4     ptyp1  ptyp6  ptys0   sysmouse  ttyd1.init  ttyp3  ttyp8
zero
ad0s1b  atkbd0   cuad0.init  devctl      geom.ctl  klog     net
nfslock  ptyp2  ptyp7  random  ttyd0     ttyd1.lock  ttyp4  urandom


Reply to: