[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Can't apt-get "x-window-system-core"


I had to remove all references to repositories in the web from the
sources.list 'cause my vmw-machine has no network connection, but I think the 12 install-cdroms should provide a complete system, even without web-connection?

Unfortunately ISO images at
are nearby 1 yer old :-(.

I have installed the base system of Debian/kFreeBSD succesfully (target is a VMware 1.0.1 machine with 12GB IDE, 192MB memory, no notworking).

Would be possible to add networking in some way ?

Alternatively, you can generate URLs on kfreebsd and wget
them on other machine.

1) "apt-get --print-uris update"

It produces lines as
'http://ftp.gnuab.org/debian/dists/unreleased/main/source/Sources.bz2' ftp.gnuab.org_debian_dists_unreleased_main_source_Sources 0

So, wget http://ftp.gnuab.org/debian/dists/unreleased/main/source/Sources.bz2
and put it into

2) "apt-get update"
It should complain about failed downloads, but is should regenerate cache using files downloaded manually in previous step.

3) "apt-get --print-uris dist-upgrade"
It produces lines as
'http://ftp.de.debian.org/debian-kfreebsd/pool-kfreebsd-i386/main/m/mawk/mawk_1.3.3-11_kfreebsd-i386.deb' mawk_1.3.3-11_kfreebsd-i386.deb 80858 87f27717f66f760540d5f747aaf956da

So, wget http://ftp.de.debian.org/debian-kfreebsd/pool-kfreebsd-i386/main/m/mawk/mawk_1.3.3-11_kfreebsd-i386.deb
and put it into

4) "apt-get dist-upgrade"
Finally perform upgrade to current sid.

Of course you have to do fetching by some script like

while read var
        url=`echo $var | cut -f1 -d" " | tr -d \'`
        out=`echo $var | cut -f2 -d" "`
        wget $url -O $out

I tried "x-window-system" and "xserver-xfree86" and more, nothing worked.

Please, try also xserver-xorg.

Hope it helps


Reply to: