[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

warning for kfreebsd-amd64 users


I strongly suggest to kfreebsd-amd64 users to not upgrade
any important packages, especially not sysvinit to version 2.86.ds1-15.

All packages built by binutils_2.17-1 or binutils_2.17-2 are affected.
They simply will not run:
"ELF binary type "0" not known."
"cannot execute binary file"

Binutils for kfreebsd-amd64 needs patch http://glibc-bsd.alioth.debian.org/patches/binutils.diff
applied, especially part

--- binutils-2.16.1cvs20060413.old/bfd/elf.c
+++ binutils-2.16.1cvs20060413/bfd/elf.c
@@ -4853,6 +4853,8 @@
     bfd_big_endian (abfd) ? ELFDATA2MSB : ELFDATA2LSB;
   i_ehdrp->e_ident[EI_VERSION] = bed->s->ev_current;

+  i_ehdrp->e_ident[EI_OSABI] = ELFOSABI_FREEBSD;
   if ((abfd->flags & DYNAMIC) != 0)
     i_ehdrp->e_type = ET_DYN;
   else if ((abfd->flags & EXEC_P) != 0)

Binaries compiled in a wrong way have output of "file"
"init: ELF 64-bit LSB executable, AMD x86-64, version 1 (SYSV), ...",
the right result is "init: ELF 64-bit LSB executable, AMD x86-64, version 1 (FreeBSD), ... "

Hope it helps


Reply to: