[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Self-hosting Debian NetBSD system available

Hmm. Not sure what's going on with Fakeroot there. It worked ok on FreeBSD.  If
you get it working, please send me a patch. I'll merge it, and we can try to
get support for both archs merged in upstream.

On Sun, Feb 03, 2002 at 11:02:22PM +0000, Matthew Garrett wrote:
> I now have a self-hosting Debian NetBSD system. The patch to sysvinit
> seems to have worked wonderfully, though several boot scripts are not
> entirely happy due to commands having different semantics. Networking
> isn't automatically set up yet (the ifupdown source is distributed in some
> weird format allowing the documentation and code to be distributed
> together, as far as I can tell. This would be fine except the package to
> untangle it requires tetex amongst other things. I'll take a look at this
> now), and it doesn't launch any gettys, but I do now have ssh running and
> can log in remotely.
> Fakeroot is compiled, but fails its test suite
> ../scripts/fakeroot -f /tmp/fakeroot-0.4.5/faked -l
> /tmp/fakeroot-0.4.5/.libs/libfakeroot.so.0 -- "touch tmp/foo; install
> tmp/foo tmp/bar; ls -al tmp/bar" | grep "root.*root.*tmp/bar"
> dlsym(open): Undefined symbol "open"
> dlsym(fopen): Undefined symbol "fopen"
> dlsym(freopen): Undefined symbol "freopen"
> dlsym(freopen): Undefined symbol "freopen"
> dlsym(lstat): Undefined symbol "lstat"
> dlsym(stat): Undefined symbol "stat"
> dlsym(fstat): Undefined symbol "fstat"
> dlsym(mknod): Undefined symbol "mknod"
> dlsym(chown): Undefined symbol "chown"
> dlsym(lchown): Undefined symbol "lchown"
> dlsym(fchown): Undefined symbol "fchown"
> dlsym(chmod): Undefined symbol "chmod"
> dlsym(fchmod): Undefined symbol "fchmod"
> dlsym(mkdir): Undefined symbol "mkdir"
> dlsym(unlink): Undefined symbol "unlink"
> dlsym(rmdir): Undefined symbol "rmdir"
> dlsym(remove): Undefined symbol "remove"
> dlsym(rename): Undefined symbol "rename"
> dlsym(getuid): Undefined symbol "getuid"
> dlsym(getgid): Undefined symbol "getgid"
> dlsym(geteuid): Undefined symbol "geteuid"
> dlsym(getegid): Undefined symbol "getegid"
> ../scripts/fakeroot: line 85: 27418 Segmentation fault      (core
> -c "$*"
> make: *** [4] Error 1
> make: Leaving directory `/tmp/fakeroot-0.4.5/test'
> and running it gives me a shell but claims that I'm still me. I'll look
> into this.
> Although it's less useful without fakeroot running, I can provide access
> to this system now for anybody who's interested in developing on it.
> -- 
> Matthew Garrett | mjg59@srcf.ucam.org
> -- 
> To UNSUBSCRIBE, email to debian-bsd-request@lists.debian.org
> with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Reply to: