[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#1007776: authemtication of wireless network after password input fails

Hi Peter, and thanks for your report.

A couple of things: please avoid sending HTML messages in general. And
since you included a large picture (by mailing list configuration
standards), your report was not delivered to our list.

Peter Mueller <petermueller@ro.ru> (2022-03-16):
> I tried to install unofficial (due to various drivers, in particular
> the Intel WiFi network driver) Debian bullseye. During the
> installation, I was asked for the network card, and I chose a wireless
> one: wlp179s0, which is in my case WLAN/Bluetooth Adapter PCIe (WL-PCI
> ASUS PCE-AX3000 BT5.0) Dual-Band (2,4 GHz/5 GHz), Bluetooth-Version
> 5.0.

Over the course of the installation process, did you get any messages
regarding missing firmware? I'm not sure this would explain the issue
you're describing, but that's an easy item to check for…

> I was asked for the WLAN ID, which I provided (the SSID of my router).
> Then I was asked for the type, which I provided as WPA/WPA2 PSK in my
> case (WPA2 for my router). Then I was asked for the WPA-Passphrase,
> which I typed in (WPA2 password for my router). Then a progress bar
> depicting an authentication attempt with the access point appeared.
> For a few minutes the bar continuously made progress  (the messages on
> the fourth console are attached) and finally reached 100%.  Then I saw
> a failure message asking me to verify the WPA-parameters which I
> input.
> I repeated the process several times, with the same result: no network
> during installation. The wireless card itself and the SSID-password
> combination are o.k. because I got connection using Debian live from
> the same installation drive. (Moreover, on a similar machine with the
> same network card the nerwork happily starts with NetworkManager,
> though with ifupdown there is a delay of several minutes at boot; cf.
> https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=993826).  Any
> bugfix? Any help?

The live test is quite useful, thanks for mentioning it. I'm wondering
whether this could be due to missing crypto modules inside our image,
which I've seen to be the reason for failure to associate from the
installer, while the installed system was fine. Any chance you could
start the live image again, save the output of `lsmod`, and attach it
here, using reply-all?

Cyril Brulebois (kibi@debian.org)            <https://debamax.com/>
D-I release manager -- Release team member -- Freelance Consultant

Attachment: signature.asc
Description: PGP signature

Reply to: