[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#1000239: marked as done (Rescue system won't find root partition, but insists on /usr)

Your message dated Mon, 06 Dec 2021 01:03:24 +0000
with message-id <E1mu2Pc-000H7t-Mc@fasolo.debian.org>
and subject line Bug#1000239: fixed in rescue 1.86
has caused the Debian Bug report #1000239,
regarding Rescue system won't find root partition, but insists on /usr
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact owner@bugs.debian.org

1000239: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=1000239
Debian Bug Tracking System
Contact owner@bugs.debian.org with problems
--- Begin Message ---
Package: debian-installer
Version: 20210731+deb11u1_amd64

Errors, "No suitable shell found on /dev/sda1"

Cycling through every partition results in what should be /usr being selected as the root partition. This is useless for a rescue syatem, because there some commands missing.

I tried to mount the root partition on a mount point I made inside the installer, but there was a problem with permissions. I can't perfectly remember. I tried 'sudo', but it isn't available in the installer. 

I was attempting to reinstall grub, to get the system to boot. I have also used the rescue syatem to change a lost password. It appears this bug may apply only to a gpt partition table and a fat32 boot partition (efi?). 

I've had this same problem with 2 systems, a lappy and a desktop. I can always work around it. I don't understand what could be going on, for lack of experience. I've only been a Debian user since Woody was in testing. 

It's easy to reproduce. Do an expert install with defaults, but partition with gpt. Boot the system with the install media, launch a rescue shell, and try to open a root shell. An incorrect device should be identified as '/'. Perhaps this occurs only when /usr is on a different partition that '/'. 

But it is bothersome, because it essentially removes 90% of the functionality from the rescue system. The install media used to be my goto for rescue. But now I've found this very annoying problem. If you require more info, I can boot the dvd again and record exact errors.

I'm on my tablet, so I don't have access to reportbug. Thanks for the help! You guys are the best!

--- End Message ---
--- Begin Message ---
Source: rescue
Source-Version: 1.86
Done: Steve McIntyre <93sam@debian.org>

We believe that the bug you reported is fixed in the latest version of
rescue, which is due to be installed in the Debian FTP archive.

A summary of the changes between this version and the previous one is

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 1000239@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
Steve McIntyre <93sam@debian.org> (supplier of updated rescue package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@ftp-master.debian.org)

Hash: SHA256

Format: 1.8
Date: Mon, 06 Dec 2021 00:19:47 +0000
Source: rescue
Architecture: source
Version: 1.86
Distribution: unstable
Urgency: medium
Maintainer: Debian Install System Team <debian-boot@lists.debian.org>
Changed-By: Steve McIntyre <93sam@debian.org>
Closes: 1000239
 rescue (1.86) unstable; urgency=medium
   * Team upload
   [ Steve McIntyre ]
   * More tweaks to the code for mounting extra filesystems
     + Rather than chroot to call mount, parse /target/etc/fstab to
       find the filesystem device for the mount point, then mount
       things directly from the d-i environment. This is needed in case
       the mount program in /target won't work (e.g. if it's for /usr
       and it depends on libraries on /usr).
     + Also prompt the user about mounting a separate /usr filesystem
       if it looks like it's needed.
     + Closes: #1000239
 4df9f3810c2371efbed2571522ea9c84a7ae9f9a 1667 rescue_1.86.dsc
 02880bc2f10385f3b2dd9389a5023512d503d032 143996 rescue_1.86.tar.xz
 a1249ea77565d527865f5915b6aeec9436463419 5693 rescue_1.86_source.buildinfo
 a70cd4792fa25999fcbf1b73b3e3d4967d6c9a93abdba6eb3445edb59bb6b924 1667 rescue_1.86.dsc
 3f4f0aa98cb879274b6c92da3361c0dd0bad32badea07a223a0316bea36df0d9 143996 rescue_1.86.tar.xz
 d758c2a53c08cd6c757563f7fad017c57d7577b25f1237b98a6df6a895bf9f4e 5693 rescue_1.86_source.buildinfo
 549649d4795845ca638f59b8df8c011c 1667 debian-installer optional rescue_1.86.dsc
 407c6d239a057917ab1902f80a9d9cb3 143996 debian-installer optional rescue_1.86.tar.xz
 40e3a0cdcc2438495b512215288e3282 5693 debian-installer optional rescue_1.86_source.buildinfo



--- End Message ---

Reply to: