[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#549703: marked as done ([i386][lenny] grub guesses wrong location for MBR?)

Your message dated Sat, 30 Oct 2021 18:30:54 +0200
with message-id <[🔎] 20211030183054.906cb9aac22395d0f32a6a86@mailbox.org>
and subject line Mass-closing old grub-installer bugs
has caused the Debian Bug report #549703,
regarding [i386][lenny] grub guesses wrong location for MBR?
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact owner@bugs.debian.org

549703: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=549703
Debian Bug Tracking System
Contact owner@bugs.debian.org with problems
--- Begin Message ---
Package: installation-reports
Severity: normal

*** Please type your report below this line ***

-- Package-specific info:

Boot method: USB key built with netbootin
Image version: Lenny Netinstall
5.0.3 "Lenny" Official i386 NETINST Binary-1
Date: 2009-10-05T10:00 GMT

Machine: Samsung NC10 Netbook
Partitions: <df -Tl will do; the raw partition table is preferred>

Filesystem    Type   1K-blocks      Used Available Use% Mounted on
/dev/sdb1     ext3     1921156    136428   1687136   8% /
tmpfs        tmpfs      513376         0    513376   0% /lib/init/rw
udev         tmpfs       10240       768      9472   8% /dev
tmpfs        tmpfs      513376         0    513376   0% /dev/shm
              ext3   131735028    192336 124850852   1% /home
              ext3     1919048     35660   1785904   2% /opt
              ext3     9611492    876764   8246488  10% /usr
              ext3     3842104    173560   3473372   5% /var

Base System Installation Checklist:
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

Initial boot:           [O]
Detect network card:    [O]
Configure network:      [E]
Detect CD:              [ ]
Load installer modules: [O]
Detect hard drives:     [O]
Partition hard drives:  [O]
Install base system:    [O]
Clock/timezone setup:   [O]
User/password setup:    [O]
Install tasks:          [O]
Install boot loader:    [E]
Overall install:        [O]


netbootin is a very handy tool.

The wireless card (atheros, pciid 168c:001c) is detected and the ath5h_pci module loads. However it is unable to associate.
Neither could I scan for access points with 'iwlist scan' or
'iwlist ap'.
The wired ethernet worked fine so I used that to complete the install.

No cdrom in the machine. Detection of this appears to have worked.

The system came with three windows partitions which I deleted.

The main problem I had was boot loader installation.
I used the default of grub (did not lower priority to check other options). When prompted for which device to install grub on, I accepted
the default value offered, '(hd0)'. This turned out to be a mistake.
I followed the prompts about rebooting the system, pulled the USB key
when the system was just starting to do its power-up sequence, and
was rewarded with
  Operating System Not Found
from the BIOS.

The problem turned out to be that grub had guessed wrongly which partition it should install to. The grub config was actually correct,
referring to (hd1,0) and using the correct UUID in the boot config.
/etc/fstab was also consistent, referring to the swap partition as being
on /dev/sdb2. Nevertheless it seems there is an inconsistency here.
If I told grub no, install to (hd1), then the correct MBR would have been updated (the one on the internal hard disk), but it's unclear if
the system would have been bootable, because of the (hd1,0) reference
in the config file.

The two disks were probably enumerated in the order
  usb stick
  hard disk
because I had to change the boot priority order in the BIOS to get
the system to boot from the USB stick.

To avoid this kind of issue, it seems the grub installation process needs to give the user some more information about what disks it sees and ask for guidance about which to install the bootloader on.
Partman handles this pretty well now, and I'd like to see grub do
as good a job, instead of (what appears to be) just guessing.
Isn't it reasonably straightforward to iterate through device.map
and pull things out of /dev/disk/by-id; displaying a table like
 [*] hd0 /dev/sda usb-USBDisk_RunDisk_0705261622141-0:0
 [ ] hd1 /dev/sdb ata-SAMSUNG_HM169HI_S1WWJF0S395641
and asking the user to select the right disk?

To avoid even listing the USB stick, and thus avoid having to ask the
question at all in most cases, it seems it should be possible to check for some file specific to the installer, but I can see the dangers in this. I thought the cd-probing code etc already determined which filesystem contains the installer?

Another option is to prompt with a default choice, as now, but give the user a 'go back' option which would lower the curent question priority.
This would allow display of the 'select from the list of possible disks'
question at that time.

I could not see how to start a shell in order to check that grub-install
had got the disk name right. I tried <alt><f2>, but this seems not to work
in the GTK installer? I don't recall trying <ctrl><alt><f2>.

To recover, I did this:
 * power off
 * insert usb key
 * power up
 * I see a grub menu now - wait for it to boot. system boots perfectly.
 * login
 * noticed /dev/sda1 was not mounted, 'df /' pointed to /dev/sdb1
   (the USB stick)
 * mount /dev/sda1 /mnt
 * sed -ie 's/hd1,0/hd0,0/' /boot/grub/menu.lst
 * tune2fs -l /dev/sda1 |grep UUID (check it matches UUID in menu.lst)
 * grub-install hd0
 * reboot
 * pull the USB stick when system starts power-up cycle

But wait - what about /mnt/boot/grub/menu.list? Shouldn't I have been
editing that? Well, somehow the filesystem at /mnt and at / were the
same thing. I checked the inodes of /mnt/boot and /boot (and /mnt, /)
to be sure, output below. Presumably this is some pivot-root magic?

One last point. After recovering the system I had to edit /etc/fstab
to mount the swap partition by uuid. Is there some reason this is not
done by default ?

Thanks for your work on the installer,

PS 'script' typescript regarding the /mnt | / strangeness

Script started on Mon 05 Oct 2009 21:26:50 EST
rutherford:/boot/grub# df
Filesystem           1K-blocks      Used Available Use% Mounted on
/dev/sdb1              1921156    124560   1699004   7% /
tmpfs                   513376         0    513376   0% /lib/init/rw
udev                     10240       788      9452   8% /dev
tmpfs                   513376         0    513376   0% /dev/shm
                     131735028    192204 124850984   1% /home
                       1919048     35660   1785904   2% /opt
                       9611492    398272   8724980   5% /usr
                       3842104    273004   3373928   8% /var
/dev/sda1              1921156    124560   1699004   7% /mnt

rutherford:/boot/grub# mount -v
/dev/sdb1 on / type ext3 (rw,errors=remount-ro)
tmpfs on /lib/init/rw type tmpfs (rw,nosuid,mode=0755)
proc on /proc type proc (rw,noexec,nosuid,nodev)
sysfs on /sys type sysfs (rw,noexec,nosuid,nodev)
procbususb on /proc/bus/usb type usbfs (rw)
udev on /dev type tmpfs (rw,mode=0755)
tmpfs on /dev/shm type tmpfs (rw,nosuid,nodev)
devpts on /dev/pts type devpts (rw,noexec,nosuid,gid=5,mode=620)
/dev/mapper/rutherford-home on /home type ext3 (rw)
/dev/mapper/rutherford-opt on /opt type ext3 (rw)
/dev/mapper/rutherford-usr on /usr type ext3 (rw)
/dev/mapper/rutherford-var on /var type ext3 (rw)
/dev/sda1 on /mnt type ext3 (rw)

rutherford:/boot/grub# stat /mnt/boot
  File: `/mnt/boot'
  Size: 4096      	Blocks: 8          IO Block: 4096   directory
Device: 801h/2049d	Inode: 40722       Links: 3
Access: (0755/drwxr-xr-x)  Uid: (    0/    root)   Gid: (    0/    root)
Access: 2009-10-05 21:25:33.000000000 +1100
Modify: 2009-10-05 21:10:11.000000000 +1100
Change: 2009-10-05 21:10:11.000000000 +1100

rutherford:/boot/grub# stat /boot
  File: `/boot'
  Size: 4096      	Blocks: 8          IO Block: 4096   directory
Device: 801h/2049d	Inode: 40722       Links: 3
Access: (0755/drwxr-xr-x)  Uid: (    0/    root)   Gid: (    0/    root)
Access: 2009-10-05 21:25:33.000000000 +1100
Modify: 2009-10-05 21:10:11.000000000 +1100
Change: 2009-10-05 21:10:11.000000000 +1100

rutherford:/boot/grub# stat /
  File: `/'
  Size: 4096      	Blocks: 8          IO Block: 4096   directory
Device: 801h/2049d	Inode: 2           Links: 21
Access: (0755/drwxr-xr-x)  Uid: (    0/    root)   Gid: (    0/    root)
Access: 2009-10-05 21:25:32.000000000 +1100
Modify: 2009-10-05 21:19:08.000000000 +1100
Change: 2009-10-05 21:19:08.000000000 +1100

rutherford:/boot/grub# stat /mnt/
  File: `/mnt/'
  Size: 4096      	Blocks: 8          IO Block: 4096   directory
Device: 801h/2049d	Inode: 2           Links: 21
Access: (0755/drwxr-xr-x)  Uid: (    0/    root)   Gid: (    0/    root)
Access: 2009-10-05 21:25:32.000000000 +1100
Modify: 2009-10-05 21:19:08.000000000 +1100
Change: 2009-10-05 21:19:08.000000000 +1100
rutherford:/boot/grub# exit

Script done on Mon 05 Oct 2009 21:27:56 EST


Please make sure that the hardware-summary log file, and any other
installation logs that you think would be useful are attached to this
report. Please compress large files using gzip.

Once you have filled out this report, mail it to submit@bugs.debian.org.

Installer lsb-release:
DISTRIB_DESCRIPTION="Debian GNU/Linux installer"
DISTRIB_RELEASE="5.0 (lenny) - installer build 20090123lenny4"

Installer hardware-summary:
umame -a: Linux marsfield-guest-131 2.6.26-2-486 #1 Wed Aug 19 05:40:02 UTC 2009 i686 unknown
lspci -knn: 00:00.0 Host bridge [0600]: Intel Corporation Mobile 945GME Express Memory Controller Hub [8086:27ac] (rev 03)
lspci -knn: 00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile 945GME Express Integrated Graphics Controller [8086:27ae] (rev 03)
lspci -knn: 00:02.1 Display controller [0380]: Intel Corporation Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller [8086:27a6] (rev 03)
lspci -knn: 00:1b.0 Audio device [0403]: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller [8086:27d8] (rev 02)
lspci -knn: 00:1c.0 PCI bridge [0604]: Intel Corporation 82801G (ICH7 Family) PCI Express Port 1 [8086:27d0] (rev 02)
lspci -knn: 	Kernel driver in use: pcieport-driver
lspci -knn: 00:1c.2 PCI bridge [0604]: Intel Corporation 82801G (ICH7 Family) PCI Express Port 3 [8086:27d4] (rev 02)
lspci -knn: 	Kernel driver in use: pcieport-driver
lspci -knn: 00:1d.0 USB Controller [0c03]: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #1 [8086:27c8] (rev 02)
lspci -knn: 	Kernel driver in use: uhci_hcd
lspci -knn: 	Kernel modules: uhci-hcd
lspci -knn: 00:1d.1 USB Controller [0c03]: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #2 [8086:27c9] (rev 02)
lspci -knn: 	Kernel driver in use: uhci_hcd
lspci -knn: 	Kernel modules: uhci-hcd
lspci -knn: 00:1d.2 USB Controller [0c03]: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #3 [8086:27ca] (rev 02)
lspci -knn: 	Kernel driver in use: uhci_hcd
lspci -knn: 	Kernel modules: uhci-hcd
lspci -knn: 00:1d.3 USB Controller [0c03]: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #4 [8086:27cb] (rev 02)
lspci -knn: 	Kernel driver in use: uhci_hcd
lspci -knn: 	Kernel modules: uhci-hcd
lspci -knn: 00:1d.7 USB Controller [0c03]: Intel Corporation 82801G (ICH7 Family) USB2 EHCI Controller [8086:27cc] (rev 02)
lspci -knn: 	Kernel driver in use: ehci_hcd
lspci -knn: 	Kernel modules: ehci-hcd
lspci -knn: 00:1e.0 PCI bridge [0604]: Intel Corporation 82801 Mobile PCI Bridge [8086:2448] (rev e2)
lspci -knn: 00:1f.0 ISA bridge [0601]: Intel Corporation 82801GBM (ICH7-M) LPC Interface Bridge [8086:27b9] (rev 02)
lspci -knn: 00:1f.2 IDE interface [0101]: Intel Corporation 82801GBM/GHM (ICH7 Family) SATA IDE Controller [8086:27c4] (rev 02)
lspci -knn: 	Kernel driver in use: ata_piix
lspci -knn: 	Kernel modules: ata_piix
lspci -knn: 00:1f.3 SMBus [0c05]: Intel Corporation 82801G (ICH7 Family) SMBus Controller [8086:27da] (rev 02)
lspci -knn: 02:00.0 Ethernet controller [0200]: Atheros Communications Inc. AR242x 802.11abg Wireless PCI Express Adapter [168c:001c] (rev 01)
lspci -knn: 	Kernel driver in use: ath5k_pci
lspci -knn: 	Kernel modules: ath5k
lspci -knn: 03:00.0 Ethernet controller [0200]: Marvell Technology Group Ltd. 88E8040 PCI-E Fast Ethernet Controller [11ab:4354] (rev 13)
lspci -knn: 	Kernel driver in use: sky2
lspci -knn: 	Kernel modules: sky2
lsmod: Module                  Size  Used by
lsmod: nls_utf8 1664 2 lsmod: nls_cp437 5504 0 lsmod: ufs 63620 0 lsmod: qnx4 7684 0 lsmod: ntfs 180544 0 lsmod: dm_mod 45384 10 lsmod: md_mod 65940 0 lsmod: xfs 446836 0 lsmod: reiserfs 187264 0 lsmod: jfs 148316 0 lsmod: ext3 103688 5 lsmod: jbd 35092 1 ext3 lsmod: vfat 8832 0 lsmod: fat 39964 1 vfat
lsmod: nls_base                6528  6 nls_utf8,nls_cp437,ntfs,jfs,vfat,fat
lsmod: ext2 52744 0 lsmod: mbcache 6656 2 ext3,ext2
lsmod: ide_generic             2432  0 [permanent]
lsmod: ide_core               94760  1 ide_generic
lsmod: ata_piix 14212 3 lsmod: libata 141216 1 ata_piix
lsmod: dock                    8076  1 libata
lsmod: rsrc_nonstatic 9344 0 lsmod: pcmcia_core 31760 1 rsrc_nonstatic lsmod: sd_mod 21904 4 lsmod: usb_storage 76352 0 lsmod: scsi_mod 129548 3 libata,sd_mod,usb_storage lsmod: evdev 7680 2 lsmod: arc4 1792 2 lsmod: ecb 2560 2 lsmod: crypto_blkcipher 14596 1 ecb lsmod: ehci_hcd 28300 0 lsmod: uhci_hcd 18320 0 lsmod: usbcore 117104 4 usb_storage,ehci_hcd,uhci_hcd lsmod: sky2 36740 0 lsmod: ath5k 87296 0 lsmod: mac80211 137116 1 ath5k
lsmod: cfg80211               21256  2 ath5k,mac80211
lsmod: fan 4100 0 lsmod: thermal 15004 0 lsmod: processor 27824 2 thermal
lsmod: thermal_sys            10656  3 fan,thermal,processor
lsmod: psmouse 31888 0 df: Filesystem 1k-blocks Used Available Use% Mounted on
df: tmpfs                   453144       696    452448   0% /dev
df: /dev/sdb1              1921156    124540   1699024   7% /target
df: /dev/mapper/rutherford-home
df:                      131735028    192204 124850984   0% /target/home
df: /dev/mapper/rutherford-opt
df:                        1919048     35660   1785904   2% /target/opt
df: /dev/mapper/rutherford-usr
df:                        9611492    398272   8724980   4% /target/usr
df: /dev/mapper/rutherford-var
df:                        3842104    269916   3377016   7% /target/var
df: /dev/sdb1              1921156    124540   1699024   7% /dev/.static/dev
df: tmpfs                   453144       696    452448   0% /target/dev
free:               total         used         free       shared      buffers
free:   Mem:       906292       679716       226576            0        42820
free:  Swap:      3903784            0      3903784
free: Total:      4810076       679716      4130360
/proc/cmdline: initrd=/ubninit video=vesa:ywrap,mtrr vga=788 installgui BOOT_IMAGE=/ubnkern /proc/cpuinfo: processor : 0
/proc/cpuinfo: vendor_id	: GenuineIntel
/proc/cpuinfo: cpu family	: 6
/proc/cpuinfo: model		: 28
/proc/cpuinfo: model name	: Intel(R) Atom(TM) CPU N270   @ 1.60GHz
/proc/cpuinfo: stepping	: 2
/proc/cpuinfo: cpu MHz		: 1596.028
/proc/cpuinfo: cache size	: 512 KB
/proc/cpuinfo: fdiv_bug	: no
/proc/cpuinfo: hlt_bug		: no
/proc/cpuinfo: f00f_bug	: no
/proc/cpuinfo: coma_bug	: no
/proc/cpuinfo: fpu		: yes
/proc/cpuinfo: fpu_exception	: yes
/proc/cpuinfo: cpuid level	: 10
/proc/cpuinfo: wp		: yes
/proc/cpuinfo: flags		: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe constant_tsc arch_perfmon pebs bts pni monitor ds_cpl est tm2 ssse3 xtpr lahf_lm
/proc/cpuinfo: bogomips	: 3196.58
/proc/cpuinfo: clflush size	: 64
/proc/cpuinfo: power management:
/proc/cpuinfo: /proc/ioports: 0000-001f : dma1
/proc/ioports: 0020-0021 : pic1
/proc/ioports: 0040-0043 : timer0
/proc/ioports: 0050-0053 : timer1
/proc/ioports: 0060-0060 : keyboard
/proc/ioports: 0064-0064 : keyboard
/proc/ioports: 0070-0077 : rtc0
/proc/ioports: 0080-008f : dma page reg
/proc/ioports: 00a0-00a1 : pic2
/proc/ioports: 00c0-00df : dma2
/proc/ioports: 00f0-00ff : fpu
/proc/ioports: 0170-0177 : 0000:00:1f.2
/proc/ioports:   0170-0177 : ata_piix
/proc/ioports: 01f0-01f7 : 0000:00:1f.2
/proc/ioports:   01f0-01f7 : ata_piix
/proc/ioports: 0376-0376 : 0000:00:1f.2
/proc/ioports:   0376-0376 : ata_piix
/proc/ioports: 03c0-03df : vesafb
/proc/ioports: 03f6-03f6 : 0000:00:1f.2
/proc/ioports:   03f6-03f6 : ata_piix
/proc/ioports: 0680-069f : pnp 00:06
/proc/ioports: 06a0-06af : pnp 00:07
/proc/ioports: 06b0-06ff : pnp 00:07
/proc/ioports: 0800-080f : pnp 00:06
/proc/ioports: 0cf8-0cff : PCI conf1
/proc/ioports: 1000-107f : 0000:00:1f.0
/proc/ioports:   1000-107f : pnp 00:06
/proc/ioports:     1000-1003 : ACPI PM1a_EVT_BLK
/proc/ioports:     1004-1005 : ACPI PM1a_CNT_BLK
/proc/ioports:     1008-100b : ACPI PM_TMR
/proc/ioports:     1010-1015 : ACPI CPU throttle
/proc/ioports:     1020-1020 : ACPI PM2_CNT_BLK
/proc/ioports:     1028-102f : ACPI GPE0_BLK
/proc/ioports: 1180-11bf : 0000:00:1f.0
/proc/ioports:   1180-11bf : pnp 00:06
/proc/ioports: 1640-164f : pnp 00:06
/proc/ioports: 1800-1807 : 0000:00:02.0
/proc/ioports: 1810-181f : 0000:00:1f.2
/proc/ioports:   1810-181f : ata_piix
/proc/ioports: 1820-183f : 0000:00:1d.0
/proc/ioports:   1820-183f : uhci_hcd
/proc/ioports: 1840-185f : 0000:00:1d.1
/proc/ioports:   1840-185f : uhci_hcd
/proc/ioports: 1860-187f : 0000:00:1d.2
/proc/ioports:   1860-187f : uhci_hcd
/proc/ioports: 1880-189f : 0000:00:1d.3
/proc/ioports:   1880-189f : uhci_hcd
/proc/ioports: 18a0-18bf : 0000:00:1f.3
/proc/ioports: 2000-2fff : PCI Bus 0000:03
/proc/ioports:   2000-20ff : 0000:03:00.0
/proc/ioports:     2000-20ff : sky2
/proc/iomem: 00000000-0009f7ff : System RAM
/proc/iomem: 0009f800-0009ffff : reserved
/proc/iomem: 000a0000-000bffff : Video RAM area
/proc/iomem: 000c0000-000c7fff : Video ROM
/proc/iomem: 000f0000-000fffff : System ROM
/proc/iomem: 00100000-3f6cffff : System RAM
/proc/iomem:   00100000-002a80a0 : Kernel code
/proc/iomem:   002a80a1-00361fff : Kernel data
/proc/iomem:   003b4000-0040dbd7 : Kernel bss
/proc/iomem: 3f6d0000-3f6e1fff : ACPI Tables
/proc/iomem: 3f6e2000-3f6e2fff : ACPI Non-volatile Storage
/proc/iomem: 3f6e3000-3fffffff : reserved
/proc/iomem: d0000000-dfffffff : 0000:00:02.0
/proc/iomem:   d0000000-d07affff : vesafb
/proc/iomem: e0000000-efffffff : PCI MMCONFIG 0
/proc/iomem:   e0000000-efffffff : reserved
/proc/iomem: f0000000-f007ffff : 0000:00:02.0
/proc/iomem: f0080000-f00fffff : 0000:00:02.1
/proc/iomem: f0100000-f01fffff : PCI Bus 0000:02
/proc/iomem:   f0100000-f010ffff : 0000:02:00.0
/proc/iomem:     f0100000-f010ffff : ath5k
/proc/iomem: f0200000-f02fffff : PCI Bus 0000:03
/proc/iomem:   f0200000-f0203fff : 0000:03:00.0
/proc/iomem:     f0200000-f0203fff : sky2
/proc/iomem: f0300000-f033ffff : 0000:00:02.0
/proc/iomem: f0340000-f0343fff : 0000:00:1b.0
/proc/iomem: f0544000-f05443ff : 0000:00:1d.7
/proc/iomem:   f0544000-f05443ff : ehci_hcd
/proc/iomem: fec00000-fec0ffff : reserved
/proc/iomem: fed00000-fed003ff : HPET 0
/proc/iomem:   fed00000-fed003ff : reserved
/proc/iomem: fed14000-fed19fff : reserved
/proc/iomem: fed1c000-fed8ffff : reserved
/proc/iomem: fee00000-fee00fff : reserved
/proc/iomem: ff000000-ffffffff : reserved
/proc/interrupts: CPU0 /proc/interrupts: 0: 76166 IO-APIC-edge timer
/proc/interrupts:   1:       1745   IO-APIC-edge      i8042
/proc/interrupts:   8:          3   IO-APIC-edge      rtc0
/proc/interrupts:   9:         42   IO-APIC-fasteoi   acpi
/proc/interrupts:  12:      20286   IO-APIC-edge      i8042
/proc/interrupts:  14:      45645   IO-APIC-edge      ata_piix
/proc/interrupts:  15:          0   IO-APIC-edge      ata_piix
/proc/interrupts:  16:         11   IO-APIC-fasteoi   ath, uhci_hcd:usb4
/proc/interrupts:  18:          0   IO-APIC-fasteoi   uhci_hcd:usb3
/proc/interrupts:  19:         36   IO-APIC-fasteoi   uhci_hcd:usb2
/proc/interrupts:  23:      10659   IO-APIC-fasteoi   uhci_hcd:usb1, ehci_hcd:usb5
/proc/interrupts: 221:      98610   PCI-MSI-edge      eth0
/proc/interrupts: NMI:          0   Non-maskable interrupts
/proc/interrupts: LOC:     105652   Local timer interrupts
/proc/interrupts: TRM:          0   Thermal event interrupts
/proc/interrupts: SPU:          0   Spurious interrupts
/proc/interrupts: ERR:          0
/proc/interrupts: MIS:          0
/proc/meminfo: MemTotal:       906292 kB
/proc/meminfo: MemFree:        226528 kB
/proc/meminfo: Buffers:         42820 kB
/proc/meminfo: Cached:         567736 kB
/proc/meminfo: SwapCached:          0 kB
/proc/meminfo: Active:         192616 kB
/proc/meminfo: Inactive:       438044 kB
/proc/meminfo: SwapTotal:     3903784 kB
/proc/meminfo: SwapFree:      3903784 kB
/proc/meminfo: Dirty:            1248 kB
/proc/meminfo: Writeback:           0 kB
/proc/meminfo: AnonPages:       20128 kB
/proc/meminfo: Mapped:           7504 kB
/proc/meminfo: Slab:            37248 kB
/proc/meminfo: SReclaimable:    31820 kB
/proc/meminfo: SUnreclaim:       5428 kB
/proc/meminfo: PageTables:        324 kB
/proc/meminfo: NFS_Unstable:        0 kB
/proc/meminfo: Bounce:              0 kB
/proc/meminfo: WritebackTmp:        0 kB
/proc/meminfo: CommitLimit:   4356928 kB
/proc/meminfo: Committed_AS:    72848 kB
/proc/meminfo: VmallocTotal:   122564 kB
/proc/meminfo: VmallocUsed:     10944 kB
/proc/meminfo: VmallocChunk:   111256 kB
/proc/meminfo: HugePages_Total:     0
/proc/meminfo: HugePages_Free:      0
/proc/meminfo: HugePages_Rsvd:      0
/proc/meminfo: HugePages_Surp:      0
/proc/meminfo: Hugepagesize:     4096 kB
/proc/bus/input/devices: I: Bus=0011 Vendor=0001 Product=0001 Version=ab41
/proc/bus/input/devices: N: Name="AT Translated Set 2 keyboard"
/proc/bus/input/devices: P: Phys=isa0060/serio0/input0
/proc/bus/input/devices: S: Sysfs=/class/input/input0
/proc/bus/input/devices: U: Uniq=
/proc/bus/input/devices: H: Handlers=kbd event0 /proc/bus/input/devices: B: EV=120013
/proc/bus/input/devices: B: KEY=4 2000000 3803078 f800d001 feffffdf ffefffff ffffffff fffffffe
/proc/bus/input/devices: B: MSC=10
/proc/bus/input/devices: B: LED=7
/proc/bus/input/devices: /proc/bus/input/devices: I: Bus=0011 Vendor=0002 Product=0007 Version=01b1
/proc/bus/input/devices: N: Name="SynPS/2 Synaptics TouchPad"
/proc/bus/input/devices: P: Phys=isa0060/serio4/input0
/proc/bus/input/devices: S: Sysfs=/class/input/input1
/proc/bus/input/devices: U: Uniq=
/proc/bus/input/devices: H: Handlers=mouse0 event1 /proc/bus/input/devices: B: EV=b
/proc/bus/input/devices: B: KEY=6420 0 70000 0 0 0 0 0 0 0 0
/proc/bus/input/devices: B: ABS=11000003
/proc/bus/input/devices: /proc/fb: 0 VESA VGA
/etc/directfbrc: quiet
/etc/directfbrc: no-hardware
/etc/directfbrc: bg-color=ffdcdad5
/etc/directfbrc: screenshot-dir=/var/log
/etc/directfbrc: #disable-module=linux_input
/etc/directfbrc: #disable-module=keyboard
/etc/directfbrc: disable-module=ps2mouse

-- System Information:
Debian Release: 5.0.3
  APT prefers stable
  APT policy: (500, 'stable')
Architecture: i386 (i686)

Kernel: Linux 2.6.26-2-686 (SMP w/2 CPU cores)
Locale: LANG=en_AU.UTF-8, LC_CTYPE=en_AU.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

--- End Message ---
--- Begin Message ---

similar to the installation-reports bugs, I'm closing the grub-installer reports 

These are reports for Debian 4 / 6 / 7 / 9 where grub-installer fails (for 
various reasons).

There have been numerous changes/improvements on this topics in the past, and 
also because of the age of the reports we should consider these problems as 
being fixed (or it is even reported in the bugs that they are fixed).
They are most likely of no use anymore for recent releases.

If you know, that the issue you reported (and gets closed here) is still 
existing in recent installation images, please file a new report for that with 
up-to-date details!

Thank you for filing these bug reports, they have been very useful at the time 
they were filed!



Holger Wansing <hwansing@mailbox.org>
PGP-Fingerprint: 496A C6E8 1442 4B34 8508  3529 59F1 87CA 156E B076

--- End Message ---

Reply to: