[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#995605: BTRFS on root + EXT2 on /boot fails to initialize on ARM A20 OLinuXino LIME 2

Package: installation-reports

Boot method: https://wiki.debian.org/InstallingDebianOn/Allwinner#Installing_from_an_SD_card_image
Image version: https://deb.debian.org/debian/dists/stable/main/installer-armhf/current/images/netboot/SD-card-images/ using firmware.A20-OLinuXino-Lime2.img.gz
Date: 2021-10-01

Machine: Olimex A20 OLinuXino Lime 2
Processor: A20 Cortex-A7 dual-core ARM Cortex-A7 CPU and dual-core Mali 400 GPU
Memory: 1GB
Partitions: /dev/<disk>2 btrfs 31G / + /dev/<disk>1 ext2 128M /boot

Base System Installation Checklist:
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

Initial boot:           [E]
Detect network card:    [O]
Configure network:      [O]
Detect media:           [O]
Load installer modules: [O]
Detect hard drives:     [O]
Partition hard drives:  [O]
Install base system:    [O]
Clock/timezone setup:   [O]
User/password setup:    [O]
Install tasks:          [O]
Install boot loader:    [O]
Overall install:        [E]


I'm trying to setup a fresh Debian with a BTRFS root and an EXT2 /boot
with the netinstall disk on an OLinuXino Lime 2 (an A20 based SBC).

When I install without BTRFS, but 2 EXT2 partitions, installation works
flawlessly, when I try with BTRFS I only obtain a black screen with a
blinking _ after the initial uboot screen.

I know btrfs + ext2 works on my SBC because I also have a Freedombox
(Debian pure blend) installed on other device of the same specs, the
installation proccedure is different though (one just copies the img to
an sd card).

The unique difference I've found between stock Debian and a working
FreedomBox is on the size of the initrd.img, and that the Debian
installer creates a subvolume for root. I can't find any difference in
the configuration for the image generation on /etc/initramfs-tools

I've tried recreating the initramfs appending btrfs to
/etc/initramfs-tools/modules but I get the same result.

What could I do to identify the problem?

Reply to: